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Overview

Agisoft Metashape is a stand-al one software product that performs photogrammetric processing of digital
images (aerial and close-range photography, satellite imagery) and generates 3D spatial data to be used
in GIS applications, cultural heritage documentation, and visual effects production as well as for indirect
measurements of objects of various scales.

The software alows to process images from RGB, thermal or multispectral cameras, including multi-
camerasystems, into the spatial information in the form of dense point clouds, textured polygonal models,
georeferenced true orthomosaics and DSMs/DTMs. Further post-processing enables to eliminate shadows
and texture artifacts from the models, calculate vegetation indices and extract information for farming
equipment action maps, automatically classify dense point clouds, etc. Metashapeis capabl e of processing
of 50 000+ photos across alocal cluster, thanksto distributed processing functionality. Alternatively, the
project can be sent to the cloud to minimize hardware investment, with all the processing options being still
available. Wisely implemented digital photogrammetry technique enforced with computer vision methods
results in smart automated processing system that, on the one hand, can be managed by a new-comer
in the field of photogrammetry, yet, on the other hand, has a lot to offer to a specialist who can benefit
from advanced features like stereoscopic mode and have complete control over the results accuracy, with
detailed report being generated at the end of processing.

How it works

Typical tasks for a photogrammetry processing project in Metashape are to build a 3D surface and an
orthomosaic. Imagery data processing procedure with Agisoft Metashape consists of three main steps.

1. The first step is called alignment. It includes aeria triangulation (AT) and bundle block adjustment
(BBA). At this stage Metashape searches for feature points on the images and matches them across
images into tie points. The program aso finds the position of the camera for each image and
refines camera calibration parameters (estimates internal (10) and external (EO) camera orientation
parameters).

The results of these procedures are visualized in the form of a tie point cloud and a set of camera
positions. The tie point cloud represents the results of image alignment and will not be directly used
in further processing (except for the sparse point cloud based surface reconstruction method, which is
suitable only for quick estimates, e.g., of completeness of adata set). But thetie point cloud is necessary
for the determination of depth maps (based on the sparse cloud selected stereo pairs). However it can
be exported for further usage in external programs. For instance, atie point cloud model can be used
in a 3D editor as a reference. On the contrary, the set of camera positions is required for further 3D
surface reconstruction by Metashape.

2. The second step is generation of a surface in 3D (mesh) and/or 2.5D (DEM). Polygonal model (mesh)
can be textured for photorealistic digital representation of the object/scene and exported in numerous
formats compatible with post-processing software, both for CAD and 3D-modeling workflows.

For city-scale projectsto provide for fast model visualization response and allow for smooth navigation
across the whole scene, Metashape enables to generate tiled models. Such hierarchical representation
preserves original resolution of the images applied to the model as a texture and is compatible with
stand-al one and web-based viewers.

Dense point cloud can be built by Metashape based on the estimated camera positions and images
themselves (dense stereo matching). Generated photogrammetric point cloud can be merged with
LIDAR data or automatically divided into several semantic classes following the project tasks.
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If the digital elevation model (DEM) is generated based on the dense point cloud data, it can include
either both terrain and all the objects above the ground, like trees, buildings and other man-made
structures (digital surface model, DSM), or only show the landscape of the territory (digital terrain
model, DTM).

3. The third step is creating of Orthomosaic, which can be georeferenced and used as a base layer for
varioustypes of maps and further post processing analysis and vectorization. Orthomosaic is generated
by projecting theimages according to their EOQ/IO data on a surface of the user's choice: DEM or mesh.

For multispectral imagery projects, orthomosaic can represent NDVI and other vegetation indices
information. Reflectance calibration feature of Metashape allows to correctly interpret radiometric
imagery data, providing that radiometric panel has been used in the project and/or sun sensor
information is available in the images meta data.

About the manual

Basically, the sequence of actions described above covers most of the data processing needs. All these
operations are carried out automatically according to the parameters set by user. Instructions on how to
get through these operations and descriptions of the parameters controlling each step are given in the
corresponding sections of the Chapter 3, General workflow chapter of the manual.

In some cases, however, additional actions may be required to get the desired results. In some capturing
scenarios masking of certain regions of the photos may be required to exclude them from the cal cul ations.
Application of masksin Metashape processing workflow aswell as editing options available are described
in Chapter 6, Editing. Camera calibration issues are discussed in Chapter 4, Referencing, that also
describes functionality to optimize cameraalignment results and provides guidance on model referencing.
A referenced model, be it amesh or aDEM serves as a ground for measurements. Area, volume, profile
measurement procedures are tackled in Chapter 5, Measurements, which also includes information on
vegetation indices cal culations. While Chapter 7, Automation describes opportunitiesto save up on manual
intervention to the processing workflow, Local network processing presents guidelines on how to organize
distributed processing of the imagery data on several nodes.

It can take up quite along time to reconstruct a 3D model. Metashape allows to export obtained results
and save intermediate datain aform of project files at any stage of the process. If you are not familiar with
the concept of projects, its brief description is given at the end of the Chapter 3, General workflow.

In the manual you can aso find instructions on the Metashape installation and activation procedures and
basic rules for taking "good" photographs, i.e. pictures that provide most necessary information for 3D
reconstruction. For theinformation refer to Chapter 1, I nstallation and Activation and Chapter 2, Capturing
scenarios.

Vi



Chapter 1. Installation and Activation

System requirements

Minimal configuration

e Windows 7 SP 1 or later (64 bit), Windows Server 2008 R2 or later (64 bit), macOS High Sierra or
later, Debian/Ubuntu with GLIBC 2.19+ (64 bit)

* Intel Core 2 Duo processor or equivalent

+ 8GB of RAM

Recommended configuration

» Windows 7 SP 1 or later (64 bit), Windows Server 2008 R2 or later (64 bit), macOS Mojave or later,
Debian/Ubuntu with GLIBC 2.19+ (64 hit)

* Intel Corei7 or AMD Ryzen 7 processor
» Discrete NVIDIA or AMD GPU (4+ GB VRAM)
* 32GB of RAM

The number of photos that can be processed by Metashape depends on the available RAM and
reconstruction parameters used. Assuming that a single photo resolution is of the order of 10 MPix, 4 GB
RAM is sufficient to make a model based on 30 to 50 photos. 16 GB RAM will allow to process up to
300-400 photographs.

GPU recommendations

Metashape supports accelerated image matching; depth maps reconstruction; depth maps based mesh,
DEM and tiled model generation; texture blending; photoconsistent mesh refinement operation due to the
graphics hardware (GPU) exploiting.

NVIDIA
GeForce GTX 7xx series and later, Quadro M4000 and later with CUDA support.

AMD
Radeon R9 series and |ater, Radeon Pro WX 7100 and later with OpenCL 1.2 support.

Metashape is likely to be able to utilize processing power of any CUDA enabled device with compute
capability 3.0 and higher or OpenCL 1.2 and higher enabled device with SPIR support for stages specified
above, provided that CUDA/OpenCL drivers for the device are properly installed. However, because of
the large number of various combinations of video chips, driver versions and operating systems, Agisoft
is unable to test and guarantee M etashape's compatibility with every device and on every platform.

The processing performance of the GPU device is mainly related to the number of CUDA cores for
NVIDIA video chipsand the number of shader processor unitsfor AMD and Intel video chips. Additionally
depth maps based mesh, DEM and tiled model reconstruction as well as photoconsistent mesh refinement
operations and texture blending would benefit from larger amount of VRAM available.
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Thetable below lists currently supported devices (on Windows platform only). Agisoft will pay particular
attention to possible problems with Metashape running on these devices.

Table 1.1. Supported Desktop GPUs on Windows platform

NVIDIA AMD

GeForce RTX 3080 Radeon RX 6800
GeForce RTX 2080 Ti Radeon VI
TeslaV100 Radeon RX 5700 XT
TedaM60 Radeon RX Vega 64
Quadro P6000 Radeon RX Vega 56
Quadro M6000 Radeon Pro WX 7100
GeForce TITAN X Radeon RX 580
GeForce GTX 1080 Ti FirePro W9100
GeForce GTX TITAN X Radeon R9 390x
GeForce GTX 980 Ti Radeon R9 290x

GeForce GTX TITAN
GeForce GTX 780 Ti

M etashape supports texture blending on GPU using V ulkan technology on Linux and Windows OS. GPU
accelerated texture blending is currently supported for frame and fisheye type cameras on NVIDIA cards
since GeForce GTX 8XX / Quadro M4000 and driver versions from 435.xx and on AMD cards since
Radeon R9 29x series / FirePro W9100 and 17.1.x drivers. Some older GPUs and older driver versions
could also support texture blending using VVulkan, however, it is hot guaranteed.

Although Metashape is supposed to be able to utilize other compatible GPU models and being run under
a different operating system, Agisoft does not guarantee that it will work correctly. However, al GPU-
based processing issues should be reported to Agisoft support team for more detailed investigation.

4 Note

e Use CPU enable flag to allow calculations both on CPU and GPU for GPU-supported tasks.
However if at least one powerful discrete GPU is used it is recommended to disable CPU flag
for stable and rapid processing.

» Using GPU acceleration with mobile or integrated graphics video chips is not recommended
because of the low performance of such GPUs.

* CUDA supported devices for some older macOS versions may require to install CUDA drivers
from official web-site first: http://www.nvidia.com/object/mac-driver-archive.html.

Due to lack of CUDA support on certain macOS versions Metashape will automatically switch
to OpenCL implementation for GPU-based processing on NVIDIA graphic devices.

Installation procedure

Installing Metashape on Microsoft Windows

To install Metashape on Microsoft Windows simply run the downloaded msi file and follow the
instructions.



http://www.nvidia.com/object/mac-driver-archive.html

Installation and Activation

Installing Metashape on macOS

Open the downloaded dmg image and drag M etashape application bundle to the desired location on your
hard drive (for example, to Applications folder. Do not run Metashape directly from the dmg image to
avoid issues on license activation step.

Installing Metashape on Debian/Ubuntu

Unpack the downloaded archive with a program distribution kit to the desired location on your hard drive.
Also, install the package: sudo apt install libxch-xinerama0. Start Metashape by running metashape.sh
script from the program folder.

30-day trial and demo mode

Once Metashape is downl oaded and installed on your computer you can run it either in the Demo mode or
in the full function mode. On every start until alicense key sequenceis entered it will show on activation
diaog offering three options: (1) activate Metashape using a valid license code, (2) start a free 30-day
trial, (3) continue using Metashape in Demo mode. Starting a 30-day trial period allows to evaluate the
functionality of the program and explore the software in full-function mode, including save and export
features. Trial license is intended to be used for evaluation purposes only and any commercial use of a
trial license is prohibited.

If you are not ready yet to start the trial period, you can opt for the Demo mode. The employment of
Metashape in the Demo mode is not time limited. Several functions, however, are not available in the
Demo mode. These functions are the following:

» savethe project;

* build tiled model;

* build orthomosaic;

* build digital elevation model (DEM);

* DEM and orthomosaic related features (such as vegetation index calculation, DEM-based
measurements);

» some Python APl commands;

« al export features, including exporting reconstruction results (you can only view a 3D model on the
screen);

* using network and cloud processing features.

To use Metashape in the full function mode for various projects you have to purchase a license. On
purchasing you will get a license code to be entered into the activation dialog of Metashape. Once the
license code is entered you will get full access to all functions of the program and the activation dialog
will no longer appear upon program start, unless the license is deactivated.

Activation procedure

Metashape node-locked license activation

The Node-locked license for Metashape allows to activate the software on one machine at atime. Node-
locked licensefiles are unique for each computer, and aretied to the system hardware. If you areto replace
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major system components or re-install operational system, the license should be deactivated first and then
the same key could be used to activate the license on the renewed system.

4 Note

e The node-locked license activation on Windows OS and macOS may require administrator
privileges. During the activation process additiona confirmation dialog will appear to apply the
elevated privileges.

» To deactivate the license select Activate Product command from Help menu and use Deactivate
button or argument --deactivate in the command line (terminal) to Metashape executable.

» When Metashape software is being uninstalled on Windows OS the license deactivation attempt
will be automatically performed, however, it is recommended to deactivate the license manually
before uninstalling the application.

M etashape software requires alicense key (adigital code) to be activated. First of all, make sure that you
haveavalid license key at hand. The number of activation/deactivation operationsisnot effectively limited
for manual license transfer scenarios. But we recommend technical possibility to transfer a node-locked
license to a new computer not to be exploited in automated scenarios involving activation/deactivation of
the node-locked license on regular basis.

[{ Note

» Excessive usage of activation/deactivation mechanism may result in the situation when user gets
blocked in the activation system.

» For scenarios which involve virtual machines and frequent license activation/deactivation
operations it is recommended to consider floating license option, in which case the license is
automatically returned to the license server when the Metashapeis stopped or the related process
iskilled unexpectedly.

Standard activation procedure, which allows to activate the product in the means of seconds, requires the
machine to be connected to the Internet. If it isyour case, please follow the online activation procedure as
described below. In case the system cannot be connected to the Internet, please opt for the offline activation
procedure, which is also described in this section of the manual.

Online Activation Procedure - To activate M etashape on a machine with Internet
connection

1. Launch Metashape software, previoudly installed on your machine, and go to Help menu for Activate
product... command.

2. InActivation dialog insert license key according to the suggested 5 digit blocks structure. Please note
that license codes never include zero digit - only letter "O".

3. If the license code has been input correctly, then the OK button will become active. Click on it to
complete the activation procedure. If the button is still grayed out, please make sure that the key you
are using is meant for the product you are trying to activate: alicense key for the Standard Edition,
for example, will not activate the Professional Edition.

Offline Activation Procedure - To activate Metashape on a machine with NO
I nter net connection

1. Launch Metashape software, previoudly installed on your machine, and go to Help menu for Activate
product... command.
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2. InActivation dialog insert license key according to the suggested 5 digit blocks structure. Please note
that license codes never include zero digit - only letter "O". Click OK button.

3. Click Save Activation Request button. Browse to the destination folder for the activation_request.act
filein the Save as dialog, typein the file name and click Save button.

4. Sendthefile saved at previous step to support@agisoft.com. Agisoft support team will process your
activation request and send the special license file to your e-mail with the instructions to complete
the activation process.

If youwouldliketo activate/deactivate M etashape software in headlessmode, please seethelist of relevant
commands bel ow:

» metashape --activate license_key

» metashape --deactivate

» metashape --activate-offline license_key file_name.act
» metashape --deactivate-offline file_name.act

Run "metashape --help" to see the complete list of the commands available.

Floating licenses

M etashape software can be used under floating license conditions. A floating license allows to install the
software on an unlimited number of machines, which are connected to a server network. However, at any
one time, Metashape can only run on the maximum number of computers for which licenses have been
purchased. Since Metashape can be installed on more systems than the number of licenses purchased, this
enables the licensee to efficiently share the product across the organization.

A software utility called Floating License Server (FLS) deployed on the server machine issues licenses
to client machines, up to the number of floating licenses purchased. If all floating licenses are in use, no
more computers can run Metashape until alicense is returned to the FLS, i.e. until Metashape processis
finished on one of the machines.

M etashape floating licenses are borrowable. A borrowed license can be used on a machine disconnected
from the server network for a certain period (up to 30 days).

Floating license activation procedure is performed on the server machine and includes two steps:
* FLSinstallation and activation

 Floating license activation

Thus, to activate afloating license you will need 3 components:

» FLSarchive (to be downloaded from the link provided upon license purchase)

» FLSactivation key (to be provided on purchasing a floating license)

 Floating license activation key (to be provided on purchasing a floating license), and the number of
floating licenses associated with the key.

[{ Note

< By default, FLS cannot be installed on avirtual machine. In case the the virtual environment is
the only option to deploy the license server, please contact support@agisoft.com for additional
instructions on the matter.
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To activate Floating License Server

1

2.

7.

Unpack the FLS archive and run FL S utility (rim/rim.exe) on the server machine.

Go to http://server_address:5054 to use web-interface of the license management system. Enter
Satus section of the left hand side menu. Find "agisoft" line in the ISV Servers table. Click agisoft
button in ACTIVATE column of the table.

Set the following values for the parameters on the Activate/Deactivate Alternate Server Hostid page.
ISV: agisoft, Activation Key: enter FLS activation key. Leave Deactivate? box unchecked. Click
Activate/Deactivate Alternate Server Hostid button.

The FLS s successfully activated now.

To complete the procedure, go to the folder where the FL'S utility has been unpacked to and delete
mock licensefile - agisoft.lic.

Return to web-interface of the license management system and go to Rer ead/Restart Server ssection
of the left hand side menu. Select "-all-" from the dropdown list of the ISV field. Click REREAD/
RESTART button.

Now the FL S activation procedure is completed.

The next step is activation of the floating license itself.

To activate a floating license

1

Go to http://server_address:5054 to use web-interface of the license management system. Enter
Activate License section of theleft hand side menu. Click BEGIN License Activation button on License
Activation page.

Do not change the suggested value of the SV activation website parameter. Click Next.

On step 2 of License activation procedure set 1SV parameter to "agisoft" value and enter Floating
license activation key into the License activation key textbox. Click Next.

Gotothefolder wherethe FL S utility has been unpacked to, open rim_agisoft FLS-activation-key.lic
file. Copy string "license=server-serial-number" from the first line of the file and enter the datainto
the License Server or Node-lock hostid: textbox on the 3d step of the License activation procedure.

Indicate the number of floating licenses to be activated in the License count (for floating licenses)
field. The number should not excess the total amount of floating licenses associated with the floating
license activation key. Click Next.

On step 4 indicate the name of the license file to be created. Click Next.

On step 5 check Activation Request Data and if everything is correct, click REQUEST LICENSE
button.

Click (Re)Sart License Server. Select "agisoft” from the dropdown list of the ISV field. Click
REREAD/RESTART button.

Floating license activation procedure is completed. Y ou can run Metashape on the client machines
connected to the server.

To run Metashape on a client machine, where the software has been installed, the client machine should
have network connection to the server, where FL S has been deployed. In case the connection is not via
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alocal network, then a specially prepared * .lic file should be properly placed to the Metashape folder on
the client machine. The datain the file should be the following string: "HOST FLS address". In case the
server uses a port different from the standard 5053 one, then the string should be: "HOST FLS address
any the port_number".

Totransfer the Floating License Server

1

5.

Deactivate FLS in web-interface of the license management system: http://server_address:5054.
Enter Satus section of the left hand side menu. Find "agisoft" line in the ISV Servers table. Click
agisoft button in ACTIVATE column of the table. Set the following values for the parameters on
the Activate/Deactivate Alternate Server Hostid page. 1SV: agisoft, check Deactivate? box. Click
Activate/Deactivate Alternate Server Hostid button.

Activate FLS on a new server following steps 1-3 from the Floating License Server activation
procedure described above.

Copy all floating license files (i.e. al *.lic files but for the rim_agisoft_license server activation
key.lic) from the original server machine to the new server to the folder where floating license server
has been unpacked to.

Modify the server host name in the first line of the copied floating license files to the name of the
new server machine.

Follow steps 5-6 from the Floating License Server activation procedure described above.

There is no need to perform Floating license activation procedure since the floating license is already
activated. Metashape can be run on the client machines connected to the new server.

To borrow afloating license

1

Connect the machine you would like to borrow the license for to the server machine and make sure
that there is a spare floating license in the server pool.

Run Metashape software on the machine. Select Activate Product... command from Help menu.

Click Borrow License button in the MetashapeActivation dialog. Set the number of days you would
like to borrow the license for and click OK button. The number of days should not exceed 30.

Now the machine can be disconnected from the server network, with M etashape being kept activated
onit.

To return the borrowed license connect the computer to the license server network, start Metashape,
select Activate Product... command from the Help menu and click Return License button in Activate
dialog window. Otherwise the license will be automatically returned to the server pool after the
borrowing period is over.




Chapter 2. Capturing scenarios

Photographs suitable for 3D model reconstruction in Metashape can be taken by any digital camera (both
metric and non-metric), as long as you follow some specific capturing guidelines. This section explains
genera principles of taking and selecting pictures that provide the most appropriate data for 3D model
generation.

IMPORTANT! Make sure you have studied the following rules and read the list of restrictions before you
get out for shooting photographs.

Equipment

Use adigital camera with reasonably high resolution (5 MPix or more). It is also recomended to take
photo in the max possible allowed resolution.

The best choice is 50 mm focal length (35 mm film equivalent) lenses. It is recommended to use focal
length from 20 to 80 mm interval in 35mm equivalent.

Avoid ultra-wide angle and fisheye lenses. The distortion of the lenses used to capture the photos should
be well simulated with the camera model used in the software. Generally, Brown's distortion model
implemented in Metashape workswell for frame cameras. However, since fisheye and ultra-wide angle
lenses are poorly simulated by the mentioned distortion model, it is crucial to choose the proper camera
type in the Camera Calibration dialog prior to processing such data - the software will switch to the
appropriate distortion model.

Fixed lenses are preferred. If zoom lenses are used - focal length should be set either to maximal or to
minimal value during the entire shooting session for more stable results, for intermediate focal lengths
separate camera calibration groups should be used.

1SO should be set to the lowest value, otherwise high 1SO values will induce additional noise to images.

Aperture value should be high enough to result in sufficient focal depth: it isimportant to capture sharp,
not blurred photos.

Shutter speed should not be too slow, otherwise blur can occur due to slight movements.

Using RAW datalosslessly converted to the TIFF filesis preferred, since JPG compression may induce
unwanted noise to the images.

Object/scene requirements

Avoid untextured, shiny, highly reflective or transparent objects. If still have to, shoot shiny objects
under acloudy sky. Direct sunlight leadsto patches on most of the surfaces; thelight patcheswhich have
moved across the target object during the shooting process will create difficulties for reconstruction
agorithms.

Consider using lighting when shooting underwater or a constant source of light that will increase the
visible distance and quality of the obtained images.

It is recommended to plan your shooting scenario in such a way so that unwanted foregrounds,
backgrounds, as well as moving objects can be avoided on the images.

Avoid absolutely flat objects or scenes. The object of interest should take up the maximum proportion
of the image possible. In some cases, the portrait camera orientation option should be considered.




Capturing scenarios

Capturing scenarios

The shooting scenario depends on the object of the survey (this is a forest area, a detached building, a
monument, etc.).

Aerial photography

In case of aerial photography the overlap requirement can be put in the following figures: 60% of side
overlap + 80% of forward overlap. When making a survey over aforest, it isrecommended to increase
the overlap value to 80% and 90% respectively. To achieve better overlap, we can recommend cross-
to-cross routes.

It isimportant plan aflight with a proper elevation model considered.

Do not perform an aerial survey of forest areaslower than 300 meters above the ground. Trees move due
the wind and when capturing from alow altitude Metashape may fail to find common points on photos.

Do not perform an aerial survey of mountain areas lower than 100 meters above the ground.

We don't recommend perform an aeria survey of the same area for the whole day. Lighting conditions
changes during the day. Y ou may get photos of the same territory with different lighting (for example
long shadows from the same structures pointing in completely different directions and having different
shapes), so Metashape might fail to find common points on the overlapping photos.

In case of aerial photography and demand to fulfill georeferencing task, even spread of ground control
points (GCPs) (at least 10 across the area to be reconstructed) is required to achieve results of highest
quality, both in terms of the geometrical precision and georeferencing accuracy. Y et, AgisoftMetashape
is able to complete the reconstruction and georeferencing tasks without GCPs, too.

Underwater survey

Underwater surveying projects are considerably harder compared to the regular indoor/outdoor image
acquisition procedure due to the very hard environment conditions (viewing distanceislimited, controlled
light environment isalmost not applicable, difficult to place and fix even afew control pointsin scene, may
be hard to repeat the operation). Therefore we recommend to plan the survey carefully before performing
actual shooting session. Taking more images than needed is aways better than having insufficient image
overlap or incomplete dataset.

Werecommend asurvey using a"snake" or "spira" routes. If possiblewait for the calm weather and bright
light - it will allow to increase the visible distance.

Close-range objects scanning

Number of photos: more than required is better than not enough.

Number of "blind-zones" should be minimized since Metashape is able to reconstruct only geometry
visible from at least two cameras.

Each photo should effectively use the frame size: object of interest should take up the maximum area.
In some cases portrait camera orientation should be used.

Do not try to placefull object in theimage frame, if some partsare missing it isnot aproblem providing
that these parts appear on other images.
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« If you are planning to carry out any measurements based on the reconstructed model, do not forget to
locate at |east two markers with a known distance between them on the object. Alternatively, you could
place aruler within the shooting area.

The following figures represent advice on appropriate capturing scenarios:
Facade (Incorrect) Facade (Correct)

7 VLA L AL AL S LA A S LA A LA S S AL A S AL LSS A AL A AL AL

Interior (Incorrect) Interior (Correct)
A A L A A A L A

1Tl

*a
-~
-~

el

e
+—9
ha

‘11t th

ANANARARANRNARRNRN NN NNRNNN NN
SUNNNNANNNMNAN NN AN
ANANARARANRNARRNRN NN NNRNNN NN

SUNNNNANNNMNAN NN AN

iz AR i
| solated Object (I ncorrect) | solated Object (Correct)
"2 °
[ S “0
[ nd +—e
" e

Image preprocessing

» Metashape operates with the original images. So do not crop or geometrically transform, i.e. resize
or rotate, the images. Processing the photos which were manually cropped or geometrically warped is

10



Capturing scenarios

likely to fail or to produce highly inaccurate results. Photometric modifications (such as brightness or
contrast adjustment) do not affect reconstruction results, providing that no hard filters are applied that
could remove minor details on the images, such as Gaussian/blur filter, for example.

Restrictions

In some cases it might be very difficult or even impossible to build a correct 3D model from a set of
pictures. A short list of typical reasons for photographs unsuitability is given below.

Modifications of photographs

M etashape can process only unmodified photos as they were taken by a digital photo camera. Processing
the photos which were manually cropped or geometrically warped is likely to fail or to produce highly
inaccurate results. Photometric modifications do not affect reconstruction results.

Lack of EXIF data

Metashape calculates initial values of sensor pixel size and focal length parameters based on the EXIF
data. The better initial approximation of the parameter valuesis, the more accurate autocalibration of the
camera can be performed. Therefore, reliable EXIF data is important for accurate reconstruction results.
However 3D scene can also be reconstructed in the absence of the EXIF data. In this case Metashape
assumes that focal length in 35 mm equivalent equalsto 50 mm and tries to align the photosin accordance
with this assumption. If the correct focal length value differs significantly from 50 mm, the alignment can
giveincorrect resultsor even fail. In such casesit isrequired to specify initial cameracalibration manually.

The details of necessary EXIF tags and instructions for manual setting of the calibration parameters are
given in the Camera calibration section.

Lens distortion

The distortion of the lenses used to capture the photos should be well simulated with the camera model
used in the software. Generally, Brown'sdistortion model implemented in Metashape workswell for frame
cameras. However, since fisheye/ultra-wide angle lenses are poorly simulated by the mentioned distortion
model, it is crucial to choose proper cameratypein Camera Calibration dialog prior to processing of such
data - the software will switch to the appropriate distortion model.

Lens calibration

It is possible to use Metashape for automatic lens calibration. M etashape uses LCD screen asacalibration
target (optionally it ispossibleto use aprinted chessboard pattern, providing thatitisflat and al itscellsare
squares). Lens calibration procedure supports estimation of the full camera calibration matrix, including
non-linear distortion coefficients. The details of camera models are given in the Appendix C, Camera
model s section.

4 Note

 Lenscalibration procedure can usually be skipped in common workflow, as M etashape cal cul ates
the calibration parameters automatically during Align Photos process. However, if the alignment
results are unstable, for example, due to the lack of the tie points between the images, the lens
calibration may be useful.
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The following camera calibration parameters can be estimated:

f
Focal length measured in pixels.

CX, cy
Principal point coordinates, i.e. coordinates of lensoptical axisinterceptionwith sensor planein pixels.

b1, b2
Affinity and Skew (non-orthogonality) transformation coefficients.

k1, k2, k3, k4
Radia distortion coefficients.

pl, p2
Tangential distortion coefficients.

Before using lens calibration tool a set of photos of calibration pattern should be loaded in Metashape.

To capture photos of the calibration pattern:

1. Select Show Chessboard... command from the Lens submenu in the Tools menu to display the
calibration pattern.

2. Use mouse scroll wheel to zoom in/out the calibration pattern. Scale the calibration pattern so that
the number of squares on each side of the screen would exceed 10.

3. Captureaseriesof photosof the displayed calibration pattern with your camerafrom slightly different
angles, according to the guidelines, outlined below. Minimum number of photos for a given focal
length is 3.

4. If you are cdlibrating zoom lens, change the focal length of your lens and repeat the previous step
for other focal length settings.

5. Click anywhere on the calibration pattern or press Escape button to return to the program.
6. Upload the captured photos to the computer.

When capturing photos of the calibration pattern, try to fulfill the following guidelines:

» Make sure that the focal length keeps constant throughout the session (in case of zoom lens).
» Avoid glare on the photos. Move the light sources away if required.

» Preferably, the whole area of the photos should be covered by calibration pattern. Move the camera
closer to the LCD screenif required.

Toload photos of the calibration pattern:

1 Create new chunk using & Add Chunk toolbar button on the Workspace pane or selecting Add Chunk

command from the Workspace context menu (available by right-clicking on the root element on the
Workspace pane). See information on using chunks in Using chunks section.

2.  Select Add Photos... command from the Workflow menu.

12
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3. Inthe Open dialog box, browse to the folder, containing the photos, and select files to be processed.
Then click Open button.

4. Loaded photoswill appear in the Photos pane.

4 Note

 You can open any photo by double clicking on its thumbnail in the Photos pane. To obtain good
calibration, the photos should be reasonably sharp, with crisp boundaries between cells.

« If you have loaded some unwanted photos, you can easily remove them at any time.

« Before calibrating fisheye lens you need to set the corresponding Camera Type in the Camera
Calibration... dialog available from the Tool s menu. Seeinformation on other cameracalibration
settings in Camera calibration section.

To calibrate camera lens
1. Select Calibrate Lens... command from the Lens submenu in the Tools menu.

2. Inthe Calibrate Lens dialog box, select the desired calibration parameters. Click OK button when
done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.

4. The calibration results will appear on the Adjusted tab of the Camera Calibration... dialog available
from the Tools menu. The adjusted values can be saved to file by using Save button on the Adjusted
tab. The saved lens calibration data can later be used in another chunk or project, providing that the
same cameraand lensis used.

4 Note

 After you have saved the calibration parametersfor the lens, you may proceed with the workflow
steps in a separate chunk for the actual image set captured by the same camera and lens. To
protect the calibration datafrom being refined during Align Photos process one should check Fix
calibration box on the Initial tab for the chunk with the data to be processed. In this caseinitial
calibration values will not be changed during Align Photos process.

After calibration is finished, you will be presented with the following information:
Detected chessboard corners are displayed on each photo (the photo can be opened by double clicking on
its name in the Photos pane). It is preferable when the majority of the corners were detected correctly. For

each detected corner the reprojection error between the detected corner position and estimated position
according to the calculated calibration is also displayed. The errors are scaled x20 times for display.

Automated mission planning

M etashape introduces functionality for obtaining optimal sets of camera positions based on rough model
and creating mission plans using these optimal sets.

To generate a detailed mission plan, you need to perform a simple overhead flight and create a rough
polygonal model. Then, a set of the viewpoints which are enough to cover the surface of the object
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with sufficient overlap is automatically generated. Finally, a round-trip passing through all the generated
viewpoints is computed and can be exported in KML file format to be used for drone controlling
application. Thistool is suitable for DJI drones. We recommend using aircraft/drones with RTK GPS to
significantly enhance flight safety and precision.

Mission planning feature works as follows:

1. Makeanoverhead flight over the region of interest to capture abasic imagery set. To capture vertical
and concave surfaces better, you may use an oblique survey preset in your drone app instead of taking
only nadir photos.

2. Import photosto Metashape and align them, then build amodel of the object. Asonly rough geometry
is needed for mission planning step, you can build mesh from sparse cloud or using low quality
settings to speedup computations. Check Bounding Box to include entire geometry of interest.

3.  Specify home point for the drone at the expected take-off point. This can be done by placing a Point
shape on the rough model. To place point precisely, you can build texture for the model or pick point
from an overhead photo that observes home point.

4. Select Plan Mission submenu from the Tools menu. Specify parameters and run processing.

5. Import filesto drone app that supports KML flight plans with gimbal orientation.

4 Note

» Please note that each flight must be watched by a pilot ready to take manual control over the
dronein case of GPS issues or unreconstructed obstacles such as wires or trees.

» Specify flight zones. To enhance flight safety, you can specify zones allowed and restricted to
fly in.

« If drone battery gets low during the flight, replace it and restart the drone at the same altitude
as that of specified home point. You will need to manually navigate drone to the position from
which the last visited waypoint isin line of sight to resume automatic flight safely.

* You may need to disable built-in drone obstacle avoidance feature in order to perform range
flights. Be even more careful after disabling obstacle avoidance asdrone will longer stop or slow
down in case of any obstacle on the way. It's not recommended to disable obstacle avoidance
feature when flying using GNSS signal without RTK.

Plan Mission parameters
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Plan Mission
General

Focus on model selection

Focus on interesting zone: Interesting zone

Survey parameters

Camera model: Default camera {50 mm)
Resolution: Capture distance (m) 10
Image overlap {%): 70

Improve hard-to-reach regions coverage

Enable multi-photo waypoints (DI Filot and Litchi C5V)

Obstade avoidance

Safety distance (m): 5

Min altitude (m): ]

Safety zone: Allowed area
Restricted zone: Restricted area
Powerlines layer: Powerlines

Flight plan properties

Home point: hiome
Min waypoint spadng (m): 0.6
Min pitch {): a0
Max pitch (=): a

Prefer horizontal movement

"Plan Mission" dialog

The following parameters control the photo alignment procedure and can be modified in the Plan Mission
dialog box:

Focus on model selection
To consider only selected triangles of the model as target for reconstruction. In any case all
reconstructed triangles will be used for obstacle avoidance.
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Focuson interesting zone
Polygons from the sel ected shape layer are used for the area selection. All mesh faces are selected that
fall into the polygonal shapes from the chosen layer when viewed from above. If any mesh faces are
used for Focus on model sel ection along with the zone, then both sourceswill be considered: manually
selected mesh faces and mesh faces corresponding to the selected shape layer.

Camera model
Choose a camera from the list, with a certain focal length in mm.

Resolution
Target image resolution. Can either be specified as GSD or distance in meters from the surface of
the rough model.

Image overlap (%)
Choose the desired overlap percentage.

Improve hard-to-reach regions coverage
Optimize coverage of hard-to-reach regions of interest by generating additional viewpoints from
allowed space.

Enable multi-photo waypoints (DJI Pilot and Litchi CSV)
Convert close waypoints to rotate-and-shoot actions without changing drone position.

Safety distance (m)
Distance from the object which is restricted for putting waypoints within or planning path through.
Focus on selection parameter is ignored here - al parts of the object available in the rough model
are considered.

Min altitude (m)
Relative altitude to home point (in meters) which isrestricted for putting waypointswithin or planning
path through.

Safety zone
Shape layer with allowed regions.

Restricted zone
Shape layer with restricted regions.

Powerlines layer
Shape layer with the detected powerlines.

Home point
The desired take-off point can be defined as 3D point shape placed in scene. If you have specified a
Safety zone, then the Home point should be located within this area.

Min waypoints spacing (m)
Minimal distance between consecutive waypoints. The default value is set to 0.5 meters according
to DJI drones firmware.

Max waypoints per flight
Maximal possible number of waypoints per KML file. If flight plan has more waypoints than specified
value, it will be split into chunks. The default valueis set to 99 according to DJI drones firmware.

Min pitch
Minimal pitch angle allowed by the drone gimbal.

16



Capturing scenarios

Max pitch
Maximal pitch angle allowed by the drone gimbal.

Prefer horizontal movement
Traverse flat surfaces in horizontal zig-zag fashion instead of a vertical one. Vertical movement is
simpler to keep direct eye contact with the drone, while the horizontal movement may be more battery
efficient.

Excessive image elimination

Reduce overlap feature is made for analyzing excessive image sets to understand which images are useful
and which are redundant and may be disabled of removed.

1. Align photos using entire dataset and build rough mesh model from the sparse cloud.
2. Select Reduce Overlap dialog available from the Tools menu.

3. Choose parameters in Reduce Overlap dialog box.

4. Click OK button.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.

6. After the operation is finished al the cameras which are not included into optimal subset will get
disabled.

Reduce overlap parameters

Reduce Overlap
General

Focus on model selection

Surface coverage: 3

Lo ] cancel |

"Reduce overlap" dialog
Reduce overlap dialog parameters:

Focus on selection
To consider only selected triangles of the polygonal model as target for reconstruction. Cameras that
do not have any of the selected polygonsin the field of view would be automatically disabled.

Surface coverage
Number of cameras observing each point from different angles.
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Chapter 3. General workflow

Processing of images with Metashape includes the following main steps:
* loading images into Metashape;

* inspecting loaded images, removing unnecessary images;
« aligning cameras;

* building dense point cloud;

* building mesh (3D polygonal model);

 generating texture;

* building tiled model;

* building digital elevation model (DEM);

* building orthomosaic;

* exporting results.

If you are using Metashape in the full function (not the Demo) mode, intermediate results of the image
processing can be saved at any stage in the form of project files and can be used later. The concept of
projects and project filesis briefly explained in the Saving intermediate results section.

The list above represents al the necessary steps involved in the construction of a textured 3D model
DEM and orthomosaic from your photos. Some additional tools, which you may find to be useful, are
described in the successive chapters.

Preferences settings

Before starting a project with Metashape it is recommended to adjust the program settings for your needs.
In Preferences dialog (General tab) available through the Tools menu you can indicate the path to the
Metashape log file to be shared with the Agisoft support team in case you face any problem during the
processing. Hereyou can al so change GUI languageto the one that is most convenient for you. The options
are: English, Chinese, French, German, Italian, Japanese, Portuguese, Russian, Spanish.

Switch Theme in case you have preferences between Dark or Light program GUI or leave it as Classic
for the simplest view. Shortcuts for the menu commands can be adjusted for your convenience on the
General tab aswell.

On the GPU tab you need to make surethat all discrete GPU devices detected by the program are checked.
M etashape exploits GPU processing power that speeds up the process significantly. However, Agisoft
does not recommend to use integrated graphic card adapters due to their possible unstable work under
heavy load. If you have decided to switch on GPUs to boost the data processing with Metashape, it is
recommended to uncheck Use CPU when performing GPU accelerated processing option, providing that
at least one discrete GPU is enabled for processing.

Advanced tab allows to switch on such advanced features like rich Python console, for example.
Furthermore, you can enable loading of extra camera data from XMP (camera calibration, camera
orientation angles, camera location accuracy, GPS/INS offset).
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K eep depth maps option can be beneficial in terms of saving up the processing time, in case there might
be aneed to rebuild dense point cloud, once generated, for asmaller part of the scene, or if both mesh and
dense cloud are based on the same quality depth maps.

Fine-level task subdivision optionisuseful in caseswhen large datasets areto be processed. Enabled option
providesinternal splitting of some tasksto the sub-jobs, thus allowing to reduce the memory consumption
during the processing. The tasks that are supported for fine-level distribution are the following: Match
Photos, Align Cameras, Build Depth Maps, Build Dense Cloud, Build Tiled Model, Build DEM, Build
Orthomosaic and Classify Points.

M etashape allows for incremental image alignment, which may be useful in case of some datamissing in
the initially aligned project. If this may be the case, you should switch on the Keep key points option on
the Advanced tab of the Preferences dialog before you start the processing of the data.

Loading images to the project

Before starting any operation it is necessary to point out which images will be used as a source for
photogrammetric processing. In fact, images themselves are not loaded into Metashape until they are
needed. So, when Add photos command is used, only the links to the image files are added to the project
contents to indicate the images that will be used for further processing. Also for import images to the
project in Metashape available Add Folder command.

Metashape uses the full color range for image matching operation and does not downsample the color
information to 8 bit. The point cloud points, orthomosaic and texture would also havethe original bit depth,
providing that they are exported in the formats that support non 8-bit colors.

Toload a set of images

L Select Add Photos... command from the Workflow menu or click Add Photos toolbar button on

the Workspace pane.

2. In Add Photos dialog box browse to the folder containing the images and select files to be processed.
Then click Open button.

3. Selected images will appear on the Workspace pane.

4 Note

« Metashape accepts the following image formats: JPEG, JPEG 2000, JPEG XL, TIFF, DNG,
PNG, OpenEXR, BMP, TARGA, PPM, PGM, SEQ, ARA (thermal images) and JPEG Mullti-
Picture Format (MPO). Image files in any other format will not be displayed in the Add Photos
dialog box. To work with such images it is necessary to convert them to one of the supported
formats.

If some unwanted images have been added to the project, they can be easily removed at any moment.

Toremove unwanted images
1. Onthe Workspace pane select the cameras to be removed.

2. Right-click on the selected cameras and choose Remove Items command from the opened context

menu, or click X Remove Items toolbar button on the Reference pane. Selected images will be
removed from the working set.
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Camera groups

If al the photos or a subset of photos were captured from one camera position - camera station, for
M etashape to process them correctly it is obligatory to move those photos to a camera group and mark
the group as Camera Station. It is important that for all the photos in a Camera Station group distances
between camera centers were negligibly small compared to the camera-object minimal distance.

Photogrammetric processing will require at |east two camera stations with overlapping photosto be present
in a chunk. A panoramic picture, however, can be exported for the data captured from only one camera
station. Refer to Exporting results section for guidance on panorama export.

Additionally, camera group structure can be used to manipulate the image data in a chunk easily, e.g. to
apply disable/enable functions to all the camerasin a group at once.

To move photosto a camera group
1. Onthe Workspace pane (or Photos pane) select the photos to be moved.

2. Right-click on the selected photos and choose Move Cameras - New Camera Group command from
the opened context menul.

3. A new group will be added to the active chunk structure and selected photos will be moved to that
group.

4. Alternatively selected photos can be moved to a camera group created earlier using Move Cameras
- Camera Group - Group_name command from the context menu.

To mark group as camera station, right click on the camera group name and select Set Group Type
command from the context menu.

Inspecting loaded images

L oaded images are displayed on the Workspace pane along with flags reflecting their status.
The following flags can appear next to the cameralabel:

NC (Not calibrated)
Notifiesthat the EXIF dataavailablefor theimageis not sufficient to estimate the camerafocal length.
In this case Metashape assumes that the corresponding photo was taken using 50mm lens (35mm
film equivalent). If the actual focal length differs significantly from this value, manual calibration is
recommended. More details on manual camera calibration can be found in the Camera calibration
section.

NA (Not aligned)
Notifies that external camera orientation parameters have not been estimated for the image yet.

Images loaded to Metashape will not be aligned until you perform the next step - photo alignment.

==
Notifies that Camera Station type was assigned to the group.

Scanned images

M etashape supports processing of scanned photos. All scanned photosfrom the same anal og camerashould
be placed in a designated calibration group. Metashape will automatically put the photos in the same
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calibration group, providing that they have been scanned to the images of the same resolution. Otherwise,
the images should be moved to a designated calibration group manually. Read more in Scanned images
with fiducial marks section.

To load scanned photos
1. Add scanned photos to the project using Add Folder... command from the Wor kflow menu.

2. Inthe Add Folder dialog box browse to the parent folder containing subfolders with images. Then
click Select Folder button.

3. Click OK button to close the dialog. Display of images in Metashape window.

Multispectral imagery

Multispectral imagery

M etashape supports processing of multispectral images saved as multichannel (single page) TIFF files.
The main processing steps (Align photos, Build Dense Cloud, Build DEM, Build Orthomosaic) for
multispectral images are performed based on the primary channel, which can be selected by the user. All
spectral bands are processed together to form a multispectral orthomosaic with the same bands as in the
source images during orthomosaic export.

Workflow for multispectral imagery processing does not differ from the common workflow for RGB
photos, except the additional primary channel selection step performed after adding images to the project.
We recommended select the band which is sharp and as much detailed as possible as a primary channel
for processing.

To select primary channel

1. Add multispectral images to the project using Add Folder... command from the Workflow menu.

2. Select folder containing the imagesin the Add Folder... dialog window. Click Select Folder button.
3. Select Multi-camera system command in the Add Photos dialog.

4. Select Set Primary Channel... command from the chunk context menu in the Wor kspace pane.

5. Inthe Set Primary Channel dialog select the channel to be used as primary and click OK button.

Display of imagesin M etashapePhotos panewindow will be updated according to the primary channel
selection.

[{ Note

e Set Primary Channel... command is available for RGB images as well. You can either indicate
only one channel to be used as the basis for photogrammetric processing or leave the parameter
value as Default for al three channels to be used in the processing.

Multispectral orthomosaic export is supported in GeoTIFF format only. When exporting in other formats,
only primary channel will be saved.

Vignetting is modeled in Metashape using a 3 degree bivariate polynomial:

V(x, y) = exp(sum;j ; * X' * y)
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- wherex and y represent normalized pixel coordinates, so that top |eft corner of the image has coordinates
(-1, -1), and bottom right corner has coordinates (1, 1).

To compensate vignetting in the image, each pixel value is divided by corresponding vignetting factor.
I = 1 / exp(sumij cj * X' * y)

where

x=2*(i+05)/w-1

y=2*(+05)/h-1

i, - integer column and row pixel coordinates

w, h —image width and height in pixels

X, Y - normalized pixel coordinates

ljj - pixel intensity in the original image with vignetting

I'jj - pixel intensity in the corrected image without vignetting

Thermal images

Metashape supports the processing of thermal images in TIFF and R-JPEG formats. Thermal images
contain information about object temperature. Y ou can usedatafrom AscTec, WIRIS camerasand cameras
with R-JPEG data, for example - DJl Zenmuse. The AscTec camerafile format is ARA, WIRIS supports
TIFF format.

Toload thermal images

1. Addthermal images to the project using Add Photos... command from the Workflow menu.

2. Choose images in the Add Photos dialog.

3. Then click Open button.

If you want to configure Palette for the images, following steps:

1. Select one of the available presets or customize Palette for the images in Raster Calculator dialog.
2. Click Apply button. The operation is compl eted.

3. Click OK button to close the dialog. Images will be displayed in M etashape window.
4  Note

» For R-JPEG data you need to use multi-camera system method. See Multispectral imagery
section.

Satellite images

M etashape can process panchromatic and multispectral satelliteimages, provided that sufficiently accurate
Rational Polynomial Coefficients (RPC) datais available for each image.

RPC coefficients are loaded automatically if they are present in RPC coefficient image tag. Alternatively,
they can be loaded from supplementary rpc.txt or .rpb files.
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Toload satellite images

1

If RPC coefficients are provided in supplementary rpc.txt or .rpb files make sure that Load satellite
RPC data from auxiliary TXT files option is enabled in the Advanced tab of the Preferences dialog
before adding images to the project.

Add satellite images to the project using Add Photos command from the Workflow menu.

Make sure that RPC coefficients are loaded correctly: check that Camera type is set to RPC for all
calibration groups which contain satellite images in Camera Calibration dialog.

Satelliteimages often have very large resol ution and navigation in the Photo view may be slow. Metashape
can take advantage of multi resolution TIFF fileswith overviews, which greatly improve user experience.
If the available satellite images do not contain overviews, it is highly recommended to create them first.
This can be done using Convert Images command from the Export submenu from the File menu.

To generate optimized TIFF imagesfor faster navigation in Photo view mode

1. Addoriginal imagesto an empty project as described in the previous procedure.

2. Select Convert Images... command from the File > Export menu.

3. Inthe Convert Images dialog make sure that Write tiled TIFF and Generate TIFF overviews options
areenabled. If your imagesarelarger than 4GB you will also need to enable Write BigTIFF fileoption.

4. Make sure that Filename template is set to some reasonable value. The default { filename} .{ fileext}
value should work in most cases.

5. Inthe Apply to section select All cameras and click OK button.

6. Inthe Select Folder dialog select a folder to save optimized images. It is recommended to select a
new empty folder for the images to make sure that original files are not overwritten.

7. Click Select Folder button to start conversion.

8. When conversion is complete generated images can be [oaded into a new project for processing.

4 Note

« Convert Images command automatically embeds RPC coefficientsin the generated files, soit is
not necessary to copy auxiliary TXT files to the new images folder.

Working with tiled satellite imagery

High resolution satellite images are often provided in atiled form, where each image is split in to multiple
TIFF files. Before loading into Metashape such data needs to be converted to combined TIFF files first.
This can be done using gdal_trandlate utility from GDAL package.

Below are example commands that can be used to perform conversion for different formats. These
commandswill generate multi-resolution TIFF fileswith overviews and with embedded RPC coefficients.

Converting DIMAP datasets

DIMAP images contain an XML index file for each image, which can be used for conversion using the
following commands:

gdal_trandate DIM_<datasethame>. XML combined.tif -co TILED=YES

gdaladdo -r average combined.tif 24 8 16 32
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Converting DigitalGlobe datasets

Tiled DigitalGlobe images contain a TIL tile index file for each image, which needs to be used for
conversion:

gdal_trandate <datasetname>.T1L combined.tif -co TILED=YES

gdaladdo -r average combined.tif 24 8 16 32
Rigid camerarigs

Multi-sensor system

Metashape supports processing of multispectral datasets captured with multiple synchronized sensors
operating in the same or different spectral ranges. In this case multiple images are available for each
position and Metashape will estimate calibration parameters for each sensor separately as well as their
relative orientation within camerarig.

To load images from multi-sensor system

L Select “—@Add Folder... command from the Wor kflow menu.

2. Inthe Add Folder dialog box browse to the parent folder containing subfolders with images. Then
click Select Folder button.

3. Inthe Add Photos dialog select the data layout Multi-camera system.

4. Created chunk with multispectral cameras will appear on the Workspace pane. The labels of the
multispectral cameras would be taken from the image filenames of the first image folder used.

To set relative camera offset for synchronized cameras manually
1. Select Camera Calibration command from the Tools menu.

2. Intheleft-hand part of the Camera Calibration dialog box select slave camerato set up offset
3. Switch to Save offset tab.

4. Check Enable reference option.

5. Set up therelative camera offset manually.

6. If needed repest procedure for each slave camera.

M etashape uses the following coordinate system for slave sensor offsets:

» X axispoints to the right side of the image,

Y axis points to the bottom of the image,

» Z axis points along the viewing direction of the master sensor.

Slave Camera Offset is calculated by the following formula:

Prmaster = Rx(omega) * Ry(phi) * Ra(keppa) * Petave + T

Where:

Pyave — point coordinates in slave sensor coordinate system,
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Prmaster — point coordinates in master sensor coordinate system,
Rx(omega): Ry(phi» Rz(kappa) — rotation matrices around corresponding axes in clockwise direction,
T — dave sensor offset.

To change master camera, you can use the corresponding command from the context menu of the camera
group displayed in the lefthand part of the Camera Calibration dialog.

The default assumption is that synchronized sensors have the same position in space. In case distance
between the sensors cannot be neglected, it is possible for Metashape to calculate relative sensor offset.
If offset parameters are known they can be input manually.

To calculaterelative camera offset for synchronized sensors
1. Select Camera Calibration command from the Tools menu.

2. Inthe left-hand part of the Camera Calibration dialog box select slave sensor to calculate relative
offset for. Slave sensors are displayed as list for the corresponding master sensor.

Switch to Save offset tab.

Check Adjust location option.

o > »

The distance for the active slave sensor will be calculated in relation to master sensor.
6. If needed repeat procedure for each slave sensor.

In case of rigid camerarigsvariance of rel ative offset can beinspected in the GPSINS Offset tab of Camera
Calibration dialog, see Variance column. Valuesin the Variance column are equal to squared standard
deviation of relative offset. Read more in Covariance matrix section.

Multi-camera system data

Metashape supports processing of multispectral datasets captured with multiple synchronized cameras
operating in different spectral ranges. In this case multiple images are available for each position and
M etashape will estimate calibration parameters for each cameraaswell astheir relative orientation within
camerarig.

Multi-camera system layout is formed at the moment of adding photos to the chunk. It will reflect the data
layout used to store image files. Therefore it is necessary to organize files on the disk appropriately in
advance. The following data layouts can be used with Metashape:

a. All image planes from each position are contained in a separate multilayer image. The number of
multilayer imagesis equal to the number of camera positions.

b. Corresponding planes from all camera positions are contained in a separate subfolder. The number of
subfoldersis equal to the number of planes.

¢. Incaseof MicaSense cameras (RedEdge, Altum), Parrot Sequoiaand DJI Phantom 4 Multispectral, the
images will be automatically arrange into camera and plane groups based on available meta data.

Once the data is properly organized, it can be loaded into Metashape as a multi-camera system. The
exact procedure depends on whether the multilayer layout (variant a) or multifolder layout (variant b) or
MicaSense datais used.

Toload data from from multilayer images

1. Select Add Folder... command from the Workflow menu.
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2. In the Add Photos dialog browse to the folder containing multilayer images and select files to be
processed. Then click Open button.

3. Inthe Add Photos dialog select Multi-camera system.
4. Created chunk with multispectral cameras will appear on the Workspace pane.

When you create chunk with multispectral cameras from multilayer images you need to set unique Layer
index for each slave sensor.

To set unique Layer index for a slave sensor
Select Camera Calibration command from the Tools menu.
Switch to slave sensor in the left hand side menu.

In the Italic tab set unique value for Layer index parameter.

A W b P

Repeat procedure for each dlave sensor.

To load data from MicaSense (RedEdge, Altum), Parrot Sequoia, DJI Phantom 4
Multispectral cameras

1. Select Add Folder... command from the Workflow menu.

2. Inthe Add Photos dialog box browse to the folder containing MicaSense images and select files to
be processed. Then click Open button.

3. Inthe Add Photos dialog select Multi-camera system.

4. Created chunk with multispectral cameras will appear on the Workspace pane. The labels of the
multispectral cameras would be taken from the first band image filenames.

For multispectral cameras the default sensors order is defined by the CentralWavelength value from the
images metadata (sensor with the lowest value is added first: transparency alpha channel is added last).
The default order can be changed from Camera Calibration dialog available from Tools menu. On the
Bands tab the Layer index can be set for each sensor as described above for multilayer images.

Y ou can perform reflectance calibration for multispectral imageres acquired using MicaSense (RedEdge,
Altum and etc.), Parrot Sequoia, DJI Phantom 4 Multispectral cameras. Read more in Vegetation indices
calculation section.

Laser scans data

Integration of terrestrial laser scanning data into photogrammetry processing workflow is supported in
M etashape based on spherical panoramas acquired by alaser scanner. The panoramas are used at theimage
matching step. Intensity map in utilized instead, if the scanner used is not capable of saving spherical
panoramas. During the dense cloud or depth maps based mesh generation operations, photogrammetric
depth maps are merged with the depth information coming from the laser scanner.

Toimport laser scans data
1. Select Import Laser Scans... command from the Import submenu of the File menu.
2. Select fileswith structured point cloud datain ASTM E57 or PTX formats in the Open dialog.

3. Specify the folder where the pre-processed laser scans will be saved to (can be re-used from that
location later without a need of completing the pre-processing procedure again).
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4. Click OK button to add the data to the active chunk.

If the project has both laser scans data and digital imagery for the same scenes, all the data should be
loaded to the same chunk and to be processed together.

Video Data

M etashape allowsfor video data processing aswell, which can be beneficial for quick inspection scenarios,
for example. The video is to be divided into frames which will be further used as source images for 3D
reconstruction.

Toimport avideofile

Select Import Video... command from the File menu.

In the Import Video dialog you can inspect the video and set the output folder for the frames.
Set the filename pattern for the frames and indicate the frame extraction rate.

Y ou can import part of the video, specify the parameters. Sart from and End at.

A

Click OK button for the frames to be automatically extracted and saved to the designated folder. The
images extracted from the video will be automatically added to the active chunk.

4 Note

* In Metashape you can choose the automatic frame step (Small, Medium, Large) or set the
parameter manually via Custom option. Once the parameter value is set, the program calcul ates
the shift for the framesto be extracted. For Small value, the shift of about 3% of the image width
will be taken into account. For Medium, it corresponds to 7% and for Large - 14% of the image
width.

After the frames have been extracted you can follow standard processing workflow for the images.

Aligning photos

The camera position at the time of image capture is defined by the interior and exterior orientation
parameters.

Interior orientation parameters include camera focal length, coordinates of the image principal point and
lens distortion coefficients. Before starting processing in Metashape the following configuration steps
should be performed:

» Separate calibration groups should be created for each physical camera used in the project. It is aso
recommended to create a separate calibration group for each flight or survey. For details see Camera
groups subsection of Loading images to the project.

* For each calibration group initial approximation of interior orientation parameters should be specified.
In most casesthisisdone automatically based on EX1F metadata. When EXIF metadataisnot available,
initial interior orientation parameters needs to be configured according to the camera certificate.

* When using images captured with analog camera, it isnecessary to set the cameracalibration parameters
manually and also add fiducial marks on each image (for additional information see Scanned images
with fiducial marks section).

Exterior orientation parameters define the position and orientation of the camera. They are estimated
during image alignment and consist of 3 translation components and 3 Euler rotation angles (see Camera
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orientation angles conventions subsection of Setting coordinate system). In many cases survey systemsare
equipped with GPS/GNSS systems for measuring exterior orientation parameters during capture which
can be used as additional measurements during bundle adjustment. To import a file with exterior images
orientation parameters see Assigning reference coordinates subsection of Setting coordinate system.

Exterior and interior image orientation parameters are cal culated using aerotriangul ation with bundle block
adjustment based on collinearity equations. Aerotriangulation allows to jointly adjust photogrammetric
measurements of tie points together with onboard measurements. As aresult, more accurate and reliable
exterior orientation parameters of images are obtained.

The result of this processing step consists of estimated exterior (translation and rotation) and interior
camera orientation parameters together with atie point cloud containing triangul ated positions of matched
image points.

To align a set of photos
1. Select Align Photos... command from the Workflow menu.

2. Inthe Align Photos dialog box select the desired alignment options. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Alignment having been completed, computed camera positions and a tie point cloud will be displayed.
You can inspect alignment results and remove incorrectly positioned photos, if any. To see the matches
between any two photos use View Matches... command from a photo context menu in the Photos pane.

Incorrectly positioned photos can be realigned.

Torealign a subset of photos

1. Reset alignment for incorrectly positioned cameras using Reset Camera Alignment command from
the photo context menu.

2. Set markers (at least 4 per photo) on these photos and indicate their projections on at least two
photos from the already aligned subset. M etashape will consider these pointsto be true matches. (For
information on markers placement refer to the Setting coordinate system section).

3. Select photosto berealigned and use Align Sel ected Cameras command from the photo context menul.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

When the alignment step is completed, the point cloud and estimated camera positions can be exported
for processing with another software if needed.

Image quality

Poor input, e. g. vague photos, can influence alignment results badly. To help you to exclude poorly
focused images from processing M etashape suggests automatic image quality estimation feature. Images
with quality value of less than 0.5 units are recommended to be disabled and thus excluded from
photogrammetric processing, providing that the rest of the photos cover the whole scene to be

reconstructed. To disable a photo use @ Disable button from the Photos pane toolbar.

M etashape estimates image quality for each input image. The value of the parameter is calculated based
on the sharpness level of the most focused part of the picture.
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To estimate image quality

1 Switch to the detailed view in the Photos pane using ©== Details command from the Change menu

on the Photos pane toolbar.
2.  Sdlect al photos to be analyzed on the Photos pane.

3. Right button click on the selected photo(s) and choose Estimate Image Quality command from the
context menu.

4. Once the analysis procedure is over, a figure indicating estimated image quality value will be
displayed in the Quality column on the Photos pane.

Alignment parameters

Align Photos

=eneral

Accuracy: High

Generic preselection

Reference preselection Source
Reset current alignment
Advanced
Key point limit: 40,000
Tie point limit: 10,000
Apply masks to: one

Exdude stationary tie points
Guided image matching

Adaptive camera model fitting

oK

"Align Photos" dialog

The following parameters control the photo alignment procedure and can be modified in the Align Photos
dialog box:
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Accuracy
Higher accuracy settings help to obtain more accurate camera position estimates. Lower accuracy
settings can be used to get the rough camera positions in a shorter period of time.

While at High accuracy setting the software workswith the photos of the original size, Medium setting
causes image downscaling by factor of 4 (2 times by each side), at Low accuracy source files are
downscaled by factor of 16, and Lowest value means further downscaling by 4 times more. Highest
accuracy setting upscales the image by factor of 4. Since tie point positions are estimated on the
basis of feature spots found on the source images, it may be meaningful to upscale a source photo
to accurately localize atie point. However, Highest accuracy setting is recommended only for very
sharp image data and mostly for research purposes due to the corresponding processing being quite
time consuming.

Generic preselection
The alignment process of large photo sets can take a long time. A significant portion of this time
period is spent on matching of detected features across the photos. Image pair presel ection option may
speed up this process due to selection of a subset of image pairs to be matched.

In the Generic preselection mode the overlapping pairs of photos are selected by matching photos
using lower accuracy setting first.

4 Note

Using only Refer ence presel ection mode without Generic preselection fits best the case when
only afew tie points are detected during theimage matching stage, it may happen, for example,
for aerial surveys of forested areas or crop fields.

Reference preselection

In the Sour ce presel ection mode the overlapping pairs of photos are selected based on the measured
camera locations (if present). For oblique imagery it is necessary to set Capture distance value
(average ground height in the same coordinate system which is set for camera coordinates data) in the
Settings dialog of the Reference pane to make the preselection procedure work efficiently. Capture
distance information must be accompanied with yaw, pitch, roll/omega, phi, kappa datafor cameras.
Rotation parameters should be input in the Reference pane. Then the presel ection based on the new 3D
points calculated as original 3D point and vector in the direction of the camera view with the length
equal to the input Capture Distance value.

The Estimated preselection mode takes into account the calculated exterior orientation parameters
for the aligned cameras. That is, if the alignment operation has been already completed for the project,
the estimated camera locations will be considered when the Align Photos procedure is run again with
the Estimated presel ection selected.

When using Sequential preselection mode the correspondence between the images is determined
according to the sequence of photos (the sequence number of the image) it is worth noting that with
this adjustment, the first with the last images in the sequence will also be compared.

Reset current alignment
If thisoptionis checked, all thetie, and key, and matching points will be discarded and the alignment
procedure will be started from the very beginning.

Additionally the following advanced parameters can be adjusted.

Key point limit
The number indicates upper limit of feature points on every image to be taken into account during
current processing stage. Using zero value allows Metashape to find as many key points as possible,
but it may result in a big number of lessreliable points.
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Tiepoint limit
The number indicates upper limit of matching points for every image. Using zero value doesn't apply
any tie point filtering.

Apply mask to

If apply mask to key points option is selected, areas previously masked on the photos are excluded
from feature detection procedure. Apply mask to tie points option means that certain tie points are
excluded from alignment procedure. Effectively thisimpliesthat if some areais masked at least on a
single photo, relevant key points on the rest of the photos picturing the same areawill be also ignored
during alignment procedure (atie point is a set of key points which have been matched as projections
of the same 3D point on different images). This can be useful to be able to suppress background in
turntable shooting scenario with only one mask. For additional information on the usage of masks
please refer to the Using masks section.

Exclude stationary tie points
Excludes tie points that remain stationary across multiple different images. This option enables
alignment without masks for datasets with a static background, e.g. in a case of a turntable with a
fixed camera scenario. Also enabling this option will help to eliminate false tie points related to the
camera sensor or lens artefacts.

Guided image matching

This option allows to effectively boost the number of keypoints per image as if the value of Key
point limit was straightforwardly increased, but without significant growth of processing time. Using
this parameter can improve results for images with vegetation (wooded terrain, grass, cornfields
and so on), spherical cameras and high resolution images (captured by professional grade cameras,
satellites or acquired by high-resolution scanning of the archival aerial images). To enable Guided
image matching, check corresponding option in Align Photos dialog and adjust Key point limit per
Mpx if needed. The number of detected points per image is calculated as (Keypoint limit per Mpx) *
(image size in Mpx). Small fraction will be extensively matched and used as guidance for matching
of remaining points.

Adaptive camera model fitting

This option enables automatic selection of camera parametersto beincluded into adjustment based on
their reliability estimates. For data sets with strong camera geometry, like images of a building taken
from all the sides around, including different levels, it helps to adjust more parameters during initial
camera alignment. For data sets with weak camera geometry , like atypical aerial data set, it helps
to prevent divergence of some parameters. For example, estimation of radial distortion parameters
for data sets with only small central parts covered by the object is very unreliable. When the option
is unchecked, Metashape will refine only the fixed set of parameters: focal length, principal point
position, three radial distortion coefficients (K1, K2, K3) and two tangential distortion coefficients
(PL, P2).

[{ Note

« Tie point limit parameter allows to optimize performance for the task and does not generally
effect the quality of thefurther model. Recommended valueis4000. Too high or too low tie point
limit value may cause some parts of the dense point cloud model to be missed. Thereason isthat
M etashape generates depth maps only for pairs of photos for which number of matching pointsis
above certain limit. Thislimit equalsto 100 matching points, unless moved up by thefigure"10%
of the maximum number of matching points between the photo in question and other photos,
only matching points corresponding to the area within the bounding box being considered.”

» The number of tie points can be reduced after the alignment process with Tie Points - Thin Point
Cloud command available from Tools menu. As aresultstie point cloud will be thinned, yet the
alignment will be kept unchanged.
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Components

Someimage subsets may be not aligned asthe result of the Align Photos operation, if the sufficient amount
of tie points was not detected between such subsets. Such subsets which are not aligned with the main
subset will be grouped into individually aligned parts - Components.

The components into which the camera alignment have been split after the Align Photos operation will be
displayed in the chunk's contents of the Workspace pane inside the Components folder.

To align componentswith each other

1. Manually create markers which would connect the components with each other. It isrequired to use
at least 3 markers between each pair of components that do not lay on the same line. See information
about placing markersin Setting coordinate system section.

2. Inorder to switch between the components doubl e-click with the left mouse button on the component's
label in the Wor kspace pane.

3. After al the components have been aligned with the help of markers, select them in the Workspace
pane and then use the Merge Components command from the context menu.

Incremental image alignment

In case some extra images should be subaligned to the set of already aligned images, you can benefit
from incremental image alignment option. To make it possible, two rules must be followed: 1) the scene
environment should not have changed significantly (lighting conditions, etc); 2) do not forget to switch on
Keep key points option in the Preferences dialog, Advanced tab BEFORE the whole processing is started.

To subalign some extra images added to the chunk with already aligned set of
images

1. Add extraphotos to the active chunk using Add photos command from the Workflow menu.
2. Open Align photos dialog from the Wor kflow menu.

3. Set alignment parameters for the newly added photos. IMPORTANT! Uncheck Reset alignment
option.

4. Click OK. Metashapewill consider existing key pointsand try to match them with key points detected
on the newly added images.

Point cloud generation based on imported camera data

M etashape supportsimport of external and internal camera orientation parameters. Thus, if precise camera
data is available for the project, it is possible to load them into Metashape along with the photos, to be
used asinitial information for 3D reconstruction job.

Toimport external and internal camera parameters
1. Select Import Cameras command from the File menu.

2. Select the format of the file to be imported.
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3. Browsetothefile and click Open button.

4. The datawill be loaded into the software. Camera calibration data can be inspected in the Camera
Calibration dialog, Adjusted tab, available from Tools menu. If theinput file contains some reference
data (camera position datain some coordinate system), the datawill be shown on the Reference pane,
View Estimated tab.

Cameradata can beloaded in one of the following formats: Agisoft (*.xml), BINGO (*.dat), Inpho Project
File (*.prj), Blocks Exchange (*.xml), Bundler (*.out), Autodesk FBX (*.fbx), VisionMap Detailed Report
(*.txt), Realviz RZML (*.rzml), Alembic (*.abc).

Once the data is loaded, Metashape will offer to build point cloud. This step involves feature points
detection and matching procedures. Asaresult, atie point cloud - 3D representation of the tie-points data,
will be generated. Build Point Cloud command is available from Tools - Tie Points menu. Parameters
controlling Build Point Cloud procedure are the same as the ones used at Align Photos step (see above).

Building dense point cloud

Metashape allows to create a dense point cloud based on the calculated exterior and interior image
orientation parameters.

Dense point cloud generation is based on depth maps cal culated using dense stereo matching. Depth maps
are calculated for the overlapping image pairs considering their relative exterior and interior orientation
parameters estimated with bundle adjustment. Multiple pairwise depth maps generated for each camera
are merged together into combined depth map, using excessive information in the overlapping regions to
filter wrong depth measurements.

Combined depth maps generated for each camera are transformed into the partial dense point clouds,
which are then merged into a final dense point cloud with additional noise filtering step applied in the
overlapping regions. The normalsin the partial dense point clouds are cal culated using planefitting to the
pixel neighborhood in the combined depth maps, and the colors are sampled from the images.

For every point in thefinal dense point cloud the number of contributing combined depth mapsis recorded
and stored as a confidence value. This confidence value can be used later to perform additional filtering of
low confidence points using the Filter by Confidence... command from the Tools > Dense Cloud menu.

M etashape tendsto produce extradense point clouds, which are of almost the same density, if not denser, as
LIDAR point clouds. A dense point cloud can be edited and classified within M etashape environment and
used as a basis for such processing stages as Build Mesh, Build DEM, Build Tiled Model. Alternatively,
the point cloud can be exported to an external tool for further analysis.

To build adense point cloud

1 Check the reconstruction volume bounding box. To adjust the bounding box use the Resize

Region, & Move Region and gg’ Rotate Region toolbar buttons. To resize the bounding box, drag
corners of the box to the desired positions; to move - hold the box with the left mouse button and
drag it to the new location.

2. Select the Build Dense Cloud... command from the Wor kflow menu.

3. Inthe Build Dense Cloud dialog box select the desired reconstruction parameters. Click OK button
when done.
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4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

4 Note

« More than one instance of Dense cloud can be stored in one chunk. In case you want to save
current Dense cloud instance and build new onein current chunk, right-click on Dense cloud and
uncheck Set as default option. In case you want to save current Dense cloud instance and edit its
copy, right-click on Dense cloud and choose Duplicate option.

Build Dense Cloud parameters

Build Dense Cloud

General
Quality: High
Advanced
Depth filtering: Mild
Reuse depth maps

Calculate point colors

Calculate point confidence

Lok ] Cancel

"Build Dense Cloud" dialog

Quality
Specifiesthe desired quality of the depth maps genration. Higher quality settings can be used to obtain
more detail ed and accurate geometry, but they require longer timefor processing. Interpretation of the
quality parameters here is similar to that of accuracy settings given in Photo Alignment section. The
only differenceisthat inthiscase UltraHigh quality setting means processing of original photos, while
each following step implies preliminary image size downscaling by factor of 4 (2 times by each side).

Additionally the following advanced parameters can be adjusted.

Depth filtering modes
At the stage of dense point cloud generation reconstruction M etashape cal culates depth mapsfor every
image. Due to some factors, like noisy or badly focused images, there can be some outliers among
the points. To sort out the outliers Metashape has several built-in filtering algorithms that answer the
challenges of different projects.

If there are important small details which are spatially distinguished in the scene to be
reconstructed, then it is recommended to set Mild depth filtering mode, for important features
not to be sorted out as outliers. This value of the parameter may also be useful for aerial projects
in case the area contains poorly textured roofs, for example. Mild depth filtering mode is also
required for the depth maps based mesh reconstruction.

If the area to be reconstructed does not contain meaningful small details, then it is reasonable
to choose Aggressive depth filtering mode to sort out most of the outliers. This value of the
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parameter normally recommended for aerial data processing, however, mild filtering may be
useful in some projects as well (see poorly textured roofs comment in the mild parameter value
description above).

Moderate depth filtering mode brings results that are in between the Mild and Aggressive
approaches. Y ou can experiment with the setting in case you have doubts which mode to choose.

Additionally depth filtering can be Disabled. But this option is not recommended as the resulting
dense cloud could be extremely noisy.

The filtering modes control noise filtering in the raw depth maps. This is done using a connected
component filter which operates on segmented depth maps based on the pixel depth values. The
filtering preset control a maximum size of connected components that are discarded by thefilter.

[ Note

 Stronger filter presets remove more noise, but also may remove useful information in case there
are small and thin structures in the scene.

Reuse depth maps
Depth maps available in the chunk can be reused for the dense cloud generation operation. Select
respective Quality and Depth filtering parameters values (see info next to Depth maps label on the
Workspace pane) in Build Dense Cloud dialog and then check Reuse depth maps option.

Calculate point colors
This option can be unchecked in case the points color is not of interest. This will allow to save up
processing time.

Calculate point confidence
If the option is enabled, the Metashape will count how many depth maps have been used to generate
each dense cloud point. This parameter can used for dense cloud filtering (see Editing point cloud).

Import point cloud

Metashape alows to import a point cloud to be interpreted at further processing stages as a dense
point cloud. If you want to upload a dense point cloud got from some external source (photogrammetry
technology, laser scanning, etc), you can use Import points command from the File menu. In the Import
points dialog browse to afile in one of the supported formats and click Open button.

Dense point cloud can beimportedin oneof thefollowing formats: Wavefront OBJ, Stanford PLY , ASPRS
LAS, LAZ, ASTM E57, ASCII PTS.

Building mesh

Mesh based on point cloud or depth maps data

Metashape can reconstruct polygonal mesh model based on the point cloud information (Dense Cloud,
Sparse Cloud, Point Cloud imported from external source) or based on the depth maps data.

To build amesh

1. Check the reconstruction volume bounding box. If the model has aready been referenced, the
bounding box will be properly positioned automatically. Otherwise, it is important to control its
position manually.
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To adjust the bounding box manually, use the Resize Region, % Move Region and 22; Rotate
Region toolbar buttons. Rotate the bounding box and then drag corners of the box to the desired
positions - only part of the scene inside the bounding box will be reconstructed. If the Height field
reconstruction method is to be applied, it is important to control the position of the red side of the
bounding box: it definesreconstruction plane. Inthis case make sure that the bounding box is correctly
oriented.

2. Select the Build Mesh... command from the Wor kflow menu.

3. Inthe Build Mesh dialog box select the desired reconstruction parameters. Click OK button when
done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

£ Note

» More than one instance of Mesh can be stored in one chunk. In case you want to save current
Mesh instance and build new one in current chunk, right-click on Mesh and uncheck Set as
default option. In case you want to save current Mesh instance and edit its copy, right-click on
Mesh and choose Duplicate option.

Build Mesh parameters

Build Mesh

General

Source data: Dense doud
Surface type: Arbitrary (30)
Quality:

Face count: High (4,737,825)

Advanced

Interpolation: Enabled (default)

Depth filtering:

Point dasses: Al

Calculate vertex colors

LUse STICT volumeTIC Masks

Reuse depth maps

Lok ] Cancel

"Build Mesh" dialog

Metashape supports severa reconstruction methods and settings, which help to produce optimal
reconstructions for a given data set.
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Sour ce data
Specifies the source for the mesh generation procedure.

» Tie pointscan be used for fast 3D model generation based solely on the tie point cloud.

» Densecloud setting will result in longer processing time but will generate high quality output based
on the previously reconstructed or imported dense point cloud.

» Depth maps setting allows to use al the information from the input images more effectively
and is less resource demanding compared to the dense cloud based reconstruction. The option
is recommended to be used for Arbitrary surface type reconstruction, unless the workflow used
assumes dense cloud editing prior to the mesh reconstruction.

Surfacetype

» Arbitrary surface type can be used for modeling of any kind of object. It should be selected for
closed objects, such as statues, buildings, etc. It doesn't make any assumptions on the type of the
object being modeled, which comes at a cost of higher memory consumption.

» Height field surface type is optimized for modeling of planar surfaces, such as terrains or
basereliefs. It should be selected for aerial photography processing as it requires lower amount of
memory and allows for larger data sets processing.

Quality
Specifies the desired reconstruction quality of the depth maps, providing that they are selected as a
source option. Higher quality settings can be used to obtain more detailed and accurate geometry, but
they require longer time for the processing.

Interpretation of the quality parameters here is similar to that of accuracy settings given in Photo
Alignment section. The only differenceisthat in this case UltraHigh quality setting means processing
of original photos, while each following step implies preliminary image size downscaling by factor
of 4 (2 times by each side). For depth maps based mesh generation Mild filtering option is used by
default, unless Reuse depth maps option is enabled. Aggressive filtering can be used if the excessive
geometry (such as isolated mesh components around the reconstructed object) is observed, however,
some fine level thin elements may be lost due to this depth filtering mode selection.

Face count

Specifiesthe maximum number of polygonsinthefinal mesh. Suggested values (High, Medium, Low)
present optimal number of polygons for amesh of a corresponding level of detail. For the dense cloud
based reconstruction they are cal culated based on the number of pointsin the source dense point cloud:
theratio is 1/5, 1/15, and 1/45 respectively. It is still possible for a user to indicate the target number
of polygonsin the final mesh through the Custom value of the Face count parameter. Please note that
while too small number of polygonsis likely to result in too rough mesh, too huge custom number
(over 10 million polygons) is likely to cause model visualization problemsin external software.

Additionally the following advanced parameters can be adjusted.

I nterpolation

If interpolation mode is Disabled it leads to accurate reconstruction results since only areas
corresponding to dense point cloud points are reconstructed. Manual hole filling is usually required
at the post processing step.With Enabled (default) interpolation mode Metashape will interpolate
some surface areas within acircle of acertain radius around every dense cloud point. Asaresult some
holes can be automatically covered. Y et some holes can still be present on the model and are to be
filled at the post processing step. In Extrapolated mode the program generates holeless model with
extrapolated geometry. Large areas of extra geometry might be generated with this method, but they
could be easily removed later using selection and cropping tools.
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Point classes
Specifiesthe classes of the dense point cloud to be used for mesh generation. For example, select only
Ground Points class to produce a DTM as opposed to a DSM. Preliminary Classifying dense point
cloud procedure should be performed for this option of mesh generation to be active. Option is only
applicable to dense cloud based reconstruction.

Calculate vertex colors
If source data has color information (point cloud colors or images are present for the depth maps based
calculation) enabling this option would allow to calcul ate the colors for the mesh vertices and display
the interpolated colors for the mesh polygonsin Shaded view mode.

Use strict volumetric masking

When this option is enabled, space volume covered with mask from at least one photo will be
suppressed. Each mask is strict - so you should use them as little as possible to prevent accidental
suppressing some surface parts. Each mask al so makes mesh reconstruction slower. For example strict
volumetric masks are useful to suppress noise between fingers by masking space between them from
single camera. Also thisis useful to suppress textureless background stuck to object contours - by
masking out background from single camera. For additional information on the usage of masks please
refer to the Using masks section. The option is only applicable for the Depth Maps source option
selected.

Reuse depth maps
If available depth maps should be reused for mesh generation, select respective Quality (seeinfo next
to Depth maps label on the Workspace pane in the chunk's contents) and then check Reuse depth maps
option. The option is applicable to the depth maps based reconstruction method only.

4 Note

« Metashape tends to produce 3D models with excessive geometry resolution, so it may be
reasonable to perform mesh decimation after geometry computation. More information on mesh
decimation and other 3D model geometry editing tools is given in the Editing model geometry
section.

Building model texture

Color calibration

If the lighting conditions have been changing significantly during capturing scenario, it is recommended
to use Calibrate colors option from the Tools menu before Build texture procedure. The option can help
to even brightness and white balance of the images over the data set. Please note that for large data sets
Calibrate colors procedure can turn out to be quite time consuming.

To calibrate colors
1. Sedlect Calibrate colors... command from the Tools menu.

2. Select the desired colors calibration parameters in the Calibrate colors dialog box. Click OK button
when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Color calibration parameters
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Calibrate Colors

Parameters

Source data: Maodel

Calibrate white balance

resct (RS

"Calibrate Colors" dialog
Sour ce data
Defines what data should be taken as the basis for overlapping areas estimation.
Tie points - the quickest yet the roughest estimation available.
Model - gives more precise results, but only on condition that the surface is detailed enough. This
parameter value is the recommended one if the aim is to calibrate colors to improve the quality of
the model texture.

DEM - is a reasonable alternative to Model value for large data sets when it is not feasible to
reconstruct solid polygonal model (mesh).

Calibrate white balance
Additional option to be switched on if white balance should be evened as well.

In Metashapeit is possibleto manually set color level adjustmentsfor one or moreimages using the Adjust
color levelstool. The Adjust Color Levelstool is available from the selected images context menu in the

Photos pane. If the image is very dark or overexposed, you can manually set adjust the levels for each
channel of theimage in the Color levels dialog of the tool or set the Average value for all channels.

Build Texture

The texture feature allows to build different types of textures for amodel.

To generate 3D model texture
1. Select Build Texture... command from the Workflow menu.

2. Select the desired texture generation parameters in the Build Texture dialog box. Click OK button
when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Texture generation parameters
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Buid Texture

General
Texture type: Diffuse map
Source data: Images
Mapping mode: Generic
Blending mode: Mosaic (default)
Texture sizefcount: 8192 |
Advanced

Enable hole filing

Enable ghosting filter

Transfi

Hre

m
m

Lok ] cancel

"Build Texture" dialog
The following parameters control various aspects of texture atlas generation:

Texturetype
Diffuse map - the basic texture that stores the colors of the model surface.

Normal map - texture map that allowsto calculate the illumination of the model parts from different
light sources in the post-processing workflow.

Occlusion map - atexturethat contai ns pre-cal culated shading information from background lighting.

Sour ce data
Images - alow to build a color texture map (diffuse map) based on the aligned images of the model
or transferred from another model with already generated color texture map.

3D model - the normal and occlusion texture maps can be built based on another model and the relief
of the model specified in the Source data field will be transferred to the current model. Usually it
is recommended to use the more detailed model as a source data for the Normal and Occlusion map
generation for the 3D model with the lower polygon count. Normal map option will not be available
in the Source data field, if less than two 3D model instances are present in the active chunk.

Mapping mode
The texture mapping mode determines how the object texture will be packed in the texture atlas.
Proper texture mapping mode selection helps to obtain optimal texture packing and, consequently,
better visual quality of the final model.

The default mode is the Generic mapping mode; it allows to parametrize texture atlas for arbitrary
geometry. No assumptions regarding the type of the scene to be processed are made; program tries
to create as uniform texture as possible.

In the Orthophoto mapping mode the whol e object surfaceistextured in the orthographic projection.
The Orthophoto mapping mode produces even more compact texture representation than the
Adaptive orthophoto mode at the expense of texture quality in vertical regions.
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In the Adaptive orthophoto mapping mode the object surface is split into the flat part and vertical
regions. The flat part of the surface is textured using the orthographic projection, while vertical
regionsaretextured separatel y to maintain accurate texture representation in such regions. Wheninthe
Adaptive orthophoto mapping mode, program tends to produce more compact texture representation
for nearly planar scenes, while maintaining good texture quality for vertical surfaces, such as walls
of the buildings.

Spherical mapping mode is appropriate only to a certain class of objects that have a ball-like form.
It allows for continuous texture atlas being exported for this type of objects, so that it is much easier
to edit it later. When generating texture in Spherical mapping mode it is crucial to set the Bounding
box properly. The whole model should be within the Bounding box. The red side of the Bounding
box should be under the model; it defines the axis of the spherical projection. The marks on the front
side determine the O meridian.

The Single camera mapping mode allows to generate texture from a single image. The image to be
used for texturing can be selected from 'Texture from' list.

The Keep uv mapping mode generates texture atlas using current texture parametrization. It can
be used to rebuild texture atlas using different resolution or to generate the atlas for the model
parametrized in the external software. Keep uv option preserves the original number of texture atlas
pages, i.e. count number can't be changed.

Blending mode (not used in Single camera mapping mode)
Selectstheway how color values of pixelsfrom different cameraswill be combined in thefinal texture.

Mosaic - implies two-step approach: it does blending of low frequency component for overlapping
images to avoid seamline problem (weighted average, weight being dependent on a number of
parameters including proximity of the pixel in question to the center of the image), while high
frequency component, that isin charge of picture details, is taken from a single image - the one that
presents good resolution for the area of interest while the camera view is ailmost along the normal to
the reconstructed surface in that point.

Average - uses the weighted average value of al pixels from individual photos, the weight being
dependent on the same parametersthat are considered for high frequency component in mosaic mode.

Max I ntensity - the image which has maximum intensity of the corresponding pixel is selected.
Min I ntensity - the image which has minimum intensity of the corresponding pixel is selected.

Disabled - the image to take the color value for the pixel from is chosen like the one for the high
frequency component in mosaic mode.

Texturesize/ count
Specifies the size (width & height) of the texture atlas in pixels and determines the number of files
for texture to be exported to. Exporting texture to severa files allows to archive greater resolution of
the final model texture, while export of high resolution texture to a single file can fail due to RAM
limitations.

Multi-pagetexture atlas generation issupported for Generic mapping mode only and K eep UV option,
if the imported model contains proper texture layout.

Additionally the following advanced parameters can be adjusted.

Enable holefilling
Thisoption is enabled on default since it helps to avoid salt-and-pepper effect in case of complicated
surface with numerous tiny parts shading other parts of the model. Only in case of very specific tasks
might it be recommended to switch the function off.
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Enable ghosting filter
In case the scene includes some thin structures or moving objects which failed to be reconstructed
as part of polygona model, it can be useful to switch on this option to avoid ghosting effect on the
resulting texture.

4 Note

» HDR texture generation requires HDR photos on input.

Improving texture quality

To improve resulting texture quality it may be reasonable to exclude poorly focused images from
processing at this step. M etashape suggests automatic image quality estimation feature. Imageswith quality
value of less than 0.5 units are recommended to be disabled and thus excluded from texture generation

procedure. To disable an image use @ Disable button from the Photos pane tool bar.

M etashape estimates image quality as a relative sharpness of the image with respect to other images in
the data set. The value of the parameter is calculated based on the sharpness level of the most focused
part of the picture.

Y ou can improve the texture using the Remove Lighting tool. Read more in Editing textures section of
the Manual for details.

To estimate image quality

1 Switch to the detailed view in the Photos pane using == Details command from the Change menu

on the Photos pane toolbar.
2. Select all imagesto be analyzed on the Photos pane.

3. Right button click on the selected image(s) and choose Estimate Image Quality command from the
context menu.

4. Once the analysis procedure is over, a figure indicating estimated image quality value will be
displayed in the Quality column on the Photos pane.

View Mesh UVs

In Metashape it is possible to analyze Mesh UV dtatistic. You can evaluate the quality of the resulting
texture using datain this dialog window.

To open UV Mapping dialog window
1. Seect View Mesh UVs... command on Mesh submenu from the Tools menu.

2. Check parameters for the texture was built in UV Mapping dialog box. Y ou can save data from this
page using Save button.
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UV Mapping

View
® Color
Diffuse map
Scaling
CQwverlap

Fesaolution

Statistics

Fill ratio: 69.6%
Cverlap ratio: 3.43e-05%
Min scaling: 63.1%
Max scaling: 135%

Min resolution: 75.5%
Max resolution:  116%

Page 1/2 -8 ®

"UV Mapping" dialog

The following parameters can be specified in UV Mapping dialog:

View
Color - displays the colors of the mesh vertices.

Diffuse map - display the basic texture that stores the colors of the model surface.
Scaling - displays the ratio of the area of the texture triangle to its area on the mesh surface.
Overlap - displays how many pixelsin the atlas correspond to more than one triangle in the mesh.

Resolution - displays the detail as a percentage. It is calculated as the ratio of the number of pixels
for the triangle from the most detailed photo to the area of the triangle in the atlas.

Statistics
Fill ratio: - displays the percentage of occupied pixels (in percent).

Overlap ratio: - value of the overlap in percent (in percent).
Min scaling: - minimum scaling value (in percent).
Max scaling: - maximum scaling value (in percent).

Min Resolution: - minimum resolution value (in percent).
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Max Resolution: - maximum resolution value (in percent).

Building tiled model

Hierarchical tiles format is a good solution for city scale modeling. It allows for responsive visualization
of large area 3D models in high resolution. The tiled model can be either opened in Metashape itself or
with Agisoft Viewer - acomplementary tool included in Metashape installer package, or with some other
external application which supports a hierarchical tiles format.

Tiled model is build based on dense point cloud, mesh or depth maps data. Hierarchical tiles are textured
from the source imagery.

[{ Note

« Build Tiled Model procedure can be performed only for projects saved in .PSX format.

< More than one instance of Tiled Model can be stored in one chunk. In case you want to save
current Tiled Model instance and build new onein current chunk, right-click on Tiled Model and
uncheck Set as default option. In case you want to save current Tiled Model instance and edit its
copy, right-click on Tiled Model and choose Duplicate option.

To build atiled model

1. Check the reconstruction volume bounding box - tiled model will be generated for the area within
bounding box only. To adjust the bounding box use the % Move Region, Resize Region and

82’ Rotate Region toolbar buttons. Rotate the bounding box and then drag corners of the box to the
desired positions.

2. Select the Build Tiled Model... command from the Wor kflow menu.

3. Inthe Build Tiled model dialog box select the desired reconstruction parameters. Click OK button
when done.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Reconstruction parameters
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Build Tiled Model

General
Source data: Depth maps
Quality: High
Pixel size (m): 0,000219425
Tile size: 256
Face count: Medium
Advanced
Depth filtering: Mild

Transfer model textur

m

Enable ghosting filter

aeptn maps

m

Reus

Merge tiled model

Lok ] Cancel

"Build Tiled Model" dialog

Sour ce data
Depth maps. Recommended for large projects when Build Mesh procedure is not feasible due to
processing time and result management issues.

Dense cloud. Can be used as an alternative to the depth maps based option in case the dense cloud has
been already generated for any other purposes, whereas the depth maps are not stored in the project
or have been generated with the filtering option different from Mild.

Mesh. Allows to keep all the details in the tiled model if a very detailed mesh has been generated
previously.

Pixel size (m)
Suggested value shows automatically estimated pixel size due to input imagery effective resolution.
It can be set by the user in meters.

Tilesize
Tile size can be set in pixels. For smaller tiles faster visualization should be expected.

Face count
Suggested values (High, Medium, Low) present optimal number of polygons for atiled model block
of acorresponding level of detail. Itisstill possiblefor auser to indicate the target number of polygons
in the final mesh through the Custom value of the Face count parameter.

Quality
Specifies the desired reconstruction quality of the depth maps, providing that they are selected as a
source option. Higher quality settings can be used to obtain more detailed and accurate geometry, but
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they require longer time for the processing. Interpretation of the quality parameters hereis similar to
that of accuracy settings given in Photo Alignment section. The only difference is that in this case
Ultra High quality setting means processing of origina photos, while each following step implies
preliminary image size downscaling by factor of 4 (2 times by each side). For depth maps based tiled
model generation Mild filtering option is used, unless Reuse depth maps option is enabl ed.

Additionally the following advanced parameters can be adjusted.

Transfer model texture
If there is a textured mesh model in the chunk, its texture can be reused for the tiled model texture
generationinstead of sourceimages. Theoptionisonly availableif Meshis selected asaSource option
for the tiled model generation.

Enable ghosting filter
In case the scene includes some thin structures or moving objects which fails to be reconstructed as
part of polygonal model, it can be useful to enable this option to avoid ghosting effect on the resulting
texture.

Reuse depth maps
Depth maps available in the chunk can be reused for the tiled model generation operation. Select
respective Quality and Depth filtering parameters values (see info next to Depth maps label on the
Workspace pane) in Build Tiled Model dialog and then check Reuse depth maps option. The optionis
only available if Depth maps are selected as a Source option for the tiled model generation.

Mer ge tiled model
This option allows to match the grid of tiles with the existing tiled model in the project and merge
newly created tiles with the existing model to the single tiled model.

Import Tiled Model
In Metashape you can add atile model to aproject using Import Tile Model command from the File menu.

Tiled model can be imported in Agisoft Tiled Model format.

Building digital elevation model

Digita elevation model (DEM) isa2.5D model of a surface represented in aform of aregular grid, with
height values stored per every cell of the grid. In Metashape DEM can be rasterized from a dense point
cloud, sparse cloud, mesh or generated directly from depth maps.

M etashape allowsto create both digital surface model (DSM), i.e. 2.5D model of the Earth surface with all
the objects on it, and digital terrain model (DTM) which represents the bare ground surface without any
objectslike plantsand buildings. DTM can be built only based on the dense point cloud data, which should
be classified into ground points and other semantic classes before DTM generation step. See Classifying
dense point cloud section of the manual for information about options to classify/filter dense point cloud
in Metashape software.

M etashape enablesto perform DSM/DTM-based point, distance, area, and volume measurements, as well
as generate cross-sections for the part of the scene selected by user. Furthermore, DEM can serve as
a source for contour lines calculations within Metashape software. More information on measurement
functionality can be found in Performing measurements on DEM section of the manual.

4 Note

« Build DEM procedure can be performed only for projects saved in .PSX format.
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« DEM can be calculated for referenced or scaled projects only. So make sure that you have set
a coordinate system for your model or specified at least one reference distance before going to
build DEM operation. For guidance on Setting coordinate system please go to Setting coordinate
system

» Morethan oneinstance of DEM can be stored in one chunk. In case you want to save curent DEM
instance and build new one in current chunk, right-click on DEM and uncheck Set as default
option. In case you want to save current DEM instance and edit its copy, right-click on DEM
and choose Duplicate option.

DEM iscalculated for the part of the model within the bounding box. To adjust the bounding box use the

% Resize Region and 22; Rotate Region toolbar buttons. Rotate the bounding box and then drag corners
of the box to the desired positions.

To build DEM

1. Select the Build DEM... command from the Workflow menu.

2. Inthe Build DEM dialog box set Coordinate system for the DEM generation or choose the projection
type.

3. Select source datafor DEM rasterization.

4. Click OK button when done.

5. The progress dialog box will appear displaying the current processing status. To cancel processing

click Cancel button.

Build DEM parameters
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Build DEM

Projection

Type: Geographic Planar Cylindrical

WGE5 84 (EPSG::4326)

Parameters

Source data: Dense doud
Quality:

Interpolation: Enabled {default)
Point dasses: All

Advanced

Depth filtering:

Reuse depth maps

Region
Setup boundaries:  5.651350 - | 5.656036 X
Reset 51.990857 - | 51993418 Y
Resolution {m): 0.274365

Total size (pix): 1171 ¥ 1032

ok ] Cancel

"Build DEM" dialog

Projection type
Geographic - allows to choose a geographic coordinate system from the dropdown list or upload
parameters of a customized geographical coordinate system. The coordinate system set by default
is the coordinate system previously selected for the model itself. Y ou can switch to a different one,
providing that corresponding datum transformation parameters are available.
Planar. Metashape alows to project DEM onto a plane set by the user. You can select projection
plane and orientation of the resulting DEM. The plane can be determined by a set of markers (if there
areno 3 markersin adesired projection planeit can be specified with 2 vectors, i. e. 4 markers). Planar
projection type may be useful for DEM generation in projects concerning facades, for example.
Cylindrical - allowsto project DEM on acylindrical surface. Inthis case height valueis calculated as
the distance from the model surface to the cylindrical surface. Refer to Building orthomosaic section
to see the options.
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Sour ce data
It is recommended to calculate DEM based on Dense Cloud data, as this option allows to perform
the point classification and surface generation based on the certain classes only. If the classification
is not required and the dense cloud is not needed by the task requirements, Depths Maps option is
recommended. Preliminary elevation data results can be generated from a Spar se Cloud, avoiding
Build Dense Cloud step for time limitation reasons. Mesh and Tiled M odel options can be used, if
DEM should follow the polygonal model precisely or dense cloud has not been reconstructed.

Quality
Specifies the desired reconstruction quality of the depth maps, providing that they are selected as a
source option. Higher quality settings can be used to obtain more detailed and accurate model, but
they require longer time for the processing. I nterpretation of the quality parameters hereis similar to
that of accuracy settings given in Photo Alignment section. The only difference is that in this case
Ultra High quality setting means processing of origina photos, while each following step implies
preliminary image size downscaling by factor of 4 (2 times by each side).

I nterpolation
If interpolation mode is Disabled it leads to accurate reconstruction results since only areas
corresponding to point cloud or polygonal points are reconstructed. Usualy this method is
recommended for Mesh and Tiled Model data source.

With Enabled (default) interpolation mode M etashape will calculate DEM for all areas of the scene
that arevisible on at least oneimage. Enabled (default) setting isrecommended for DEM generation.

In Extrapolated mode the program generates holeless model with some elevation data being
extrapolated up to the bounding box extents.

Point classes
The parameter alows to select a point class (classes) that will be used for DEM calculation.

To generate digital terrain model (DTM)), it is necessary to classify dense cloud points first in order to
divide them in at least two classes: ground points and the rest. Please refer to Classifying dense point
cloud section to read about dense point cloud classification options. Select Ground value for Point class
parameter in Build DEM dialog to generate DTM.

M etashape generates DEM only for the area inside the bounding box. To calculate DEM for a particular
rectangular part of the project, use Region section of the Build DEM diaog. Indicate coordinates of the
bottom left and top right corners of the region you would like to build the DEM for. Suggested values
indicate coordinates of the bottom left and top right corners of the whole area to be rasterized, the area
being defined with the bounding box.

Resolution value shows effective ground resolution for the DEM estimated for the source data. Size of the
resulting DEM, calculated with respect to the ground resolution, is presented in Total size section fields.

Import DEM

M etashape allowsto import aDEM in project. Y ou can use Import DEM... command from the File menu.
In the Import DEM dialog browse to afile and select coordinate system.

DEM can be imported in GeoT|FF Raster Data format.

Building orthomosaic

Orthomosaic is a combined image created by seamless merging of the original images projected on the
object surface and transformed to the selected projection. A polygonal model (mesh) or adigital elevation
model can be selected as a surface where the images will be projected to.
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Metashape allows using one of the following projection types. Geographic, Planar or Cylindrical.
Geographic projection servesfor most typical task of creation an orthomosaic in ageographical coordinate
system. Planar projection allows to select arbitrary orientation of projection plane which is useful for
projects concerning facades or other non-horizontal surfaces. To minimize distortions for objects of a
cylindrical shape, like tubes, round towers, tunnels, etc., a Cylindrical projection type can be used.

M etashape enables to perform orthomosaic seamline editing for better visual results (see section of the
manual).

For multispectral imagery processing workflow Ortho view tab presents Raster Calculator tool for NDVI
and other vegetation indices calculation to analyze crop problems and generate prescriptions for variable
rate farming equipment. More information on NDV | calculation functionality can be found in Vegetation
indices calculation section.

4 Note

 Build Orthomosaic procedure can be performed only for projectssavedin .PSX format for chunks
with the existing mesh or DEM.

« More than one instance of Orthomosaic can be stored in one chunk. In case you want to save
current Orthomosaic instance and build new one in current chunk, right-click on Orthomosaic
on the Workspace pane and uncheck Set as default option. In case you want to save current
Orthomosai ¢ instance and edit its copy, right-click on Orthomosaic and choose Duplicate option.

« In the Ortho view a Basemap for the orthophotomosaic can be included as a bottom layer.
Select Show Basemap from the Ortho view toolbar. In M etashape two modes of the Basemap are
supported: Map and Satellite. Map - displays map tiles using Open Street Map. Satellite option

display satellite layer.
If the lighting conditions have been changing significantly during capturing scenario, it isrecommended to
use Calibrate colors option from the Tools menu before Build orthomosai ¢ procedure. The option can help
to even brightness and white balance of the images over the data set. Please note that for large data sets

Calibrate colors procedure can turn out to be quite time consuming. See information on color calibration
parameters in Building model texture section.

To build Orthomosaic
1. Select the Build Orthomosaic... command from the Workflow menu.

2. In the Build Orthomosaic dialog box select Coordinate system in which the orthomosaic will be
generated or select projection type.

3. Select type of Surface datathat will be used to build the orthophoto.
4. Click OK button when done.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Build orthomosaic parameters
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Build Orthomosaic
Projection
Type:
WGES 84 (EPSG:4326)
Parameters
Surface:

Blending mode:
Refine seamlines
Enable hole filling

Enable ghosting filter

Fixel size (%)

Max. dimension (pix):

Region

Setup boundaries:

Total size (pix):

OK

DEM

Mosaic (default)

2.13235e-06

1.31667e-06

ANG

[ ]]

Cancel

"Build Orthomosaic" dialog

Projection type
Geographic - allows to choose a geographic coordinate system from the dropdown list or upload
parameters of a customized geographical coordinate system. The coordinate system set by default
is the coordinate system previously selected for the model itself. Y ou can switch to a different one,

providing that corresponding datum transformation parameters are available.

Planar . Metashape allows to project the orthomosaic onto a plane set by the user, providing that mesh
isselected asthe surface type. Y ou can select projection plane and orientation of the orthomosaic. The
plane can be determined by a set of markers (if there are no 3 markersin adesired projection plane it
can be specified with 2 vectors, i. e. 4 markers). Planar projection type may be useful for orthomosaic

generation in projects concerning facades or other vertical surfaces.
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Cylindrical - allowsto project orthomosaic on acylindrical surface. It helpsto avoid severedistortions
while projecting cylindrical objects, like tubes, round towers, tunnels, etc.

To project 3D pointson acylindrical surface oneneedsto: 1) definethecylinder, i.e. defineitsaxisand
itsradius; 2) drop aperpendicular fromthe 3D point to the axisof the cylinder - the point of intersection
of the perpendicular and the cylindrical surface isthe projection of the 3D point in question; 3) agree
on how to define x and y coordinates of a point on the cylinder. For the purpose of orthomosaic and
DEM generation in cylindrical projection Metashape defines x and y coordinates of a point on the
cylinder in the following way: x - along the curve in the zero-plane, y - along the zero-element of the
cylindrical surface (zero-line), where zero-plane and zero-line are to be defined.

M etashape offers four methods to perform projecting on cylindrical surface. They differ in how the
four core elements - cylinder axis and radius, zero-plane and zero-line - are defined.

Current Region. The cylinder isinscribed in the Bounding box: the axis goes through the cross sign
on the bottom side of the Bounding box perpendicular to the bottom plane; the radiusis defined as one
half of the shorter side of the rectangle in the bottom of the Bounding box. Zero-plane goes through
the center of the Bounding box perpendicular to the axis; zero-line belongs to the Bounding box side
which is opposite to the side with the vertical marks.

Current View. The axisis set as the line from the viewpoint to the center of rotation for the model.
Radius is defined as one half of the shortest of all the edges of the Bounding box. Zero-plane goes
through the center of rotation for the model perpendicular to the axis; zero-line goes through the
highest point (in monitor-related coordinate system) of the curve in the zero-plane.

Markers. At least three marker are required. The first pair sets the axis. The third marker defines
zero-point, i.e. defines zero-plane and zero-line, on condition that radiusis the distance from the third
marker to the axis.

XIY/Z. The axis is the line parallel to the corresponding Cartesian axis - X/Y/Z, going through the
center of the Bounding box. Radius (r) is defined as one half of the shortest edge of the Bounding box.
Zero-plane goes through the center of the Bounding box perpendicular to the axis; zero-line is the
line opposite to the cut line. The cut line definition for each of the three possible optionsisillustrated
on the Figure below.

Interior projection option allows to switch to projecting on the inner surface of the cylinder.

Surface
Orthomosaic creation based on DEM data is especially efficient for aerial survey data processing
scenarios alowing for time saving on mesh generation step. Alternatively, mesh surface type allows
to create orthomosaic for less common, yet quite demanded applications, like orthomosaic generation
for facades of the buildings or other models that might be not referenced at all.
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Blending mode
M osaic (default) - implements approach with datadivision into several frequency domainswhich are
blended independently. The highest frequency component is blended along the seamline only, each
further step away from the seamline resulting in aless number of domains being subject to blending.
Aver age - uses the weighted average color value of all pixels from individual images.
In Disabled mode the color value for the pixel is taken from the image with the camera view being
almost along the normal to the reconstructed surface in that point.

Pixel size
Default value for pixel sizein Export Orthomosaic dialog refers to ground sampling resolution, thus,
it is useless to set a smaller value: the number of pixels would increase, but the effective resolution
would not. However, if it is meaningful for the purpose, pixel size value can be changed by the user
in coordinate system units or in meters.

Max. dimension (pix)
The parameter allows to set maximal dimension for the resulting raster data.

Back face culling
The option allows to neglect on projecting parts of the surface where normals are counter directed to
the targeted projection plane.

Enable holefilling
Thisoption is enabled on default since it helps to avoid salt-and-pepper effect in case of complicated
surface with numeroustiny parts shading other parts of the source surface model. Only in case of very
specific tasks might it be recommended to switch the function off.

Enable ghosting filter
This option uses nadir (or close to nadir) images for orthomosaic generation. Other images will not
be taken into account for creating orthomosaic.

Refine seamlines
The option is recommended to be used for DTM-based orthomosaics in order to make automatically
created seamlines to bypass buildings and other complex objectsin order to avoid visual artefacts on
the final image and time consuming manual orthomosaic patching.

M etashape generates orthomosaic only for the areainside the bounding box. However, if the orthomosaic
should be generated for a particular (rectangular) part of the project, Region section of the Build
Orthomosaic dialog should be used for indication of the coordinates of the bottom | eft and top right corners
of the region to be applied in the left and right columns of the textboxes respectively. Estimate button
allows you to see the coordinates of the bottom left and top right corners of the whole area.

Estimate button al so enablesto control total size of theresulting orthomosai c dataaccording to the currently
selected reconstruction area and resolution (Pixel size or Max. dimension parameters). The information is
shown in the Total size (pix) section fields.

Import Orthomosaic

M etashape allows to import a orthomosaic in project. Y ou can use Import Orthomosaic... command from
the File menu. In the Import Orthomosai ¢ dialog browse to afile and select coordinate system.

Orthomosaic can be imported in GeoTIFF Raster Data format.

Building panorama

Metashape is capable of panorama stitching for images taken from the same camera position - camera
station. To indicate for the software that loaded images have been taken from one camera station, one
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should move those photos to a camera group and assign Camera Station type to it. For information on
camera groups refer to Loading images to the project section.

To build panorama

1. Select the Build Panorama command from the Workflow menu.

2. Setting parameters for building panoramain the Build Panorama dialog.
3. Click OK button for starting generate panorama.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

[{ Note

 Build Panorama procedure can be performed only for projects saved in .PSX format.

Build panorama parameters

Buid Panorama
Freview

Camera group: Group 1

Parameters
Apply to: Active chunk
Blending mode: Mosaic (default)

Enable ghosting filter

Region
Setup boundaries:  -130 - 130 X
Reset -53 - | B3 Y
Image size (pix): 27034 ¥ 13517

"Build Panorama’ dialog

Preview
Camera group - select camera station for building panorama.
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Orientation and rotation parameter s - setting orientation and rotation using corresponding buttons
for building panorama.

Parameters

Apply to - select chunk or entire workspace.

Blending mode - selects the method how color values of pixels from different cameras will be
combined in the final panorama (Mosaic, Average, Disabled). Mosaic - implies two-step approach:
it does blending of low frequency component for overlapping images to avoid seamline problem
(weighted average, weight being dependent on a number of parameters including proximity of the
pixel in question to the center of the image), while high frequency component, that is in charge of
picture details, is taken from a single image - the one that presents good resolution for the area of
interest while the camera view is amost aong the normal to the reconstructed surface in that point.
Average - uses the weighted average value of all pixels from individual photos, the weight being
dependent on the same parametersthat are considered for high frequency component in mosaic mode.
Disabled - the image to take the color value for the pixel from is chosen like the one for the high
frequency component in mosaic mode.

Enable ghosting filter - in case the scene includes some thin structures or moving objects, it can be
useful to switch on this option to avoid ghosting effect on the resulting panorama.

Region

Setup boundaries - set boundaries for the region of panoramato be exported. Text boxesin the first
line (X) allow to indicate the angle in the horizontal plane and the second line (Y) serves for angle
in the vertical plane limits.

I mage size (pix) - option enables to control the dimensions of the exported image file.

Saving intermediate results

Certain stages of 3D model reconstruction can take a long time. The full chain of operations could
eventually last for 4-6 hours when building a model from hundreds of photos. It is hot always possible to
complete al the operationsin one run. Metashape allows to save intermediate results in a project file.

Metashape project archive (.PS2)

Metashape Archivefiles (*.psz) may contain the following information:

List of loaded photographs with reference paths to the image files.

Photo alignment data such as information on camera positions, sparse point cloud model and set of
refined camera calibration parameters for each calibration group.

Masks applied to the photosin project.
Depth maps for cameras.
Dense point cloud model with information on points classification.

Reconstructed 3D polygona model with any changes made by user. This includes mesh and texture
if it was built.

List of added markers aswell as of scale-bars and information on their positions.

Structure of the project, i.e. number of chunksin the project and their content.

Notethat since M etashape tends to generate extradense point cloudsand highly detailed polygonal models,
project saving procedure can take up quite along time.
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Metashape project file (.PSX)

The software also allows to save Metashape Project file (*.psx) which stores the links to the processing
resultsin *.psx file and the dataitself in * .files structured archive. Thisformat enables responsive loading
of large data (dense point clouds, meshes, etc.), thus avoiding delays on reopening a thousands-of -photos
project. DEM, orthomosaic, panorama and tiled model generation options are available only for projects
saved in PSX format.

Y ou can save the project at the end of any processing stage and return to it later. To restart work simply
load the corresponding file into Metashape. Project files can also serve as backup files or be used to save
different versions of the same model.

Project files use relative paths to reference original photos. Thus, when moving or copying the project file
to another location do not forget to move or copy photographs with al the folder structure involved as
well. Otherwise, Metashape will fail to run any operation requiring source images, although the project
file including the reconstructed model will be loaded up correctly. Alternatively, you can enable Store
absolute image paths option on the Advanced tab of the Preferences dialog available from Tools menu.

Exporting results

M etashape supports export of processing resultsin various representations. sparse and dense point clouds,
camera calibration and camera orientation data, mesh, etc. Orthomosaics and digital elevation models
(both DSM and DTM), as well as tiled models can be generated according to the user requirements.

Point cloud and camera calibration data can be exported right after photo alignment is completed. All other
export options are available after the corresponding processing step.

If you are going to export the results (point cloud / mesh / tiled model ) for the chunk that is not referenced,
please note that the resulting file will be oriented according to a default coordinate system (see axes in
the bottom right corner of the Model view), i. e. the model can be shown differently from what you see
in Metashape window.

b
To align the model orientation with the default coordinate system use “4# Rotate object button from the

F;
Toolbar. & Move object and “* Scale object instruments can be used to adjust the size and location of
the unreferenced model.

In some cases editing model geometry in the external software may be required. M etashape supports model
export for editing in external software and then allows to import it back as it is described in the Editing
model geometry section of the manual.

Main export commands are available from the File menu.

Point cloud export

To export sparse or dense point cloud
1. Select Export Points... command from the File menu.
2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

3. Inthe Export Points dialog box select desired type of point cloud: Sparse point cloud or Dense point
cloud.
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4. Specify the coordinate system and indicate export parameters applicable to the selected file type,
including the dense cloud classes to be saved.

5. Click OK button to start export.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Split in blocks option in the Export Points dialog can be useful for exporting large projects. It is available
for referenced models only. Y ou can indicate the size of the section in xy plane (in meters) for the point
cloud to be divided into respective rectangular blocks. The total volume of the 3D sceneis limited with
the Bounding Box. The whole volume will be split in equal blocks starting from the point with minimum
x and y values. Note that empty blocks will not be saved.

In some casesit may be reasonableto edit point cloud before exporting it. To read about point cloud editing
refer to the Editing point cloud section of the manual.

M etashape supports point cloud export in the following formats:
» Wavefront OBJ (*.obj)

e Stanford PLY (*.ply)

» XYZ Point Cloud (*.txt)
« ASPRSLAS(*.las)

s LAZ (*.laz)

« ASTM E57 (*.657)

» Topcon CL3 (*.cl3)

« ASCII PTS (*.pts)
 Autodesk DXF (*.dxf)

» U3D (*.u3d)

» Adobe PDF (*.pdf)
 Point Cloud Data (*.pcd)
* potree (*.zip)

» Cesium 3D Tiles (*.zip)
» Agisoft OC3 (*.oc3)

[{ Note

» Saving color information of the point cloud is not supported by the OBJ and DXF formats.

e Saving point normals information is not supported by the LAS, LAZ, PTS, CL3 and DXF
formats.
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M etashape supports direct uploading of the point cloudsto the following resources. 4DMapper, PointBox,
PointScene and Sketchfab. To publish your point cloud online use Upload Data... command from the File
menu.

Tie points and camera calibration, orientation data

export

To export camera calibration and camera orientation data select Export Cameras... command from the
File menu.

M etashape supports camera data export in the following formats:

Agisoft XML structure (*.xml)
Bundler OUT file format (*.out)
CHAN file format (*.chan)

Boujou TXT file format (*.txt)
Realviz RZML format (*.rzml)
Omega Phi Kappatext file format (*.txt)
PATB project (*.pro)

BINGO project file (*.dat)

ORIMA file (*.txt)

Maya ASCII (*.ma)

AeroSys Exterior orientation (*.orn)
Inpho project file (*.prj)

Summit Evolution project (*.smtxml)
Blocks Exchange (* .xml)

Alembic (*.abc)

Autodesk FBX (*.fbx)

[{ Note

» Cameradata export in Bundler and Boujou file formats will save sparse point cloud datain the
samefile.

e Cameradataexport in Bundler file format would not save distortion coefficients k3, k4.

To export control points and tie points data one should choose one of the following export formats in the
Export Cameras dialog: BINGO, ORIMA, PATB, Summit Evolution or Blocks exchange. Tie points and
Control points can be exported only along with interior and exterion orientation parameters of the cameras.

Asaresult of export in PATB format, the following files will be written:
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example.pro
Project file PATB. It contains information on the units of measurement (microns/millimeters). This
eliminates the ambiguity in interpreting the data on import.

example.im
File with coordinates of tie points projections on the images.

example.con
File with measured coordinates of the ground control points.

example.ori
File with the calculated parameters of the exterior orientation for the cameras.

example.at
File with the calculated coordinates of tie points (adjusted terrain coordinates).

£ Note

e *.imand *.con formats are input filesfor PATB and *.ori. and * .at are output formats.
Asaresult of export in BINGO format, thefollowing fileswill be written to the destination folder: itera.dat
(ITERA file); image.dat IMAGE COORDINATE file); geoin.dat (GEO INPUT file); gps-imu.dat (GPS
IMU data).

As aresult of export in Summit Evolution format two files will be created (*.cam, *.smtxml). File in
* cam format includesinformation about cameracalibration parameters. Filein* .smtxml format is Summit
Evolution project file.

To export / import camera calibration data only select Camera Calibration... command from the Tools

menu. Using ="/ Il?ll buttonsit is possible to load / save camera calibration datain the following formats:
» Agisoft Camera Calibration (*.xml)

» Australis Camera Parameters (*.txt)

» Australisv7 Camera Parameters (* .txt)

» PhotoModeler Camera Calibration (*.ini)

« 3DM CalibCam Camera Parameters (*.txt)
» CaCam Camera Calibration (*.cal)

* Inpho Camera Calibration (*.txt)

e USGS Camera Calibration (*.txt)

» Pix4D Camera Calibration (*.cam)

* OpenCV Camera Cdlibration (*.xml)

 Z/I Distortion Grid (*.dat)

Panorama export
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To export panorama

1. Select Export Orthomosaic command from the File menu.
2. Set exporting parameters and click Export... button.

3. Browse the destination folder and formats.

4. Click Save button.

M etashape supports panorama export in the following formats:

o JPEG (*.jpg)

JPEG 2000 (* .jp2)

JPEG XL (*.jxl)

TIFF/GeoTIFF (* tif, * tiff)

PNG (*.png)

BMP (*.bmp)
3D model export

To export 3D model
1. Select Export Model... command from the File menu.
2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

3. Inthe Export Model dialog specify the coordinate system and indicate export parameters applicable
to the selected file type.

4. Click OK button to start export.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

If amodel generated with Metashape is to be imported in a 3D editor program for inspection or further
editing, it might be helpful to use Shift function while exporting the model. It allows to set the value to
be subtracted from the respective coordinate value for every vertex in the mesh. Essentialy, this means
trandlation of themodel coordinate system origin, which may be useful since some 3D editors, for example,
truncate the coordinates values up to 8 or so digits, while in some projects they are decimals that make
sense with respect to model positioning task. So it can be recommended to subtract a value equal to the
whole part of acertain coordinate val ue (see Reference pane, Camera coordinates val ues) before exporting
the model, thus providing for areasonable scale for the model to be processed in a 3D editor program.

M etashape supports model export in the following formats:
» Wavefront OBJ (*.ohj)

» 3DSfileformat (*.3ds)
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Some fileformats (OBJ, 3DS, VRML, COLLADA, PLY, FBX) save texture image in aseparatefile. The
texture file should be kept in the same directory as the main file describing the geometry. If the texture

VRML models (*.wrl)
COLLADA (*.dae)

Stanford PLY (*.ply)

X3D models (*.x3d)

STL models (*.stl)

Alembic (*.abc)

Autodesk FBX (*.fbx)
Autodesk DXF Polyline (*.dxf)
Autodesk DXF 3DFace (*.dxf)
Open Scene Graph (*.osgb)
Binary gITF (*.glb)

U3D models (*.u3d)

Adobe PDF (*.pdf)

Google Earth KMZ (*.kmz)

atlas was not built only the model geometry is exported.

M etashape supports direct uploading of the models to Sketchfab resource. To publish your model online

use Upload Data... command from the File menu.

Tiled model export

To export tiled model

1.
2.

3.

M etashape supports tiled model export in the following formats:

Select Export Tiled Model... command from the File menu.
Browse the destination folder, choose the file type, and print in the file name. Click Save button.

The progress dialog box will appear displaying the current processing status. To cancel processing

click Cancel button.

Cesium 3D Tiles (*.zip)
Scene Layer Package (*.9lpk)

PhotoMesh Layer (*.zip)

e Agisoft Tiled Model (*.tls)
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e Agisoft Tile Archive (*.zip)
» Open Scene Graph (*.osgb)

Agisoft Tiled Model can be visualized in Agisoft Viewer application, which is included in Agisoft
M etashape Professional installation package. Thanksto hierarchical tilesformat, it allowsto responsively
visualize large models.

M etashape supports direct uploading of the tiled models to the following resources. 4DMapper, Melown
Cloud, Sputnik. To publish your tiled model online use Upload Data... command from the File menu.

Orthomosaic export

To export Orthomosaic
1. Select Export Orthomosaic... command from the File menu.
2. Inthe Export Orthomosaic dialog box specify coordinate system for the Orthomosaic to be saved in.

3. Check Write KML file and / or Write World file options to create files needed to georeference the
orthomosaic in the Google Earth and / or aGIS.

4. Click Export... button to start export.
5. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

4 Note

« Write KML file option is available only if the selected export coordinate system is WGS84 due
to the fact that Google Earth supports only this coordinate system.

» World file specifies coordinates of the four corner vertices of the exporting orthomosaic. This
information is aready included in GeoTIFF file, however, it could be duplicated in the external
files for some reason. If orthomosaic is exported in JPEG, PNG or BMP file formats and should
have the georeferencing information World file should be written.

If the export file of afixed size is needed, it is possible to set the length of the longer side of the export
filein Max. dimension (pix) parameter. The length should be indicated in pixels.

Solit in blocks option in the Export Orthomosaic dialog can be useful for exporting large projects. You
can indicate the size of the blocks (in pix) for the orthomosaic to be divided into. The whole areawill be
split in equal blocks starting from the point with minimum x and y values. Note that empty blocks will
not be saved.

To export a particular part of the project use Region section of the Export Orthomosaic dialog. Indicate
coordinates of the bottom | eft and top right corners of the region to be exported in theleft and right columns
of the text boxes respectively. Estimate button allows you to see the coordinates of the bottom left and
top right corners of the whole area.

Alternatively, you can indicate the region to be exported using polygon drawing option in the Ortho view
tab of the program window. (For instructions on polygon drawing refer to Shapes section of the manual.)
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Once the polygon isdrawn, right-click on the polygon and set it as aboundary of the region to be exported
using Set Boundary Type option from the context menu.

Default value for pixel size in Export Orthomosaic dialog refers to ground sampling resolution, thus, it
isuseless to set a smaller value: the number of pixels would increase, but the effective resolution would
not. If you have chosen to export orthomosaic with a certain pixel size (not using Max. dimension (pix)
option), it is recommended to check estimated Total size (pix) of the resulting file to be sure that it is not
too large to be correctly saved to the targeted file format.

For (Geo)TIFF export compression type may be set by the user. The following options are available:
LZW, JPEG, Packbits, Deflate. Additionally, the file may be saved without compression (None value
of the compression type parameter). Write BigTIFF file option allows to save files bigger than standard
TIFF limit of 4Gb. Total size textbox in the Export Orthomosaic dialog helps to estimate the size of the
resulting file. However, it is recommended to make sure that the application you are planning to open the
orthomosaic with supports BigTIFF format. Alternatively, you can split a large orthomosaic in blocks,
with each block fitting the limits of a standard TIFF file.

While exporting orthomosaic in JPEG format, JPEG quality parameter controls balance between
compression level (i.e. quality of the result) and export file size: the higher the value of the parameter (%)
the more emphasisis on the quality at the expense of alarger resulting file.

The following formats are supported for orthomosaic export:

* TIFF/GeoTIFF (*.tif)

» JPEG 2000 (*.jp2)

* JPEG (*.jpg)

* PNG (*.png)

* BMP (*.bmp)

» Google Earth KMZ (*.kmz)

» Google Map Tiles (*.zip)

* MBTiles (*.mbtiles)

e World Wind Tiles (*.zip)

» TileMap Service Tiles (*.zip)

M etashape supports direct uploading of the orthomosaicsto the following resources. 4ADM apper, MapBox,
Melown Cloud, Picterra, Sputnik. To publish your point cloud online use Upload Data... command from
the File menu.

Multispectral orthomosaic export is supported in GeoTIFF format only. When exporting in other formats,
only primary channel will be saved. Multispectral orthomosaic has all channels of the original imagery.

Optionally the alpha channel may be included that defines transparency being used for no-data areas of
the orthomosaic.

To export Multispectral orthomosaic

1. Select Export Orthomosaic... command from the File menu.
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2.  Follow steps 2-3 from Orthomosaic export procedure above.

3. Select None value for Raster transform parameter.

4. Click Export button to start export.

5. Browsethe destination folder, choose GeoTIFF type, and print in the file name. Click Save button.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

To export Seamlines

1. Select Generate Seamlines... command from the Orthomosaic submenu from the Tools menu.

2. Click right button on Shapes layer on the Workspace pane.

3. Select Export Layers from the context menu.

4. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

The following formats are supported for seamlines export:
 Shapefiles (*.shp)

» KML files (*.kml)

o KMZ files (*.kmz)

» DXFfiles (*.dxf)

* GeoJSON files (*.geojson)

» GeoPackage files (*.gpkg)
NDVI data export

Vegetation index data export is available with the Export Orthomosaic... command from the File menu.
V egetation index data can be saved as two types of data: asagrid of floating point index values calculated
per pixel of orthomosaic (multichannel orthomosaic if several vegetation indices have been calculated for
the project) or asan orthomosaic in pseudocolors according to apallet set by user (exportsonly datafor the
first vegetation index or combined datafor selected 3 vegetation indices, providing that False Color value
is set for the Color palette parameter). The format is controlled with Raster transform option in Export
Orthomosaic / Export Google KMZ / Export Google Map Tiles / Export MBTiles / Export World Wind
Tilesdialogs. None value allowsto export orthomosaic generated for the data before any index calculation
procedure was performed.

Digital Elevation Model (DSM/DTM) export

Metashape allows to calculate and then export both a digital surface model (DSM) and a digital terrain
model (DTM) (see Building digital elevation model section).
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To export Digital Elevation Model
1. Select Export DEM... command from the File menu.
2. Inthe Export DEM dialog specify coordinate system to georeference the DEM.

3. Check Write KML file and/or Write World file options to create files needed to georeference the
DEM in the Google Earth and/or a GIS.

4. Click Export button to start export.
5. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

4  Note

* Write KML file option is available only if the model is georeferenced in WGS84 coordinate
system due to the fact that Google Earth supports only this coordinate system.

« World file specifies coordinates of the four corner vertices of the exporting DEM. This
information is already included in GeoTIFF elevation data as well as in other supported file
formats for DEM export, however, you could duplicate it for some reason.

If export file of afixed sizeisneeded, it is possible to to set the length of the longer side of the export file
in Max. dimension (pix) parameter. The length should be indicated in pixels.

Unlike orthomosaic export, it is sensible to set smaller pixel size compared to the default value in DEM
export dialog; the effective resolution will increase. If you have chosen to export DEM with a certain pixel
size (not using Max. dimension (pix) option), it is recommended to check estimated Total size (pix) of the
resulting file to be sure that it is not too large to be correctly saved to the targeted file format.

No-data value is used for the points of the grid, where elevation value could not be calculated based on
the source data. Default value is suggested according to the industry standard, however it can be changed
by user.

Split in blocks option in the Export DEM dialog can be useful for exporting large projects or meeting
special DEM requirements. (See Orthomosaic export section for details.)

To export a particular part of the project use Region section of the Export DEM dialog (see Orthomosaic
export section for details). Similarly to orthomosaic export, polygons drawn over the DEM on the Ortho
tab of the program window can be set as boundariesfor DEM export. (For instructions on polygon drawing
refer to Shapes section of the manual.)

The following formats are supported for DEM export:

GeoTIFF elevation data (*.tif)

Arc/Info ASCII Grid (*.asc)

Band interleaved file format (*.bil)

XYZ fileformat (*.xyz)

Sputnik KMZ (*.kmz)
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Google Map Tiles (*.zip)

MBTiles (*.mbtiles)

World Wind Tiles (*.zip)
» TileMap Service Tiles (*.zip)

Metashape supports direct uploading of the elevation models to the following resources. 4DMapper,
MapBox, Melown Cloud, Sputnik. To publish your elevation model online use Upload Data... command
from the File menu.

[ Note

« In Metashape DEM export colored from RGB palette is supported. Select Palette option in the
Raster transform section of the Export DEM dialog box. The palette option is supported for the
following export formats. TIFF, JPEG, JPEG2000, PNG.

Render Photos

M etashape all owsto render frames from viewpoints specified by the user. Thismay be useful, for example,
in casethetarget sceneisamoving oneanditiscrucial to keep the number of simultaneously taken frames
minimal during capture. A 3D model can be generated based on some optimal number of photos, and later
on extraframes can be rendered in Metashape software.

This functionality also allowsto correct the initial imagesin such away as to make them appropriate for
lenticular photography.

4 Note

« Thisoption is available after Align photos step. Please note that it works only for unreferenced
chunk.

Torender extraframesfrom a 3D model

1. Select Render Photos.. command of Export subcommand of File menu.
2. Inthe Render Photos dialog output image size and filename template.
3. Check Interpolate image positions.

4.  Specify the number of images to be rendered.

5. Specify the quality for depth maps cal culation (see Building dense point cloud section) and click OK
button.

6. Inthe Model view drag the plane of zero parallax to the desired position.

7. Specify the export area (the part of the scene to be rendered) - adjust the size of the gray plane (drag
the corners). Note that yellow rectangles indicate the footprint for al input images.

8. Adjust the step between the viewpoints for imagesto be rendered. They are marked with blue points.
Drag the starting/ending blue dots.

9. Click OK button in the top part of the Model view.
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10. Specify the folder for the rendered images to be stored to and click OK button.

To correct theinput imagesfor the lenticular photography
1. Select Render Photos.. command of Export subcommand of File menu.
2. Inthe Render Photos dialog output image size and filename template.

3. Uncheck Interpolate image positions and click OK button.

4. Inthe Model view drag the plane of zero parallax to the desired position.

5.  Specify the export area (the part of the scene to be rendered) - adjust the size of the gray plane (drag
the corners). Note that yellow rectangles indicate the footprint for al input images.

6. Adjust the step between the viewpoints for imagesto be rendered. They are marked with blue points.
Drag the starting/ending blue dots.

7. Click OK button in the top part of the Model view.

8. Specify the folder for the rendered images to be stored to and click OK button.

Extra products to export

In addition to main targeted products Metashape allows to export some other processing results, like:

- Convert Images... command is available from Export submenu of the File menu and allowsto export free
of lens distortions and geometrically corrected images. It also allowsto convert large imagesto apyramid-
optimized TIFF format for prompt navigation in the Photo view mode.

In the Parameter s section of the Convert Images dialog window the user can check the following options:
Correct distortions, Center principal point, Square pixels, Apply color correction and Update GPS meta
data. Metashape supports export of the images with GPS data refined during alignment and additionally
corrected basing on the GCPs (if those were used in the project). Filename template for converted images
should also be specified in the dialog window.

In the Compression section of the Convert Images dialog window the user can set one of the suggested
TIFF compression parameters. LSW, JPEG, Packbits, Deflate; set JPEG quality and specify if Tiled TIFF,
BigTIFFfileor TIFF overviews should a so be saved. The corrections can be applied to all cameras, entire
workspace, selected cameras or even to a current photo.

- Depth map for any image (Export Depth... command available from photo context menu). Y ou can export
diffuse map, depth map and normal map.

- Individually orthorectified images (Export Orthophotos... command available from Export submenu of
the File menu).

- High resolution image of the model as it is shown in the Model view or in Ortho view mode. Capture
View command available from the context menu shown on right button click in the Model or Ortho view.

£ Note

* You need to have mesh model generated in the chunk in order to export diffuse map, depth map
and normal map.
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Convert Images
Parameters

Transform to initial calibration
Remove distortions

Center prindpal point
Square pixels

Apply color correction

Mer

[fs]

E mulaspecral Images

|Ipdate GPS meta data

Filename template: {filename}. {fileext}
Compression
TIFF compression: LZw
JPEG quality: a9
Write tiled TIFF Write BigTIFF file

Generate TIFF overviews

Apply to
All cameras Entire workspace

cslerted Famers currert nhoto
eleCted cameras Lurrent pnoto

o< ] Cancel

"Convert Images' dialog

Survey Statistics

M etashape generates a report with Survey Statistics. Survey Satistics contains information about camera
overlap, cameralocations, camerarotationsand ground control points. To createareport inthe PDF format,
read Processing report generation section.

To create Survey Statistics
1. Select Survey Satistics command from the Tools menu.

2. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

3. In the Survey Satistics dialog displayed camera overlap, camera locations, camera rotations and
ground control points. Information about survey statistics can be export in the following format:
JPEG, JPEG 2000, PNG, TIFF, BMP, OpenEXR, TARGA.

4. Click Close button to close the dialog.
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Survey Statistics Tabs

Camera overlap
Image with camera |locations and image overlap.

Cameralocations
Image with cameralocations and error estimates. Z error is represented by ellipse color. X,Y error are
represented by ellipse shape. Estimated camera locations are marked with a block dot.

Camerarotations
Image shows camera orientations and error estimates

Ground control points
Image shows control and check point locations and error estimates. Z error is represented by ellipse
color. X,Y errors are represented by ellipse shape. Estimated locations are marked with a dot for
control points or T-crossing for check points.

Connectivity

During initial image alignment, one or more components are generated, each of which represents a
connected photogrammetric network. However, in the process of editing tie points or markers, the
connectivity of an individual component may be lost, which will lead to incorrect determination
of the relative orientation parameters in the component. The Connectivity tab displays a list of
disconnected camera groups, helping to locate possibly misaligned parts in the alignment. The user
can add additional markers between listed groups of images or split the groupsinto separate connected
components based on this information.

Roalling Shutter
Image visualization rolling shutter effect if this parameter enable in the Camera calibration dialog

window before starting align images. Camera y-axis direction represented by red lines. Estimated
camera movement represented by green lines. Cameras with zero rolling shutter are grayed out.

Processing report generation

Metashape supports automatic processing report generation in PDF format, which contains the basic
parameters of the project, processing results and accuracy evaluations.

To generate processing report
1. Select Generate Report... command from the File menu.
2. Browsethe destination folder, choose the file type, and print in the file name. Click Save button.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

M etashape processing report presents the following data:
* Orthomosaic sketch.

» Survey data including coverage area, flying altitude, GSD, general camera(s) info, as well as overlap
statistics.

» Camera calibration results: figures and an illustration for every sensor involved in the project.

» Camera positioning and orientation error estimates.
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 Ground control and check points error estimates.

» Scale bars estimated distances and measurement errors.

Digital elevation model sketch with resolution and point density info.

» Processing parameters used at every stage of the project.

4 Note

» Processing report can be exported after alignment step.

Survey Data

Fig. Cameralocations and image overlap - shows the model and position the camerasis shown and the
number of overlapsisdisplayedin color.

Number of images - total humber of images uploaded into the project.

Camera stations - number of aligned images.

Flying altitude - average height above ground level.

Tiepoints - total number of valid tie points (equals to the number of points in the sparse cloud).
Ground resolution - effective ground resolution averaged over al aligned images.

Projections - total number of projections of valid tie points.

Coverage area - size of the area that has been surveyed.

Reprojection error - root mean sgquare reprojection error averaged over all tie points on all images.

Table. Cameras - table with the parameters. camera model, resolution, focal length, pixel size,
precalibrated.

Reprojection error is the distance between the point on the image where a reconstructed 3D point can be
projected and the original projection of that 3D point detected on the photo and used as a basis for the
3D point reconstruction procedure.

Camera Calibration

For precalibrated cameras internal parameters input by the user are shown on the report page. If acamera
was not precalibrated, internal camera parameters estimated by M etashape are presented.

Fig. Imageresidualsfor camera - displaysthe reprojection errorsfor the tie points detected on the source
images, averaged acrossall theimages of the calibration group and inside the certain "cells" on theimages.

Camera name (focal length) - camera model name and number of images.
Type - cameratype.

Resolution - image dimensions in pixels.

Focal Length - focal length in mm.

Pixel Size - pixel sizein pm.
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Table. Calibration coefficients and correlation matrix - table with the calibration coefficients and
parameters of the covariance matrix (F, Cx, Cy, B1, B2, K1, K2, K3, K4, P1, P2).

Camera Locations

Fig. Cameralocationsand error estimates - presenting camera locations and error estimates. Z error is
represented by ellipse color. X, Y error are represented by ellipse shape. Estimated camera locations are
marked with a black dot.

X error (m) - root mean square error for X coordinate for al the cameras.

Y error (m) - root mean square error for Y coordinate for all the cameras.

XY error (m) - root mean square error for X and Y coordinates for all the cameras.
Z error (m) - root mean square error for Z coordinate for al the cameras.

Total error (m) - root mean square error for X, Y, Z coordinates for all the cameras.
Total error = sqrt(Sumi=1" [(Xi, est - Xi,in)” + (Yi, est - Yi,in)” + (Zi, et - Zi,in)] / 1)
Xi. in - input value for X coordinate for i camera position,

Xi, est - €stimated value for X coordinate for i camera position,

Yi,in - input value for Y coordinate for i camera position,

Yi et - €stimated value for Y coordinate for i camera position,

Z; in - input value for Z coordinate for i camera position,

Z; o - estimated value for Z coordinate for i camera position,

Camera Orientations

Fig. Camera orientations and error estimates - shows camera orientations and error estimates. Arcs
represent yaw error estimates.

Yaw error (in degrees) - error for yaw.
Pitch error (in degrees) - error for pitch.
Roll error (in degrees) - error for roll.

Total error (in degrees) - root mean square error all angles.

Ground Control and Check Points

Fig. GCP locations and error estimates - displays GCP locations and error estimates. Z error is
represented by ellipse color. X,Y errors are represented by ellipse shape. Estimated GCP locations are
marked with a dot or crossing.

XY error (m) - root mean square error for X and Y coordinates for a GCP location / check point.
Z error (m) - error for Z coordinate for a GCP location / check point.

Error (m) - root mean square error for X, Y, Z coordinates for a GCP location / check point.
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Proj ections - number of projections for a GCP location / check point over al the images.

Error (pix) - root mean sgquare error for X, Y coordinates on an image for a GCP location / check point
averaged over al the images.

Total - root mean square error al the GCP locations / check points.

Scale Bars
Distance (m) - scale bar length estimated by Metashape.
Error (m) - difference between input and estimated values for scale bar length.

Total - root mean square error al the scale bars in Control/Check section.

Digital Elevation Model
Fig. Reconstructed digital elevation model - presenting digital elevation model.

Resolution - effective resolution of the exported DEM. The value depends on the Quality parameter value
used at Build point cloud step, providing that DEM has been generated from dense point cloud.

Point Density - average number of dense cloud points per square meter.

Processing Parameters

Processing report contains processing parameters information, which is also available form Chunk context
menu. Along with the values of the parameters used at various processing stages, this page of the report
presents information on processing time.

For projects calculated over network processing time will be displayed as a sum of the time spent for
processing by each node.

M etashape matches images on different scales to improve robustness with blurred or difficult to match
images. The accuracy of tie point projections depends on the scale at which they were located. Metashape
uses information about scale to weight tie point reprojection errors. Key point size is the Sigma of the
Gaussian blur at the pyramid level of scales at which the key point was found.

In the Reference pane settings dial og tie point accuracy parameter corresponds to the normalized accuracy
- i.e. accuracy of tie point projection detected at the scale equal to 1. Tie points detected on other scaleswill
have accuracy proportional to their scales. This helps to obtain more accurate bundle adjustment results.

On the processing parameters page of the report (aswell asin chunk information dialog) two reprojection
errors are provided: the reprojection error in the units of key point scale (this is the quantity that is
minimized during bundle adjustment), and the reprojection error in pixels (for convenience). The Mean
key point size value is averaged Key point size value over all key points. Average tie point multiplicity
value istheratio of the total number of projections to the number of tie points.

Cameratrack creation and fly through video
rendering

In Metashape you can create an overview video of the model along a certain tragjectory. Cameratrack can
be created automatically (using simple preset options), imported from external file and edited manually.
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To manually create a track and add a viewpoint, click Append button on the Animation pane. Append
option will add the current viewpoint to the active camera track.

To automatically create Horizontal track

1. Select Animation command from the View menu.

2. Click Create button on the Animation pane toolbar.

3. Choose Horizontal preset parameter in Create Track dialog window and set the Keyframe count.
4. Click OK button.

5. Adjust the position of the viewpoint in the camera track in Model view by dragging the left mouse
button to display it visually.

To automatically create Vertical track

1. Select Animation command from the View menu.

2. Click Create button on the Animation pane toolbar.

3. Choose Vertical preset parameter in Create Track dialog window and set the Keyframe count.
4. Click OK button.

5. Adjust the position of the viewpoint in the camera track in Model view by dragging the left mouse
button to display it visually.

[ Note

e To display the camera track path, select Show animation command from the Show/Hide items
submenu on the Model menu.

Camera track parameters can be adjusted in the Animation Settings dialog window. The following
parameters can be changed: Camera Track Label, Duration (in seconds), Field of view (deg), Smooth
camera track option, Loop camera track option, Rotation angles convention. Click Settings button on the
Animation pane to open Animation Settings dial og.

Torecord thevideo

1. To record the video according to the created camera track to the external file click on Capture on
the Animation pane toolbar.

2. Select the desired export parameters in the Capture Video dialog, such as export video resolution,
compression type and frame rate.

3. Tosavethetrack path to external file click Save button on the Animation pane.
M etashape supports camera track export in the following formats:

+ CameraPath

« KML

« CSV
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4 Note

e That KML format is only supported for projects georeferenced in geographic/projected systems
convertible to WGS84 system.
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Camera calibration

Calibration groups

While carrying out photo alignment Metashape estimates both interior and exterior camera orientation
parameters, including nonlinear radial distortions. For the estimation to be successful it is crucial to apply
the estimation procedure separately to photos taken with different cameras. Once photos have been loaded
in the program, Metashape automatically divides them into calibration groups according to the image
resolution and/or EXIF meta data like cameratype and focal length. All the actions described below could
and should be applied (or not applied) to each calibration group individually.

Calibration groups can be rearranged manually.

To createanew calibration group

1. Select Camera Calibration... command from the Tools menu.

2. Inthe Camera Calibration dialog box, select photos to be arranged in a new group.
3. Intheright-click context menu choose Create Group command.
4.

A new group will be created and depicted on the left-hand part of the Camera Calibration dial og box.

To move photos from one group to another
1. Select Camera Calibration... command from the Tools menu.
2. Inthe Camera Calibration dialog box choose the source group on the left-hand part of the dialog.

3. Select photos to be moved and drag them to the target group on the left-hand part of the Camera
Calibration dialog box.

To place each photo into a separate group you can use Split Groups command available at the right button
click on a calibration group name in the left-hand part of the Camera Calibration dialog

Camera types

Metashape supports four major types of camera: frame camera, fisheye camera, spherical camera and
cylindrical camera. Additionally RPC camera type is available for satellite imagery that is accompanied
with the RPC metainformation. Cameratype can be set in Camera Calibration dialog box available from
Tools menu.

Frame camera. If the source data within a calibration group was shot with aframe camera, for successful
estimation of camera orientation parameters the information on approximate focal length (pix) isrequired.
Obviously, to calculate focal length valuein pixel it is enough to know focal length in mm along with the
sensor pixel sizein mm. Normally this data is extracted automatically from the EXIF meta data.

Frame camerawith Fisheyelens. If extrawide lenseswere used to get the source data, standard M etashape
cameramodel will not allow to estimate camera parameters successfully. Fisheye cameratype setting will
initialize implementation of adifferent cameramodel to fit ultra-wide lens distortions.

Spherical camera (equirectangular projection). In case the source datawithin acalibration group was shot
with aspherical camera, cameratype setting will be enough for the program to cal cul ate cameraorientation
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parameters. No additional information is required except the image in equirectangular representation. This
type of camerawill also be used for images obtained from Laser Scanners.

Spherical camera Cylindrical projection. In case the source data within a calibration group is a set of
panoramic images stitched according to cylindrical model, camera type setting will be enough for the
program to calculate camera orientation parameters. No additional information is required.

Satellite images with RPC coefficients. To automatically detect the camera type, select Preferences
command from Tools menu. Click Advanced tab and turn on the check box Load satellite RPC data from
auxiliary TXT files.

Optionaly rolling shutter compensation can be enabled by checking the Enable rolling shutter
compensation box in the Camera Calibration dialog available from Tools menu.

In case source images lack EXIF data or the EXIF data is insufficient to calculate focal length in pixels,
M etashape will assume that focal length equalsto 50 mm (35 mm film equivalent). However, if theinitial
guess values differ significantly from the actual focal length, it islikely to lead to failure of the alignment
process. So, if photos do not contain EXIF meta data, it is preferable to specify focal length (mm) and
sensor pixel size (mm) manually. It can be done in Camera Calibration dialog box available from Tools
menu. Generally, thisdataisindicated in camera specification or can be received from some online source.
To indicate to the program that camera orientation parameters should be estimated based on the focal
length and pixel sizeinformation, it is necessary to set the Type parameter on the Initial tab to Auto value.

Scanned images with fiducial marks

Metashape supports processing of analog aerial images scanned to digita files. On uploading, all the
scanned images from the same analog camera should be placed in a designated calibration group.
M etashape will automatically put the camerasto the same calibration group, providing that they have been
scanned to the images of the same resolution. In case scanned analog images from different cameras have
been uploaded to the same chunk, it isrequired to divide them manually into different calibration groups. It
could be done in Camera Calibration dialog available from Tools menu. To move images to a designated
calibration group manually, select cameras on the Camera Calibration dialog window and select Merge
Groups command from the cameras context menu.

Cameracalibrationin case of scanned imagesis performed based on thefiducial marksinformation. That is
why cameracalibration startswith fiducial marks detection in thisworkflow. Metashape enables automatic
detection of most of the fiducial mark types. See Figure below.

N/

7N

Supported fiducia marks.

[ Note

» Fiducial marks detection can be only performed for Film cameras. Don't forget to enable the
Film camera with fiducial marks option in the Camera Calibration dialog box for all the groups
which contain corresponding scanned images.

To calibrate scanned images with automatically detectable fiducial marks
1. Select Camera Calibration... command from the Tools menu.

2. Inthe Camera Calibration dialog box check Film camera with fiducial marks option.
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Close Camera Calibration dialog with OK button.
Run Detect Fiducials... command from the Markers submenu from the Tools menu.

Inthe Camera Calibration dialog box print in coordinates of the automatically detected fiducial marks
on the image according to the analog camera certificate. They should be measured in coordinate
system associated with the sensor: origin - in the center of the sensor; axes X - to the right, axes Y
- downwards; in millimeters (mm).

Close Camera Calibration dialog with OK button and proceed to general Metashape processing
workflow starting from Align Photos... step. The software will automatically scale and orientate all
the photos according to the fiducial marks information.

In case your fiducial markstype is not among those supported for automatic detection (see Figure above),
please place a feature request with Agisoft support team: support@agisoft.com. The current version of
the software allows to perform calibration of the scanned images based on such fiducial marks manually
following the procedure outlined below.

To calibrate scanned images with non-standard fiducial marks manually

1
2.
3.

© © N o O

11.

£

Select Camera Calibration... command from the Tools menu.
In the Camera Calibration dialog box check Film camera with fiducial marks option.

OntheFiducialstab add fiducial mark instances, the number should be equal to the amount of fiducial
marks used on the original photos.

Print in coordinates of the fiducial marks on the image according to the analog camera certificate.
They should be measured in coordinate system associated with the sensor: origin - in the center of
the sensor; axes X - to theright, axes Y - downwards; in millimeters (mm).

Close Camera Calibration dialog with OK button.

Then it is necessary to place al the fiducials on each photo from the calibration group.
Open the photo in Photo view.

Zoom in to afiducial mark center.

Right button click on the targeted fiducial mark and use Place Fiducial command from the context
menu. Y ou will need to choose a corresponding fiducial mark instance from the dropdown list.

In case you need to replace one fiducial mark with another right-click fiducial mark and use Replace
Fiducial command from its context menu. You will need to choose a corresponding fiducial mark
instance from the dropdown list.

After placing al the fiducial mark instances, you can proceed to general Metashape processing
workflow. The software will automatically scale and orientate all the photos according to the fiducial
marks information.

Note

« If there is no camera certificate with fiducial marks coordinates information for the data set in
guestion, then it will be necessary to additionally run Calibrate Fiducials... command from the
context menu of the selected images in the Camera Calibration dialog box. All the images from
the respective calibration group should be selected for the purpose.

« Itisrecommended to mask out all the margins with auxiliary information on scanned photos to
avoid negative effect on the stability of the further processing.
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Camera calibration parameters

Photogrammetric calibration of camerasis performed to determine the values of the interior orientation of
the cameras, including the parameters of distortion of the cameralens. The camera calibration parameters
can be input manualy, if they have been acquired as a part of precalibration procedure.

To specify camera calibration parameters
1. Select Camera Calibration... command from the Tools menu.

2. Select calibration group, which requires re-estimation of camera orientation parameters on the left
side of the Camera Calibration dialog box.

In the Camera Calibration dialog box, select I nitial tab.
Modify the calibration parameters displayed in the corresponding edit boxes.
Set the Type to the Precalibrated value.

Repeat to every calibration group where applicable.

N o o &~ W

Click OK button to set the cadibration.
The following calibration parameters are available:

f
Focal length measured in pixels.

CX, cy
Principal point coordinates, i.e. coordinates of lensoptical axisinterceptionwith sensor planein pixels.

b1, b2
Affinity and Skew (non-orthogonality) transformation coefficients.

k1, k2, k3, k4
Radia distortion coefficients.

pl, p2
Tangential distortion coefficients.

4 Note

< Alternatively, initia calibration data can be imported from file using Load button on the Initial
tab of the Camera Calibration dialog box. In addition to Agisoft calibration file format it is
possible to import data from Australis, PhotoMaodeler, 3DM CalibCam, CalCam, Inpho camera
calibration, USGS camera calibration, OpenCV and Z/I Distortion Grid formats.

Initial calibration data will be adjusted during the Align Photos processing step. Once Align Photos
processing step is finished adjusted calibration data will be displayed on the Adjusted tab of the Camera
Calibration dialog box. Thedetailsabout distortion model sused in Metashape aregiveninthe Appendix C,
Camera models section.

If very precise calibration datais available, click Select... button next to Fixed parameters: item. In Fixed
parametersdial og choose calibration parametersthat are to befixed and click OK button. Theinitial values
for the chosen parameters will not be changed during Align Photos or Optimize Cameras operations.

In some casesit may be required to estimate some sub-set of parametersindividually for each camerainthe
calibration group. Inthis case such parameters should be selected in the section Image-variant parameters.
Click Select button and choose these parameters in Image-variant parameters dialog box.
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Adjusted camera calibration data can be saved to file using Save button on the Adjusted tab of the Camera
Calibration dialog box.

Analyzing calibration results

M etashape provides a number of tools to analyze camera calibration results available from context menu
of acameragroup in the Camera Calibration dialog.

Distortion

Distortion tab presents estimated camera distortion plot. Total, Radial, Decentering, Corrections and
Residual optionsare availablein the tab. Distortion graph represent the distortion values and direction
according to the adjusted calibration coefficient values. It shows the plot in the discrete vectors mode
for a central point in the corresponding image cell. Residuals presents residuals graph which allows
to evaluate how adequately the camera is described with the applied mathematical model. Note that
residuals are averaged per cell of an image and then across all the images in a camera group. Scale
reference under the plot indicates the scale of the distortiong/residuals.

Profile
Profile tab presents increase of the corresponding radial and decentering distortions with distance
from the center of the photo. Profiles can be saved asimage.

Correlation
Correlation tab presents:

» Adjusted values of theinternal camera orientation parameters;
» Errors- standard deviation, read more in Covariance matrix section;

» Correlation values for internal camera orientation parameters - reflect the degree of correlation
between the corresponding parameters.

Vignetting
Vignetting tab presents radiometric distortion of the lens. Metashape uses radiometric distortion
parameters of the lens from photos metadata, in case there is no information about radiometric
distortion of the lens in photo metadata Vignetting tab is inactive. You can calculate radiometric
distortion manually using Calibrate Colors command available from the Tools menu, read more in
Building model texture section.

Setting coordinate system

Many applications require data with a defined coordinate system. Setting the coordinate system also
provides a correct scaling of the model allowing for surface area and volume measurements and makes
model loading in geoviewers and geoinformation software much easier. Some Metashape functionality
like digital elevation model export is available only after the coordinate system is defined.

M etashape supports setting a coordinate system based on ground control point (marker) coordinates and/
or camera coordinates. In both cases the coordinates are specified in the Reference pane and can be either
loaded from the externa file or typed in manualy. Initially Metashape expects both GCPs and camera
coordinates data to be specified in the same coordinate system and assigns it as the coordinate system of
the chunk. In such a case all the outputs by default will be referenced in this particular coordinate system.

If the GCPs and camera coordinates datais measured in different coordinate systems, M etashape allowsto
input thisdataasis, provided that either all the coordinate systems are based on the same datum or for all of
them transformation-to-WGS84 parameters are specified in the coordinate system definition or manually
set in the datum transformation settings dialog. For Metashape to correctly interpret the coordinates data,
it is necessary to enable individual coordinate system selection for cameras and markersin the Reference
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pane settings dialog by checking the corresponding option and sel ecting proper coordinate systems. In this
case coordinate system to reference the model in (coordinate system of the chunk) should be set in the
Reference pane settings dialog - in the very first dropdown menu list.

Setting coordinate system based on recorded camera positions is often used in aerial photography
processing. However, it may be also useful for processing close-range data sets collected with GPS enabled
cameras. Placing markersisnot required if recorded cameracoordinatesare used to initialize the coordinate
system.

In case ground control points are used to set up the coordinate system, markers should be placed in the
corresponding locations of the scene.

Using camera data for georeferencing is faster since manual marker placement is not required. On the
other hand, ground control point coordinates are usually more accurate than telemetry data, allowing for
more precise georeferencing. During georeferencing process the model is linearly transformed using 7
parameter similarity transformation (3 parameters for tranglation, 3 for rotation and 1 for scaling). Such
transformation can compensate only for linear model misalignment.

Placing markers

M etashape uses markersto specify locationswithin the scene. Markers are used for setting up acoordinate
system, photo alignment optimization, measuring distances and volumes within the scene as well as for
marker based chunk alignment. The position of markers is determined by their coordinates in the images.
Alternatively, it is possible to set Drawing Plane for marker placement in the Model view. Read more
about setting drawing plane in Shapes section.

To determine the spacial coordinates of the markers, it is necessary to measure planar coordinates of the
markers on at least 2 images.

4 Note

» Marker placement is not required for setting up a coordinate system based on recorded camera
coordinates. Instead the ground control points (GCPs) can be used to improve the accuracy of
results.

M etashape supports two approaches to marker placement: manual marker placement and guided marker
placement. Manual approach implies that the marker projections should be indicated manually on each
photo where the marker is visible. Incorrect projection markers affect accuracy. Be careful when placing
the markers on theimages, specify the exact position, and see that the markers are not obscured by foreign
objects (for example, grass or foliage). In such cases, it is better not to put a marker on such an image.
Manual marker placement does not require 3D model and can be performed even before photo alignment.

In the guided approach marker projection is specified for a single photo only. Metashape automatically
projects the corresponding ray onto the model surface and calculates marker projections on the rest of
the photos where marker is visible. Marker projections defined automatically on individual photos can be
further refined manually. Reconstructed 3D model surface is required for the guided approach.

Guided marker placement usually speeds up the procedure of marker placement significantly and also
reduces the chance of incorrect marker placement. It is recommended in most cases unless there are any
specific reasons preventing this operation.

Ground control and check points

In Metashape you can use two types of markers. They are control and check points. Control points are
used to reference the model. While check points are used to validate accuracy of the camera alignment
and optimization procedures results.
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To create a control/check point

1. Select marker on the Reference pane.

2. Ensurethat the selected marker has at least two projections placed on the aligned images. Y ou should
check pointsbox. If the check box isenabled, the point isthe control point. When check box isdisable,
the point is the check point.

3. Input control/check point coordinates information to the Source Values tab of the Reference pane.

4. Enable marker on the Reference pane to make it a control point or disable to useit as a check point.

5. Control and check point errors can be inspected on the Errors Values tab.

£ Note

* After you change the point type click '_"Jrl'ﬂ Update toolbar button from the Reference pane.

« After use the Update button, the 7th parametric transformation is performed.

To place amarker using guided approach

1. Open aphoto where the marker is visible by double clicking on its name.

2 Switch to the marker editing mode using ”Q? Show Markers toolbar button.

3. Right click on the photo at the point corresponding to the marker location.

4. Select Add Marker command from the context menu. New marker will be created and its projections
on the other photos will be automatically defined.

4 Note

« |If the 3D model is not available or the ray at the selected point does not intersect with the model
surface, the marker projection will be defined on the current photo only.

» Guided marker placement can be performed in the same way from the 3D view by right clicking

on the corresponding point on the model surface and using ﬂ% Create Marker command fromthe
context menu. While the accuracy of marker placement in the 3D view isusually much lower, it
may be still useful for quickly locating the photos observing the specified |ocation on the model.

To view the corresponding photos use ”ﬁ Filter Photos by Markers command again from the
3D view context menu. If the command isinactive, please make sure that the marker in question
is selected on the Reference pane.

If the circle under the flag is ® e in the Model view, the marker is selected. If © yellow -
the marker is not selected.

To placea marker using manual approach

1

2.

Create marker instance using "%Add marker button on the Workspace pane or by Add Marker
command from the Chunk context menu.

Open the photo where the marker projection needsto be added by double clicking on the photos name.
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Switch to the marker editing mode using ”Q? Show Markerstoolbar button.

4. Right click at the point on the photo where the marker projection needsto be placed. From the context
menu open Place Marker submenu and select the marker instance previoudly created. The marker
projection will be added to the current photo.

5. Repeat the previous step to place marker projections on other photos if needed.

To save up time on manual marker placement procedure Metashape offers guiding lines feature. When a
marker is placed on an aligned photo, Metashape highlights lines, which the marker is expected to lie on,
on the rest of the aligned photos.

£ Note

 If a marker has been placed on at least two aigned images Metashape will find the marker

projections on the rest of the photos. The calculated marker positions will be indicated with }
icon on the corresponding aligned photos in Photo view mode.

Automatically defined marker locations can be later refined manually by dragging their projections on the
corresponding photos.

The commands Unpin marker and Block marker are available from the context menu of the marker on
the image. To reset the updated marker position, select Unpin marker command, the marker will display
as a blue flag. If Blocks marker option is selected, then the marker projection on particular image will
not be displayed.

Torefine marker location

1. Open the photo where the marker is visible by double clicking on the photo's name. Automatically

placed marker will be indicated with “Q?i con.

Switch to the marker editing mode using ”Q? Edit Markerstoolbar button.

3.  Movethe marker projection to the desired location by dragging it using left mouse button. Once the

marker location isrefined by user, the marker icon will change to ﬂ'—‘D

4 Note

» To list photos where the marker locations are defined, select the corresponding marker on the
Workspace pane. The photos where the marker is placed will be marked with aﬂq? icon on the

Photos pane. To filter photos by marker use "ﬁ Filter by Markers command from the 3D view
context menu.

In those cases when there are hesitations about the features depicted on the photo, comparative inspection
of two photos can prove to be useful. To open two photosin Metashape window simultaneously Move to
Other Tab Group command is available from photo tab header context menu.

M etashape supports automatic marker projection refinement based on the image content. Choose Refine
Markers command from the Markers submenu of the Tools menu.

To open two photos simultaneously

1. Inthe Photos pane double click on one photo to be opened. The photo will be opened in a new tab
of the main program window.
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Right click on thetab header and choose Move to Other Tab Group command from the context menu.
The main program window will be divided into two parts and the photo will be moved to the second
part.

The next photo you will choose to be opened with a double click will be visualized in the active tab
group.

M etashape automatically assignsdefault |abelsfor each newly created marker. Theselabel s can be changed
using the Rename... command from the marker context menu in the Workspace / Reference pane.

Assigning reference coordinates

To reference the model, real world coordinates of at least 3 points of the scene should be specified.
Depending on the requirements, the model can be referenced using marker coordinates, camera
coordinates, or both. Real world coordinates used for referencing the model aong with the type of
coordinate system are specified in the Reference pane.

Themodel can belocated in either local Euclidean coordinates or in georeferenced coordinates. M etashape
supports a wide range of various geographic and projected coordinate systems, including widely used
WGS84 coordinate system. Besides, almost al coordinate systems from the EPSG registry are supported
aswell.

Methods to input coordinates data

Reference coordinates can be specified in one of the following ways:

» Loaded from a separate text file (using character separated values format).

 Entered manually in the Reference pane.

» Loaded from GPS EXIF tags (if present).

Toload reference coordinates from a text file

1

Click = Import toolbar button on the Reference pane. (To open Reference pane use Reference
command from the View menu.) Browse to the file containing recorded reference coordinates and
click Open button.

In the Import CSV diaog set the coordinate system if the data presents geographical coordinates.
Select the delimiter and indicate the number of the data column for each coordinate.

Indicate columns for the orientation dataif present. Make sure that the proper angle triple (according
to the source data) is set; [yaw,pitch,roll], [omega, phi, kappa], [phi, omega, kappa] or [apha, nu,
kappa] .

Optionally, indicate accuracy values for coordinates and rotation angles.

Click OK button. The reference coordinates data will be loaded onto the Reference pane.

Note

« If reference coordinates of amarker / camera position for aphoto are not specified in the loading
file the current value will be kept for them.

« Anexample of acoordinates datafile in the CSV format is given in the next section.
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Information on the accuracy of the source coordinates (X, y, z) aswell as of the source orientation angles
can beloaded withaCSV fileaswell. Check Load Accuracy option and indicate the number of the column
where the accuracy for the data should be read from. It is possible to indicate the same accuracy column
for al three coordinates/angles.

To assign reference coor dinates manually

1 Switch to the View Source mode using E View Source button from the Reference pane toolbar. (To

open Reference pane use Reference command from the View menu.)

2. Onthe Reference pane select x/y/z or angle data cells and press F2 button on the keyboard to assign
values to corresponding coordinates/angles.

3. Repeat for every marker/camera position (orientation angle) needed to be specified.

4. To remove unnecessary reference coordinates select corresponding items from the list and press Del
key.

Click F‘:[ﬂ Update toolbar button to apply changes and set coordinates.

System of angular elements of exterior orientation([yaw,pitch,roll], [omega, phi, kappa] or [alpha, nu,
kappa]) can be switched in the Reference Settings dialog. Do not forget to click OK button in the Reference
Settings dialog to apply the changes.

Additionally, it is possible to indicate accuracy data for the coordinates / orientation angles. Select Set
Accuracy... command from the context menu of an image on the Reference pane and input accuracy
data both for position (i.e. x,y,z coordinates) and orientation (i.e. [yaw, pitch, roll], [omega, phi, kappa],
[phi,omega,kappa] or [apha, nu, kappa] angles) data. It is possible to select several cameras and apply
Set Accuracy... command simultaneously to al of them. Alternatively, you can select Accuracy (m) or
Accuracy (deg) text box for a certain camera on the Reference pane and press F2 button on the keyboard
to type the text data directly onto the Reference pane. Note that "/* delimiter allows to enter different
accuracy datafor x, y, z or orientation angles ([yaw, pitch, roll], [omega, phi, kappa], [phi,omega,kappa]
or [alpha, nu, kappa]) data respectively.

Toload reference coordinates from GPS EXIF tags

1 Click E Import EXIF button on the Reference pane. (To open Reference pane use Reference

command from the View menu.) The reference coordinates data will be loaded into the Reference
pane.

2. If the corresponding options in the Advanced tab o the Preferences window are checked on, it is
also possible to load camera orientation angles and location/rotation accuracy parameters from XMP

extension of the image header. The data will be loaded upon clicking E Import EXIF button.

Camera orientation angles conventions

Metashape allows to define camera orientation with either [yaw, pitch, roll], [omega, phi, kappa], [phi,
omega, kappa] or [apha, nu, kappa] angles. The more common scenario is to load [yaw, pitch, roll]
measurements directly from the airborne IMU system and, hence, default setting in Metashapeisto tackle
the input values as [yaw, pitch, roll] data.

To provide compatibility with different processing workflows Metashape also supports [omega, phi,
kappa] data input. The omega, phi, kappa angles are defined as the angles used in order to rotate the
(X,Y,Z) geodetic coordinate system and align it with the image coordinate system.
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» Omegaistherotation around the X axis.
* Phi istherotation around the Y axis.

» Kappaistherotation around the Z axis.
Y aw, Pitch, Roll definition:

* Yaw istherotation around the Z axis.

* Pitchistherotation around the Y axis.

* Rall istherotation around the X axis.
Alpha, Nu, Kappa definition:

» Alphaistherotation around the Z axis.
* Nuistherotation around the X axis.

» Kappaistherotation around the Y axis.

RTK/PPK camera coordinates data

If the source data includes RTK/PPK measurements, it is important to input accuracy values for all the
respective cameras onto the Reference pane. Otherwise default accuracy value (10 m) will be assumed for
all camera coordinates in the chunk, hence, the value of the RTK/PPK measurements will efficiently be
lost and the processing results will not be referenced with expected accuracy. In case the coordinates input
for the cameras are measured for the point where the measuring instrument is mounted (not the camera
itself) it is aso necessary to input measurement instrument shift with respect to the cameraitself on GPS
INS Offset tab of Camera Calibration dialog available from Tools menu.

After reference coordinates have been assigned M etashape automatically estimates coordinatesin alocal
Euclidean system and cal cul ates the referencing errors. To see the results switch to the View Estimated or

View Errors modes respectively using @ View Estimated and L_l_ View Errorstoolbar buttons.

Setting georeferenced coordinate system

To set a georeferenced coordinate system
1. Assign reference coordinates using one of the options described above.

2 Click %5 sati ngs button on the Reference pane toolbar.

3. In the Reference Settings dialog box select the Coordinate System used to compile reference
coordinates data if it has not been set at the previous step.

4. Specify the assumed measurement accuracy in the left-hand side part of the dialog.

5. If the information about GPS system shift with respect to the camera itself is available, it is worth
inputting it on GPS/INS Offset tab of Camera Calibration dialog available from Tools menu. See
Figure below.

6. Specify the assumed image coordinates accuracy in the corresponding column of the dialog.
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7. Specify Capture distance parameters for the datasets where the images are captured with the oblique
camera mount (more than 20-30 degrees from the vertical).

8. Click OK button to initialize the coordinate system and estimate geographic coordinates.

4 Note

« When the coordinate information for the camera locations is present in the Source values tab
of the Reference pane and the Capture Distance parameter is not defined, the Reference Pair
Preselection will consider only XY Z coordinatesfor preliminary identification of the overlapping
image pairs. For each camera the certain number of closest neighbors will be selected for the
image matching operation.

< When the Capture Distance parameter is input and camera orientation angles (yaw, pitch, roll
or omega, phi, kappa) are present along with the XY Z camera locations in the Reference pane,
then for the neighbors estimation the following points are considered: from the original camera
locations the vector is sent according to the orientation angles, the length of the vector is equal
to the Capture Distance parameter values. So for each camerathe new 3D location is calculated
(X'Y'Z") and these new points are used for the neighbors estimation.

« |If camera orientation angles are not loaded to the Source values tab or Reference preselectionis
not enabled in the Align Photos dial og, the Capture Distance parameter will be ignored.

GPSJ/INS Offset

Z cam
GPS

®

Ycam

Z offset

Yoffset

VAR,

» X cam

X offset

GPS offset.

Rotation angles for the camera coordinates in M etashape are defined around the following axes. yaw axis
runs from top to bottom, pitch axis runs from left to right wing of the drone, roll axis runs from tail to nose

86



Referencing

of the drone. Zero values of the rotation angle triple define the following camera position aboard: camera
looks down to the ground, frames are taken in landscape orientation, and horizontal axis of the frame is
perpendicular to the central (tail-nose) axis of the drone. If the camera is fixed in a different position,
respective yaw, pitch, roll values should be input on GPS/INS Offset tab of Camera Calibration dialog.
The signs of the angles are defined according to the right-hand rule. See Figure below.

INS offset.

4 Note

e Step 5 can be safely skipped if you are using standard GPS system (not that of superhigh
precision).

In Select Coordinate System dialog it is possible to ease searching for the required georeferencing system
using Filter option. Enter respective EPSG code (e.g. EPSG::4302) to filter the systems.

Coordinate system editor

If the target coordinate system is not on the list, it is possible to set its parameters manually. In Select

Coordinate Systemdial og choose any coordinate system and click 4 Edit button. (Obvioudly, itisoptimal
to select a coordinate system which parameters are the most similar onesto the target coordinate system.)
Enter the proper name for the system to be shown on the list and edit al the parameters according to the
coordinate system definition.

Configurable datum transformation

If the project coordinate system should be converted to WGS84, Datum Transformation Settings dialog

isamed at controlling proper parameters for the conversion. The dialog can be accessed via #% Setti ngs
button next to Coordinate System selection field in the Reference Settings dial og.
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Using different vertical datums

By default Metashape requires al the source atitude values for both cameras and markers to be input as
values measured above the ellipsoid. However, M etashape allowsfor the different geoid model s utilization
aswell. Metashape installation package includes only EGM 96 geoid model, but additional geoid models
can be downloaded from Agisoft's website if they are required by the coordinate system selected in the
Reference pane settings dialog. Downloaded geoid model from the supported list should be copied to
\geoids\ folder in Metashape install ation directory before using the corresponding coordinate system from
GULI.

Please refer to the following web-page to review the list of supported geoid models. http://
www.agi soft.com/downloads/geoids/.

Additional features of the Reference pane

To view the estimated geographic coordinates, reference errors and variance switch between the View
Estimated, View Errorsand View V ariance modes respectively using @ View Estimated, L_l_ View Errors

and E View Variance toolbar buttons. A click on the column name on the Reference pane sorts the
markers and cameras by the datain the column. At this point you can review the errors and decide whether
additional refinement of marker locations is required (in case of marker based referencing), or if certain
reference points should be excluded.

To save the errors and/or estimated coordinates use =2l Export toolbar button on the Reference pane.

To reset a chunk georeferencing, use Reset Transform command from the chunk context menu on the
Workspace pane. [R] indicator of achunk being georeferenced will be removed from the chunk name.

4 Note

e Unchecked reference points on the Reference pane are not used for georeferencing and
optimization. Use context menu to check/uncheck selected items.

» After adjusting marker locations on the photos, the coordinate system will not be updated

automatically. It should be updated manually using 'Tﬂ Update toolbar button on the Reference
pane.

« Metashape allows to convert the estimated geographic coordinates into a different coordinate
system. To calculate the coordinates of the camera positions and/or markers in a different

coordinate system use = Convert toolbar button on the Reference pane.

Example of a reference coordinates file in CSV format
(*.txt)

Thereference coordinates can be loaded onto the Reference pane using character separated text fileformat.
Eachreference point isspecifiedin thisfileon aseparateline. Samplereference coordinatesfileisprovided
below:
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# <l abel > <l ongitude> <l atitude> <hei ght> <yaw> <pitch> <roll >
| MG 01. JPG 40.165011 48.103654 433.54 15.54 0.39 0.87
| MG 02. JPG 40.165551 48.103654 434.72 15.73 0.38 1.21
| MG_03.JPG 40.166096 48.103640 435.63 15.67 0.24 1.04

Individual entries on each line should be separated with atab (space, semicolon, comma, etc) character.
All lines starting with # character are treated as comments.

Records from the coordinate file are matched to the corresponding cameras or markers basing on the
label field. Camera coordinates labels should match the file name of the corresponding photo including
extension. Marker coordinates |abels should match the labels of the corresponding markers in the project

file. All labels are case insensitive.

M etashape has the ability to use degrees, minutes, secondsin aCSV file. An example entry:

| M300001. j pg, 19°39' 59. 99"E, 60° 20' 0. 05"N, 100. 073997

or "colon" delimiter:

| M300002. j pg, 19: 39: 59. 99E, 60: 20: 0. 05N, 100. 073997

4 Note

» Character separated reference coordinates format does not include specification of the type of
coordinate system used. The kind of coordinate system used should be selected separately in the
Reference Settings dialog.

« Metashape requires Z value to be indicating the height above the €ellipsoid (or above geoid, if
corresponding compound coordinate system is selected in the Reference pane settings dialog).

Optimization

Optimization of camera alignment

Optimize Cameras command performsafull bundle adjustment procedure on the aligned photogrammetric
block, simultaneously refining exterior and interior camera orientation parameters and triangulated tie
point coordinates. Adjustment is performed based on all available measurements and corresponding
accuracies, including image projections of tie points and markers, GPS coordinates of image centers, GCP
coordinates, scale bar distances, etc.

4 Note

« If markers are used for the optimization process, we recommend distributing the control points
evenly over the survey object. It isalso necessary that the markers are not located on one straight
line.

89



Referencing

To ensure maximum geometric accuracy of processing results, it isimportant to always optimize cameras
after adding or editing measured values and/or their accuracies, e.g. loading GPS camera coordinates,
adding GCPs, changing accuracy settings.

4 Note

» By default optimization adjusts both exterior and interior camera orientation parameters. When
working with a pre-calibrated camera, it is possible to load available calibration in the Camera
Cadlibration dialog and set its parameters as fixed. Fixed parameters will not be adjusted during
optimization step.

To optimize camera alignment

1.

2.

10.

Set the marker and/or camera coordinates to be used for optimization (if not done yet).

Click ‘&8 Setti ngstoolbar button on the Reference pane and set the coordinate system (if not doneyet).

In the Reference pane Settings dialog box specify the assumed accuracy of measured values as well
as the assumed accuracy of marker projections on the source photos.

Click OK button.

Indicaterelative GPS device and/or INSto cameracoordinates (if infoisavailable) on GPSINS Offset
tab of Camera Calibration dialog available from Tools menu.

Check Adjust GPSINS offset box.

Click OK button.

Click & Optimize toolbar button on the Reference pane.
In Optimize Camera Alignment dialog box check additional camera parameters to be optimized.

Click OK button to start optimization.

Note

« Step 5 can be safely skipped if you are using standard GPS (not that of extremely high precision).

« Using RTK / PPK camera coordinates datawill also provide more accurate results. More details
about using RTK / PPK data can be found in Setting coordinate system section.

* The optimization procedure discards active depth maps, dense cloud and mesh model from the
chunk. It is recommended to rebuild these objects after performing the optimization.

 The optimization process can improve the results of alignment and reduce the errors.

Optimize Camera Alignment parameters
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Optimize Camera Alignment

General
Fit f Fit ox, cy
Fit k1l Fitpl
Fitk2 Fitp2
Fit k3 Fitb1
Fit k4 Fit b2
Advanced

Adaptive camera model fitting
Estimate tie point covariance

Fit additional corrections

Lok ] Cancel

"Optimize Camera Alignment" dialog

Fit additional corrections
With this option enabled Metashape estimates additional coefficients that are necessary to achieve
better accuracy. There are different corrections which alows to compensate the distortions which
cannot befit by theideal Brown's model used (see Appendix C, Camera models section). This option
may be helpful for the datasets acquired with DJI P4 RTK drone, when no GCPs are used.

Adaptive camera model fitting
This option enables automatic selection of camera parameters to be included into adjustment based
on their reliability estimates. Read more about in Aligning photos section.

Estimatetie point covariance
The function alows to estimate the covariance values of the tie point.

Image coordinates accuracy for markers indicates how precisely the markers were placed by the user or
adjusted by the user after being automatically placed by the program.

Capture distance parameter is used to make reference preselection mode of alignment procedure work
effectively for oblique imagery. See Aligning photos for details.

Camera, marker and scale bar accuracy can be set per item (i.d. per camera/marker/scale bar) using
Accuracy column on the Reference pane. Accuracy vaues can be typed in on the pane per item or for a
group of selected items. Alternatively accuracy values can be uploaded along with camera/lmarker data
asatext file (see Assigning reference coordinates subsection of Setting coordinate system). Additionaly,
different accuracy per coordinate can beindicated using "/ as a separator between valuesin the Accuracy
column.

GPS/INS offset values input by the user can aso be adjusted by M etashape with respect to measurement
accuracy that may be indicated on the GPSINStab of Camera Calibration dialog. Uncheck Adjust GPS
INS offset box to allow for adjustment procedure.
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Generally it isreasonableto run optimization procedure based on markersdataonly. It isdueto thefact that
GCPs coordinates are measured with significantly higher accuracy compared to GPS data that indicates
camera positions. Thus, markers data are sure to give more precise optimization results. Moreover, quite
often GCP and camera coordinates are measured in different coordinate systems, that also prevents from
using both cameras and markers data in optimization simultaneously.

The results of the optimization procedure can be evaluated with the help of error information on the
Reference pane. In addition, distortion plot can be inspected along with mean residuals visualized per
calibration group. Thisdataisavailablefrom Camera Calibration dialog (Tools menu), from context menu
of a camera group - Distortion Plot... command. Note that residuals are averaged per cell of an image
and then across all the images in a camera group. Scale reference under the plot indicates the scale of the
distortiong/residuals. Read more in What do the errors in the Reference pane mean? section.

In case optimization results does not seem to be satisfactory, you can try recalculating with lower values
of accuracy parameters, i.e. assuming ground control measurements to be more accurate.

Covariance matrix

If additional analysesis required, extra option Estimate tie point covariance can be selected on running
the Optimization procedure. As a result, Metashape will calculate covariance matrix for the bundle
adjustment calculations. Covariance matrix captures the uncertainty of the transformation. Covariance
matrix diagonal elements are variances, oiiz; the positive square root of the variance, 4, is called the
standard deviation. Standard deviation values for the camera position coordinates and rotation angles can
be inspected on the Reference pane - View Variance tab. Covariance matrix off-diagonal elements are
covariances, 4ij. The value of each covariance reflects the degree of correl ation between the corresponding
parameters. Calculated covariance valuesfor the tie points can be inspected in the Model view using Point
Cloud Covariance command available from View Mode submenu of Model menu. Vector associated with
each tie point indicates the direction and value of the largest error for thetie point estimated position (large
semi-axis of the error ellipsoid determined by the covariance values). The color code is amed to help to
perceive the general distribution of the errors across the tie point cloud at a glance.

Scale bar based optimization

Scale bar is program representation of any known distance within the scene. It can be a standard ruler or
a specialy prepared bar of a known length. Scale bar is a handy tool to add supportive reference data to
your project. They can prove to be useful when there is no way to locate ground control points al over
the scene. Scale bars allow to save field work time, since it is significantly easier to place several scale
bars with precisely known length, than to measure coordinates of afew markers using special equipment.
In addition, Metashape allows to place scale bar instances between cameras, thus making it possible to
avoid not only marker but ruler placement within the scene as well. Surely, scale bar based information
will not be enough to set a coordinate system, however, the information can be successfully used while
optimizing the results of photo alignment. It will aso be enough to perform measurements in Metashape
software. See Performing measurements on 3D model.

To add a scale bar between markers

1. Placemarkersat the start and end points of the bar. For information on marker placement please refer
to the Setting coordinate system section of the manual.

2. Select both markers on the Reference pane using Ctrl button.

Select B Create Scale Bar command form the Model view context menu. The scale bar will be
created and an instant added to the Scale Bar list on the Reference pane.
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5.

Switch to the E View Source mode using the Reference pane toolbar button.

Double click on the Distance (m) box next to the newly created scale bar name and enter the known
length of the bar in meters.

To add a scale bar between camer as

1

Select the two cameras on the Workspace or Reference pane using Ctrl button. Alternatively, the
cameras can be selected in the Model view window using selecting tools from the toolbar.

Select Ei2 Create Scale Bar command form the context menu. The scale bar will be created and an
instant added to the Scale Bar list on the Reference pane.

Switch to the E View Source mode using the Reference pane toolbar button.

Double click on the Distance (m) box next to the newly created scale bar name and enter the known
length of the bar in meters.

Torun scale bar based optimization

1.

2.

On the Reference pane check all scale bars to be used in optimization procedure.

Click ©% Setti ngs toolbar button on the Reference pane. In the Reference pane Settings dialog box
specify the assumed accuracy of scale bars measurements.

Click OK button.

Click # Optimizetoolbar button. In Optimize Camera Alignment dial og box check additional camera
parameters to be optimized if needed. Click OK button to start optimization.

After the optimization is complete, cameras and markers estimated coordinates will be updated aswell as
all the georeferencing errors. To analyze optimization results switch to the View Estimated mode using
the Reference pane toolbar button. In scale bar section of the Reference pane estimated scale bar distance

will be displayed.
Todeletea scale bar
1. Select the scale bar to be deleted on the Reference pane.

2.

3.

Right-click on it and chose Remove Scale Bars command from the context menu.

Click OK for the selected scale bar to be deleted.

What do the errors in the Reference pane

mean?

To analyze errors switch to the View Errors mode using the Reference pane toolbar button.

Camer as section

1.

Error (m) - residual error per coordinate or in 3D space. That is distance between the input (source)
and estimated positions of the camera.
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2. Error (deg) - residua error per orientation angle or in 3D space (that is root mean sgquare error
calculated over all three orientation angles).

3. Error (pix) - root mean square reprojection error calculated over al valid tie points detected on the
photo.

4. Totd error - total error iscalculated asroot mean squarefor al theval uesin the corresponding column.

Reprojection error is the distance between the point on the image where a reconstructed 3D point can be
projected and the original projection of that 3D point detected on the photo and used as a basis for the
3D point reconstruction procedure.

M arkers section

1. Error (m) - residual error per coordinate or in 3D space. That is distance between the input (source)
and estimated positions of the marker.

2. Error (pix) - root mean sguare reprojection error for the marker calculated over al photos where
marker isvisible.

3. Total error (Control points and Check points) - total error is calculated as root mean square for all
the values in the corresponding column.

If the total reprojection error for some marker seems to be too large, it is recommended to inspect
reprojection errors for the marker on individual photos. The information is available with Show Info
command from the marker context menu on the Reference pane.

In Metashape estimated check point coordinates displayed in the Reference pane ( as well as the error
values) are calculated based on minimization of the reprojection error only, without taking into account
measured check point coordinates in 3D-space. So they do not correspond to adjusted coordinates from
the bundl e adjustment step, and are cal culated solely from weighted image measurements.

On the other hand, estimated coordinates of the control points correspond to the adjusted values, that is,
they are calcul ated taking into account both reprojection error and measured obj ect space coordinates. This
approach alows for better detection of the measurement errors.

If you are interested in the difference between measured (source) and triangulated (estimated) control
point coordinates only, you can temporary uncheck the corresponding entry in the Reference pane (thus
making it a check point) and observe the values in the Errors tab. Note that Update button shouldn't be
pressed after conversion of the control point to the check point, otherwise the estimated values would be
recal culated with the given reference point excluded from the computation.

Scale Bar s section

1. Error (m) - residual error per coordinate or in 3D space. That is difference between the input (source)
scale bar length and the measured distance between two cameras or markers representing start and
end points of the scale bar.

2. Total error (Control scale bars and Check scale bars) - total error is calculated as root mean square
for all the values in the corresponding column.

Working with coded and non-coded targets

Coded and non-coded targets are specially prepared, yet quite simple, real world markers that can add
up to successful 3D model reconstruction of a scene. Targets are artificial markers placed in the scene to
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provide manual image correspondences in cases where automatic matching fails. Coded and non-coded
targets can mark object point to be used for georeferencing. In the figure of coded targets, their identifier is
recorded, which allowsto automatically and accurately compare their projections of different images. The
difference between coded and non-coded targets is that while a non-coded target looks like an ordinary
full circle or afigure (circle/ rectangular) with 4 segments, the coded target has aring parted in black and
white segments around the central full circle.

Coded targets advantages and limitations

Coded targets (CTs) can be used as markersto define local coordinate system and scale of the model or as
true matchesto improve photo alignment procedure. M etashape functionality includes automatic detection
and matching of CTson source photos, which allowsto benefit from marker implementation in the project
while saving time on manual marker placement. Moreover, automatic CTs detection and marker placement
is more precise then manual marker placement.

Metashape supports four types of circle CTs: 12 hit, 14 bit, 16 bit and 20 bit. While 12 hit pattern is
considered to be decoded more precisely, whereas 14 bit, 16 bit and 20 bit patterns allow for a greater
number of CTsto be used within the same project.

To be detected successfully CTs must take up a significant number of pixels on the original photos. This
leadsto anatural limitation of CTsimplementation: while they generally proveto be useful in close-range
imagery projects, aerial photography projects will demand too huge CTsto be placed on the ground, for
the CTsto be detected correctly.

Coded targets in workflow

Sets of all patterns of CTs supported by Metashape can be generated by the program itself.

Tocreatea printable PDF with coded tar gets

1. Select Print Markers... command from the Tools menu.

2. Specify the CTstype and desired print parametersin Print Markers dialog.
3. Click OK.

Once generated, the pattern set can be printed and the CTs can be placed over the scene to be shot and
reconstructed.

When the images with CTs seen on them are uploaded to the program, Metashape can detect and match
the CTs automatically.

To detect coded targets on sour ce images

1. Select Detect Markers... command from the Tools menu.

2. Specify parameters of detector in Detect Markers dialog according to the CTstype.

3. Click OK.

M etashape will detect and match CTs and add corresponding markers to the Reference pane.

CTs generated with Metashape software contain even number of sectors. However, previous versions of
M etashape software had no restriction of the kind. Thus, if the project to be processed contains CTs from
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previousversions of M etashape software, it isrequired to disable parity check in order to make the detector
work.

Non-coded targets implementation

Non-coded targets can a so be automatically detected by M etashape (see Detect Markersdial og). However,
for non-coded targets to be matched automatically, it is necessary to run align photos procedure first.

Non-coded targets.

Non-coded targets are more appropriate for aerial surveying projects due to the simplicity of the pattern
to be printed on alarge scale.

When non-coded targets are detected M etashape all ows automatic matching of detected non-coded targets
with referencing coordinates imported from file. To do that, when importing referencing coordinates
check the Ignore labels box in the Import CSV dialog. Metashape will try to match non-coded targets
markers with imported referencing coordinates markers, in case of success non-coded targets markers
will have corresponding coordinates. In case automatic matching does not work or works with errors,
manual assignment of an identifier is required if some referencing coordinates are to be imported from
afile correctly.
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Chapter 5. Measurements

Performing measurements on 3D model

M etashape supports measuring of distances on the model, as well as of surface area and volume of the
reconstructed 3D model. All the instructions of this section are applicable for working in the Model view
of the program window, both for analysis of Dense Point Cloud or of Mesh data. When working in the
Model view, al measurements are performed in 3D space, unlike measurements in Ortho view, which
are planar ones.

Distance measurement

Metashape enables measurements of distances between the points of the reconstructed 3D scene.
Obviously, model coordinate system must be initialized before the distance measurements can be
performed. Alternatively, the model can be scaled based on known distance (scale bar) information to
become suitable for measurements. For instructions on setting coordinate system pleaserefer to the Setting
coordinate system section of the manual. Scale bar concept is described in the Optimization section.

To measuredistance

L Select 4 Ruler instrument from the Toolbar of the Model view.

2. Click on the point of the model where the measurement should be started from.

3. Upon the second click on the model the distance between the indicated points will be shown right
in the Model view.

4. Thedistance can be measured along the polyline drawn with the Ruler.

5. To complete the measurement and to proceed to a new one, please press Escape button on the
keyboard. The result of the measurement will be shown on the Console pane

Shape drawing is enabled in Model view as well. See Shapes section of the manual for information on
shape drawing. Measure command avail able from the context menu of a selected shape allowsto learn the
coordinates of the vertices aswell as the perimeter of the shape.

To measure several distances between pairs of points and automatically keep the resulting data, markers
can be used.

To measur e distance between two markers

1. Placethe markersin the scene at the targeted locations. For information on marker placement please
refer to the Setting coordinate system section of the manual.

2. Select both markersto be used for distance measurements on the Reference pane using Ctrl button.

Select Ef Create Scale Bar command form the 3D view context menu. The scale bar will be created
and an instant added to the Scale Bar list on the Reference pane.

Switch to the estimated values mode using @ View Estimated button from the Reference pane
toolbar.
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5.

The estimated distance for the newly created scale bar equals to the distance that should have been
measured.

To measur e distance between camer as

1. Select the two cameras on the Workspace or Reference pane using Ctrl button. Alternatively, the
cameras can be selected in the Model view window using selecting tools from the Toolbar.

2 Select E& Create Scale Bar command form the context menu. The scale bar will be created and an
instant added to the Scale Bar list on the Reference pane.

3 Switch to the estimated values mode using @ View Estimated button from the Reference pane
toolbar.

4. The estimated distance for the newly created scale bar equals to the distance that should have been
measured.

4 Note

* Pleasenotethat the scale bar used for distance measurements must be unchecked on the Reference
pane.

¢ The distance values measured by Metashape are displayed in meters.

Shape-based measurements

Polyline and Polygon measurements

1

3.

4,

Indicate a line to make a cut of the model usi ng’c\ Draw Polyline '/ Draw Polygon tool from the
Model view.

Double click on the last point to indicate the end of a polyline.
Right button click on the polyline/polygon and select Measure... command from the context menu.

In the Measure Shape dialog displayed coordinates points, perimeter and coordinate system.

Point measur ement

1

2.

3.

Select Point measurement from the Toolbar of the Model view.
Right button click on the point and select Measure... command from the context menu.

In the Measure Shape dialog displayed coordinate point and coordinate system.

Surface area and volume measurement

Surface area or volume measurements of the reconstructed 3D model can be performed only after the scale
or coordinate system of the scene is defined. For instructions on setting coordinate system please refer to
the Setting coordinate system section of the manual.
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To measure surface area and volume
1. Select Measure Area and Volume... command from the Tools menu.

2. Thewhole model surface areaand volume will be displayed in the Measure Area and Volume dialog
box. Surface area is measured in square meters, while mesh volume is measured in cubic meters.

V olume measurement can be performed only for the models with closed geometry. If there are any holes
in the model surface Metashape will report zero volume. Existing holes in the mesh surface can be filled
in before performing volume measurements using Close Holes... command from the Tools menu.

Performing measurements on DEM

Metashape is capable of DEM-based point, distance, area, and volume measurements as well as of
generating cross-sections for a part of the scene selected by the user. Additionally, contour lines can be
calculated for the model and depicted either over DEM or Orthomosaic in Ortho view within Metashape
environment. Measurements on the DEM are controlled with shapes: points, polylines and polygons. For
information about how to create and work with shapes please refer to Shapes section of the manual.

Point measurement

Ortho view alows to measure coordinates of any point on the reconstructed model. X and Y coordinates
of the point indicated with the cursor as well as height of the point above the vertical datum selected by
the user are shown in the bottom right corner of the Ortho view.

Distance measurement

To measuredistance with a Ruler

L Select & Ruler instrument from the Toolbar of the Ortho view.

2. Click on the point of the DEM where the measurement should be started from.

3. Upon the second click on the DEM the distance between the indicated points will be shown right
in the Ortho view.

4. Thedistance can be measured along the polyline drawn with the Ruler.

5.  To complete the measurement and to proceed to a new one, please press Escape button on the
keyboard. The result of the measurement will be shown on the Console pane.

To measur e distance with shapes

1 Connect the points of interest with a polyline using A Draw Polyline tool from the Ortho view

toolbar.
2. Double click on the last point to indicate the end of a polyline.
3. Right button click on the polyline and select Measure... command from the context menu.

4. Inthe Measure Shape dialog inspect the results. Perimeter value equals to the distance that should
have been measured.
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In addition to polyline length val ue (see perimeter value in the Measure Shape), coordinates of the vertices
of the polyline are shown on the Planar tab of the Measure Shape dialog.

4 Note

« Measure option is available from the context menu of a selected polyline. To select a polyline,
double-click onit. A selected polylineis colored in red.

Area and volume measurement

To measure area and volume

1 Draw apolygon on the DEM using _/Draw Polygon instrument to indicate the areato be measured.

2. Right button click on the polygon and select Measure... command from the context menu.

3. Inthe Measure Shape dialog inspect the results: see area value on the Planar tab and volume values
on the Volume tab.

M etashape allows to measure volume above best fit / mean level / custom level planes. Best fit and mean
level planes are calculated based on the drawn polygon vertices. Volume measured against custom level
plane allows to trace volume changes for the same area in the course of time.

[ Note

* Measure option is available from the context menu of a selected polygon. To select a polygon,
double-click onit. A selected polygon is colored in red.

Cross sections and contour lines

Metashape enables to calculate cross sections, using shapes to indicate the plane(s) for a cut(s), the cut
being made with aplane parallel to Z axis. For apolyline/polygon the program will calculate profilesalong
all the edges starting from the first drawn side.

To calculate cross section

1. : . A e
Indicate a line to make a cut of the model using Draw Polyline / ' Draw Polygon tool from
the Ortho view toolbar.

2. Double click on the last point to indicate the end of a polyline.

3. Right button click on the polyline/polygon and select Measure... command from the context menu.

4. Inthe Measure Shape dialog inspect the results on the Profile tab of the dialog.

Generate Contours... command is available either from DEM label context menu on the Wor kspace pane
or from the Tools menu.

To generate contours
1. Select Generate Contours... command from Tools menu.

2. Inthe Generate Contours dialog select DEM as the source data for calculation.
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3. Setvauesfor Minimal altitude, Maximal altitude parameters as well as the Interval for the contours.
All the values should be indicated in meters.

4, Click OK button once done.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

6. When the procedure is finished, a shape layer with "contours" label will be added to the project file
structure shown on the Workspace pane.

Contour lines can be exported using Export Contours command from the contour lines label context menu
on the Wor kspace pane. Alternatively the command is available from the File menu. In the Export Contour
Linesdialog it is necessary to select the type of the contour lines to be exported. A shape file can store the
lines of the same type only: either polygons or polylines.

Transform DEM

M etashape supports transformation of the digital elevation models. Different DEMs can be subtracted one
from another for the changes observation purposes.

Transform DEM

Coordinate System
WES 84 (EP5G:4326)

Parameters

Calculate difference

DEMZ

Region

Setup boundaries: £.533043 - | £.551036 E

46.562190 - 46578330 ¥
Resaolution {m/pix): 0,16523

Total size (pix): 8345 X 10338

Lok ]
"Transform DEM" dialog
Totransform DEM
1. Select DEM from which you want to transform on the Workspace pane.
2. Sdlect Transform DEM... command from Tools menu.

3. Inthe Transform DEM... dialog select the check Calculation difference box and select the file from
the drop-down list for calculation.
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4. Press OK bhutton to calculate transform DEM.

5. Inthedialog box click Yes button in order to create a new DEM instance with the calculation result.
If No button in pressed, the result will overwrite the active DEM instance contents.

6. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

7.  When the procedure is finished, a layer with transform DEM label will be added to the project file
structure shown on the Workspace pane.

Vegetation indices calculation

Multispectral cameras

M etashape enables to calculate NDVI and other vegetation indices based on the multispectral imagery
input. Vegetation index formula can be set by the user, thus allowing for great flexibility in data anaysis.
Calculated data can be exported asagrid of floating point index values cal culated per pixel of orthomosaic
or as an orthomosaic in pseudocolors according to a palette set by the user. In case several indices
are calculated for the same orthomosaic, the results can be exported as a multichannel orthomosaic,
one channel per index. Furthermore, values of 3 different vegetation indices can be mixed to represent
combined results as afalse color "RGB" image.

Calibrate Reflectance

In Metashape you can execute the reflectance calibration of multispectral image dataacquired using Parrot
Sequoia or MicaSense RedEdge cameras. Images from Parrot Sequoia and MicaSense RedEdge can be
loaded at once for al bands. If the images are stored in several folders, the same operation should be
repeated for each folder. Metashape can automatically sort out those calibration images to the special
camera folder in the Workspace pane if the image meta-data says that the images are for calibration. The
imageswill be disabled automatically (not to be used in actual processing). If thereis no such information
in the image meta-data, the calibration images will be detected automatically in calibrate reflectance.

4 Note

» Please remember to add reflectance calibration images.
1. Choose Calibrate Reflectance from the Tools menu.

2. PressLocate Panelsbutton. Asaresult theimageswith the panel will be moved to the separate folder
and the masks would be applied to cover everything on the images except the panel itself. If you are
using the panel for the first time, and its calibration is not added to Metashape internal database yet,
you will be prompted to load calibration from CSV file.

3. If youdon't have aCSV filewith calibration information, you can enter calibration values manually.
It can be done manually in Calibrate Reflectance dialog or using Select Panel... button. In the Select
Reflectance Panel dialog it is possible to: load reflectance information from a CSV file; save current
table (wavelength / reflectance factor); edit the name of a panel in the database (the nameis used in
Calibrate Reflectance dialog); remove the panel from the database.

4. Check on Use reflectance panel and Use sun sensor options in the Calibrate Reflectance dialog to
perform calibration based on panel data and/or image meta information.
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5.

Click OK to start calibration process.

To calculate a vegetation index

1

2.

10.

11.

12.

Open orthomosaic in the Ortho tab double-clicking on the orthomosaic label on the Workspace pane.

Open Raster Transformtool using " Raster Transform button from the Ortho view tool bar.

On the |eft-hand side of the Transform tab of the Raster Calculator dialog all the bands of the input
imagesarelisted. Set avegetation index expression on the Output Bands side of thetab using keyboard
input and operator buttons of the raster calculator if necessary. If the expression isvalid, the line will

be marked with “?f?si gn.

Y ou can set several vegetation index expressionsto be calculated. Use Q X buttons to add/del ete
linesin the list of output bands.

Click OK button to have the index (or indices) calculated. The result - orthomosaic with vegetation
index (or indices) information, each index being stored in a separate channel, can be exported with
Export orthomosaic command from the File menu. For guidance on the export procedure, please refer
to NDVI data export section of the manual.

Alternatively to Step 5, if you would like to have the index visualized in Ortho view of Metashape
window for inspection, follow Steps 6-12. Check Enable transform box and switch to the Pal ette tab
of the Raster Calculator dialog.

Select output band in Use band field on the Palette tab.

Click '_“:II'UU pdate button to have the histogram of the index values shown on the left-hand side of the
Palette tab.

Select the range of meaningful index values either manually on the histogram or apply automatically
calculated range with the Auto button at the bottom of the tab.

Select palette preset from the drop-down list on the right-hand side of the Pal ette tab.

Click Apply button. Once the operation is completed - all the vegetation indices are calculated, the
index values stored in the selected output band (indices cal culated according to the selected output
band expression set on the Transformtab of the Raster Calculator) will be shown in the Ortho view,
index values being visualized with pseudocol ors according to the pal ette set in the Raster Calculator
dialog.

Y ou can either continue your work in Raster Calculator or click OK button to close the dialog.

Pal ette defines the color for each index value to be shown with. Metashape offers several standard palette
presets on the Pal ette tab of the Raster Calculator dialog. A preset (Heat, NDV1, Gray scale) can be chosen
from the drop-down list on the Palette tab of the Raster Calculator dialog. Alternatively, the user can

upload the palette from a Surfer Color Spectrum (*.clr) file (= 'Import Palette), preliminary prepared in
an external tool.

The palette can also be edited within M etashape environment using DAdd Color and @ Remove Color
buttons on the Pal ette tab of the Raster Calculator dialog. For each new line added to the palette acertain
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index value should be typed in. Double click on the newly added line to type the value in. A customized

palette can be saved for future projects using HExport Palette button on the Palette tab of the Raster
Calculator dialog.

The range of meaningful index values can be manually adjusted on the left-hand side of the Palette tab or
set automatically with the Auto button at the bottom of the tab. Interpolate colors option can be checked
to introduce intermediate colors to the output image.

False color value on the drop-down list of the palette presets allows to visualize combined results of
particular 3 vegetation indices tackled as false RGB colors.

4 Note

« If you change the index expression for selected output band on the Transform tab, do not forget
to adjust Palette settings for visualization purposes: click Update button on the Palette tab to
have the histogram of the index values updated, set the range of the meaningful values, chose
the proper color palette.

« If you would like to inspect values of a different vegetation index, not the one already shown,
you need to set the corresponding formula in the selected band of the Output Band list on the
Transformtab of the Raster Calculator dialog.

« If you would like to see original multispectral orthomosaic, with no index calculation applied,
uncheck Enable transform option on the Transformtab of the Raster Calculator dialog and click
Apply/OK button. If theinput images havethree channelsmarked asR, G, B, then the orthomosaic
will be visualized as an RGB image (or false RGB). Otherwise, the spectral data from the first
channel will be visualized in gray scale.

Prescription maps generation

The prescription map is generated based on the orthomosaic with calculated index (NDVI). Select
Generate Prescription Map command on the Orthomosaic submenu from the Tools menu.

In Metashape Prescription maps are built according to the following algorithm:

Specify the area along with the boundary vector layer (if there are no vector layers, orthomosaic isused in
its entirety). The selected area will be transformed if there is an active raster transformation rule (Raster
transform). For the resulting raster, a histogram of the values of the first transformed channel is built and
this histogram is divided into clusters. In Metashape available 2 methods for clusterization: Jenks natural
breaks and Equal intervals clustering:

- when using the Jenks natural breaks clustering method, the splitting occurs automatically;

- when using the Equal intervals clustering method, the histogramis splitinto equal intervalsintheinterval
from the min index value to the max index value. Min and Max value index calculated automatically.

After thisstep, the cellsthat fall into the same cluster are combined and for each cluster, itsbordersare built
and written into avector layer named Prescription. The resulting layer contains several groups of polygons
(MultiPolygon) corresponding to the clusters. The attributes of each group contain the average value of the
index for the given cluster (zonal_mean) and the ordinal number of the cluster (cluster_id), starting from 1.
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Generate Prescription Map A
Parameters
Boundary shape layer: Mone
Cell size {m): 1
Vegetation dasses
Classes: 4 Jenks natural breaks Q
. . 0.257 0.503 . 0.715 .
SN S S S S — MR- —
] 0.1 0.2 0.3 0.4 0.5 0.6 0.7 0.8 0.9
. Zonal mean Area (ha) Rate (kg/ha)
1 |0.132549 20.2335 100
2 0331366 14,9904 100
3 0.624177 27.5218 100
4 0810672 28.6274 100

Total amount (ka): 913731

"Generate Presctiption Map" dialog
The following parameters can be adjusted:
Boundary shape layer
Layer with polygon for which the Prescription map will be generated (if there are no shape layer, the

whole orthomosaic will be used).

Cell size(m)
Setting cell sizein meters.

Classes
Specify the number of classes.

Methodsfor clusterization
Jenks natural breaks and Equal intervals clustering
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Histogram
Histogram displays the index histogram and the division into zones.

Table
A table showsthevalueof Zones, Area(ha), and Rate (kg/ha). Thesevaluesinthetable can be changed
aswell asthe Total amount.

Total amount (kg)
Setting total amount in kg.

To change the fertilizer consumption, after building the Prescription map layer, select Prescription map
on the Workspace pane and choose Prescription map properties... command on the context menu.

Select Export Layers... command on the Prescription map layer on the Workspace paneto export Presiction
map in Shapefile format.

Modified visible range cameras

Modified visible range cameras provide data in the form of three channel imagery, but those channels
do not contain standard R, G, B spectrum range information due to some physical manipulation done on
the sensor. For example, a Colored Infrared (CIR) cameraby MAVinci records Red+NIR datain thefirst
channel, Green+NIR datain the second channel, and NIR datain the third one.

Modified visible range cameras are used for vegetation monitoring along with multispectral cameras. To
cal culate vegetation indices with M etashape the data captured with a modified camera should be calibrated
first. This means we need to get pure R, G, NIR values to apply vegetation index formula. To perform
the calibration, one needs calibration matrix data. In this context, a calibration matrix is amatrix of linear
transformation of source light intensity values in each channel into absolute values of intensity.

In case of CIR cameraby MAVinci, calibration matrix can be calculated based on the histograms for the
following relations: NIR/R, NIR/G. Calibration matrix spectrum values will be equal to the values of the
cut offs (kr, kg) of the corresponding histograms. C ={(kg, 0, -1), (0, kg, -1), (0, 0, 1)} . Then the vector of
the absolute intensity values for R, G, NIR spectrum bands, scaled according to NIR intensity value, can
be calculated as X1=C* X, where C [3x3]- CIR calibration matrix, Xg [3x1]- vector of the source values
of the intensity for each band.

M etashape offers dialog to manually input values of the calibration matrix - see Color Matrix section of
the CIR Calibration tab in the Raster Calculator dialog. (Thetab isavailable for 3 bandsimagery only. If
the project deals with multispectral imagery, thereis no need to calibrate the data.) One can either printin
the values, or select the values with sliders on the histograms. For a CIR cameraby MAVinci, calibration
matrix values can be set automatically with the Auto button.

Once the calibration matrix values are set, click Apply button for Metashape to perform the calibration.
After that you can proceed to Transform and Palette tabs of the Raster Calculator to calculate vegetation
indices as described in the section above. Metashape will use calibrated values as Input Bands on the
Transformtab.

Index based contour lines
M etashape enables to cal culate contour lines based on the calculated index values.

To calculate contour lines based on vegetation index data

1. Select Generate Contours... command from the orthomosaic icon context menu on the Workspace
pane, while index data is shown in the Ortho view.
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2.  Select Orthomosaic as the source for the contours cal cul ation.
3. Adjust the min/max value and the interval parameters for the task.
4. Press OK button to calculate index values.

5. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

6. When the procedure is finished, a shape layer with "contours" label will be added to the project file

structure shown on the Wor kspace pane. The contour lines will be shown over the index data on the
Ortho tab.

Powerlines detection

Metashape supports automatic powerlines detection. The algorithm uses aligned images to detect
powerlines. Detected powerlineswill be saved as shapes (3D polylines) in one or more shape layers. Read
more about shape properties in Shapes section.

4 Note

» The shape layer with the powerlines can be used together with the Plan Mission tool to indicate
the danger zone for adrone flight.

Detect Powerlines
1. Select the Detect Powerlines command from the Tools menu.
2. Choose parameters in Detect Powerlines dialog box.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Detect Powerlines parameters

Detect Powerlines
General

IIse model for visibility checks
Min altitude from DEM {m): 1

Mumber of vertices per line: 11

Lok ] Cancel

"Detect Powerlines' dialog

Use modd for visibility checks
Helps to reconstruct more powerlines in scenes with difficult geometry where wires are occluded by
the model in images.
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Min altitude from DEM (m)
To exclude road marking or, for example, fences, we recommend setting this parameter, which
requiresto generate DEM as an additional preliminary step.

Number of vertices per line
During drawing powerlines, alarge number of vertices can be created intheline. It is possible to limit
the number of vertices by specifying the desired maximum number of vertices per line. The value"0"
can be set to avoid the number of vertices to be limited.

Stereoscopic measurements and vectorization

Metashape supports performing measurements and vectorization in stereo mode on stereo pairs
(overlapping photos). In Metashape Hardware stereo is supported only for systems (graphics cards) that
support the technology Quad Buffered Stereo.

Before starting to use stereo mode the parameters of Stereoscopic Display Mode for the current hardware
needs to be adjusted in the General tab of Preferences dialog available from Tools menu. Metashape
supports simply anaglyph display mode (for red/blue glasses) as well as hardware stereo mode that
assumes polarization glasses and professional grade hardware (GPU that supports quad-buffer stereo and
3D monitor). The parameters of the 3D controller can be adjusted on the Navigation tab available in the
Preferences dialog window.

For example, if you use Stealth3DM ouse controller, you need to install virtual com port to enable thistype
of controller selection on the Navigation tab available in the Preferences dialog window. If 3D controller
cannot be configured on the Navigation tab, please follow the steps below:

* check the USB Serial Comport in the Ports section of Device manager dialog;

» open Port Settings tab of Properties dialog window, then click on Advanced tab. In the Advanced
Settings dialog switch the COM port number to COM 3;

* restart the computer;

* in Metashape open Preferences dialog window from Tools menu and in the Navigation tab you should
be able to select COM 3 port then for the Stealth3DMous device.

Working with stereo pairsin Metashapeis performed in Model view pane with Top predefined view set up.
Setting up stereo mode

1. Align photos. (For more information about photo alignment refer to Aligning photos section)

2. Switch to Model view pane.

3. Select Top command from Predefined Views submenu of Model menu.

4. Select Sereo mode view command from the View Mode submenu of the Model menu.

Turn on stereo pair overlay by clicking = Show Images toolbar button.

Navigation
1. Navigate through overlaying stereo pair with right mouse button pressed.

2. Tocontrol 3D cursor depth, navigate with the right mouse button and Shift key pressed. When using
the 3D controller, height change is performed with the help of a special whesl.
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Stereo pair selection

1

2.

4.

Right button click on the area of interest on the model and select Filter by point command.

In the Photos pane select both images of a stereo pair, right click on the selection and choose Look
Through command.

To avoid switching between stereo pairs while navigating through model, lock current overlaying

stereo pair by clicking D Lock Image toolbar button.

In case you need to select another stereo pair, repeat step two.

M easur ements and vectorization

4 Note

* The Snhapping tool in Metashape will help you to do vectorization. The following snapping types
areavailable: Axis, Vertex and Edge. To use snapping mode, click Axis Shap, Vertex Shap, Edge
Shap on the toolbar and press Shift button when you start drawing shapes.

e . . .
To measure distance click " Ruler toolbar button, hold right mouse button and left click on the first
point, than move 3D cursor to the next point and left click on it.

To draw point, click “¥" Draw Point toolbar button and left click on the point of your interest.

To draw polyline click A Draw Polyline toolbar button, left click on the first point, than move 3D
cursor to the next point, and left click on it. Perform double |eft click to finish the polyline.

o

To draw polygon click ' Draw Polygon toolbar button, left click on the first point, than move 3D
cursor to the next point, and left click on it. Perform double | eft click to finish the polygon.
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Using masks

Overview

Masks are used in Metashape to specify the areas on the photos which can otherwise be confusing to
the program or lead to incorrect reconstruction results. Masks can be applied at the following stages of
processing:

» Matching of the images

* Building Depth Maps

* Building Mesh from the depth maps source with the strict volumetric masks option applied
* Building Texture

* Building Tiled Model

* Building Orthomosaic

* Building Panorama

Alignment of the photos
Masked areas can be excluded during feature point detection. Thus, the objects on the masked parts
of the photos are not taken into account while estimating camera positions. This is important in the
setups, where the object of interest is not static with respect to the scene, like when using aturn table
to capture the photos.

Masking may be also useful when the object of interest occupies only a small part of the photo. In
this case a small number of useful matches can be filtered out mistakenly as a noise among a much
greater number of matches between background objects.
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Building dense point cloud

While building dense point cloud, masked areas are not used in the depth maps computation process.
Masking can be used to reduce the resulting dense cloud complexity, by eliminating the areas on the
photos that are not of interest.

Masked areas are always excluded from processing during dense point cloud and texture generation
stages, including Tiled Model generation process.

Let'stake for instance a set of photos of some object. Along with an object itself on each photo some
background areas are present. These areas may be useful for more precise camera positioning, so it
is better to use them while aligning the photos. However, impact of these areas at the building dense
point cloud is exactly opposite: the resulting model will contain object of interest and its background.
Background geometry will "consume" some part of mesh polygons that could be otherwise used for
modeling the main object.

Setting the masks for such background areas allows to avoid this problem and increases the precision
and quality of geometry reconstruction.

Building orthomosaic

During building orthomosaic process, masked areas on the photos are not used for building
orthomosaic.

Building texture atlas

During texture atlas generation (for single mesh model and tiled model), masked areas on the photos
are not used for texturing. Masking areas on the photosthat are occluded by outliers or obstacles helps
to prevent the "ghosting” effect on the resulting texture atlas.

Loading masks

Masks can be loaded from external sources, as well as generated automatically from background images
if such datais available. M etashape supports |oading masks from the following sources:

» From aphachannel of the source photos.

» From separate images.

» Generated from background photos based on background differencing technique.

» Based on reconstructed 3D model.

Toimport masks

1

2.

Select Import Masks... command from the File menu.
In the Import Mask dialog select suitable parameters. Click OK button when done.

When generating masks from separate or background images, the folder selection dialog will appear.
Browse to the folder containing corresponding images and select it.

The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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Import Masks
Parameters

Method: From Alpha
Operation: Replacement

Filename template: mask.jp

Tolerance: 163 H

Apply to

(]

All cameras Entire workspace

Selected cameras Current photo

ok ] Cancel

"Import Masks" dialog
The following parameters can be specified during mask import:

Method
Specifies the source of the mask data.

From Alpha - load masks from alpha channel of the source photos.
From File - load masks from separate images.

From Background - generate masks from background photos.
From Model - generate masks based on reconstructed model.

Operation
Specifies the action to be done in case a second mask is imported for the photo.

Replacement - new mask will be loaded and stored instead of the original one.

Union - two masks will be united and stored.

I nter section - the intersection of the two masks will be stored as a new mask for the photo.
Difference - only the difference between two masks will be stored as a new mask for the photo.

Filename template (not used in From alpha mode)
Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:

{filename} - file name of the source photo without extension.
{fileext} - extension of the source photo.

{camera} - cameralabel.

{frame} - frame number.

{filenum} - sequential number of the mask being imported.
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For example, {filename} _mask.png template can be used if masks are available in PNG format and
have a_mask suffix.

Tolerance (From Background method only)
Specifies the tolerance threshold used for background differencing. Tolerance value should be set
according to the color separation between foreground and background pixels. For larger separation
higher tolerance values can be used.

Appgpgifieswhether masks should be imported for the currently opened photo, active chunk or entire
Workspace.
All camer as - load masks for active chunk.
Entire wor kspace - load masks for all chunks in the project.
Selected camer as - load mask for the currently checked cameras (if any).

Current photo - load mask for the currently opened photo (if any).

Generate masks

The Generate masks tool allows to create masks from the mesh model. Due to the nature of the shooting,
not the whole object may be placed in focus, which will lead to blurred areas in the pictures. The texture
will be more blurry than possible if built texture uses the images data from defocus areas. The tool allows
to exclude such areas prior to the texture blending procedure by applying the masks automatically to out
of focus areas.

To generate mask
1. Select Generate Masks command from the Mesh submenu from the Tools menu.
2. Inthe Generate Masks dialog select suitable parameters. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

Generate Masks
Parameters

Operation: Replacement
Mask defocus areas
Force model coverage

Blur threshold 3.00

Apply to

All cameras Entire workspace

o P o
o cted o as L

Lo ] cancel |
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m
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"Generate Masks' dialog
The following parameters can be specified in Generate Masks dialog:

Operation
Specifies the action to be done in case a second mask is imported for the photo.

Replacement - new mask will be loaded and stored instead of the original one.

Union - two masks will be united and stored.

I nter section - the intersection of the two masks will be stored as a new mask for the photo.
Difference - only the difference between two masks will be stored as a new mask for the photo.

Mask defocus areas
Enabled applying masksto the areas that are out of focus based on the depth information of each point.

Fix coverage (for Replace and Union oper ations only)
Allows to avoid blind spots on the model surface when generating masks.

Blur threshold
The Blur threshold parameter defines the allowed blur radius on a photo in pixels. In most cases, we
recommend using the 2 or 3 pixels.

Apply to
Specifies whether masks should be created for the currently opened photo, active chunk or entire
Workspace.

All camer as - generate masks for active chunk.
Entire wor kspace - generate masks for all chunks in the project.
Selected camer as - generate mask for the currently checked cameras (if any).

Current photo - generate mask for the currently opened photo (if any).

Editing masks

Modification of the current mask is performed by adding or subtracting selections. A selection is created
with one of the supported sel ection tools and is not incorporated in the current mask until it is merged with
amask using Add Selection or Subtract Selection operations.

To edit the mask

1. Open the photo to be masked by double clicking on its name on the Workspace / Photos pane. The
photo will be opened in the main window. The existing mask will be displayed as a shaded region
on the photo.

2. Select the desired selection tool and generate a selection.

Click on "/ Add Selection toolbar button to add current selection to the mask, or . Subtract

' Invert Selection button allowsto invert current
selection prior to adding or subtracting it from the mask.

Selection to subtract the selection from the mask.

The following tools can be used for creating selections:
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L—41 Rectangle selection tool
Rectangle selection tool is used to select large areas or to clean up the mask after other selection tools
were applied.

% Intelligent scissorstool
Intelligent scissorsis used to generate a selection by specifying its boundary. The boundary isformed
by selecting a sequence of vertices with a mouse, which are automatically connected with segments.
The segments can be formed either by straight lines, or by curved contours snapped to the object
boundaries. To enable snapping, hold Ctrl key while selecting the next vertex. To complete the
selection, the boundary should be closed by clicking on the first boundary vertex.

% ntelligent paint tool
Intelligent paint tool is used to "paint" a selection by the mouse, continuously adding small image
regions, bounded by object boundaries.

M agic wand tool
Magic Wand tool is used to select uniform areas of the image. To make a selection with a Magic
Wand tool, click inside the region to be selected.

The range of pixel colors selected by Magic Wand is controlled by the tolerance value. At lower
tolerance values the tool selects fewer colors similar to the pixel you click with the Magic Wand tool.
Higher value broadens the range of colors selected.

[ Note

« Toadd new areato the current selection hold the Ctrl key during selection of additional area.

« To subtract a part from the current selection hold the Shift key during selection of the area to
be subtracted.

» Toreset mask selection on the current photo press Esc key.

A mask can beinverted using Invert Mask command from the Edit menu. The command is activein Photo
view only. Alternatively, you can invert masks either for selected cameras or for al cameras in a chunk
using Invert Masks... command from a photo context menu on the Photos pane.

The masks are generated individually for each image. If some object should be masked out, it should be
masked out on all photos, where that object appears.

Exporting masks

Created masks can be also saved for external editing or storage.

To export masks

1. Select Export Masks... command from the File menu.

2. Inthe Export Mask dialog select suitable parameters. Click OK button when done.
3. Browseto the folder where the masks should be saved and select it.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.
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Export Masks

Farameters

File type: Single channel mask image

Filename template: mask.jpg

Apply to
All cameras Entire workspace
Selected cameras Current photo

ok |
"Export Masks" dialog
The following parameters can be specified during mask export:
Export masksfor
Specifies whether masks should be exported for the currently opened photo, active chunk or entire
Workspace.
Current photo - save mask for the currently opened photo (if any).
Active chunk - save masks for active chunk.

Entire workspace - save masks for all chunksin the project.

Filetype
Specifies the type of generated files.

Single channel mask image - generates single channel black and white mask images.

Image with alpha channel - generates color images from source photos combined with mask data
in alphachannel.

Mask file names
Specifies the file name template used to generate mask file names. This template can contain special
tokens, that will be substituted by corresponding data for each photo being processed. The following
tokens are supported:
{filename} - file name of the source photo without extension.
{fileext} - extension of the source photo.
{camera} - cameralabel.
{frame} - frame number.

{filenum} - sequential number of the mask being exported.

For example, {filename} _mask.png template can be used to export masksin PNG format with _mask
suffix.
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4 Note

< When importing/exporting mask for the current photo only, Metashape will prompt for the actual
image instead of image folder. Mask file names parameter will not be used in this case.

Editing point cloud

The following point cloud editing tools are available in Metashape:

Automatic filtering based on specified criterion (sparse cloud only)

Automatic filtering based on applied masks (dense cloud only)

Automatic filtering based on points colors (dense cloud only)

Automatic filtering by class (dense cloud only)

Automatic filtering by selection (dense cloud only)

Automatic filtering by confidence (dense cloud only)

Reducing number of pointsin point cloud by setting tie point per photo limit (sparse cloud only)
Reducing number of dense cloud points by setting up point spacing value

Colorize dense point cloud

Sample points operation to create dense point cloud from the mesh or tiled model

Manual points removal

4 Note

 Point cloud editing operation can be undone/redone using Undo/Redo command from the Edit
menu.

Filtering points based on specified criterion

In some cases it may be useful to find out where the points with high reprojection error are located within
the sparse cloud, or remove points representing high amount of noise. Point cloud filtering helps to select
such points, which usually are supposed to be removed.

M etashape supports the following criteriafor point cloud filtering:

Reprojection error

Maximum reprojection error in normalized units across all images where tie-point was measured.
max; |X - Xi| /

where

X'j - point projection according to adjusted orientation parameters on the i-th image in pixels,

Xj - measured point projection coordinates on the i-th image in pixels,
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s - image scale at which corresponding projection was measured on the i-th image

High reprojection error usualy indicates poor localization accuracy of the corresponding point
projections at the point matching step. It is also typical for false matches. Removing such points can
improve accuracy of the subsequent optimization step.

Reconstruction uncertainty

Ratio of the largest semi-axisto the smallest semi-axis of the error ellipse of the triangulated 3D point
coordinates. The error ellipse corresponds to the uncertainty of the point triangulation alone without
taking into account propagation of uncertainties from interior and exterior orientation parameters.

sart(ky / ks)

where

k1 - largest eigenvalue of the tie-point covariance matrix,
k3 - smallest eigenvalue of the tie-point covariance matrix

High reconstruction uncertainty is typical for points, reconstructed from nearby photos with small
baseline. Such points can noticeably deviate from the object surface, introducing noise in the point
cloud. While removal of such points should not affect the accuracy of optimization, it may be useful
to remove them before building geometry in Point Cloud mode or for better visual appearance of the
point cloud.

Image count

Number of images where the tie point was measured.

M etashape reconstruct all the points that are visible at |east on two photos. However, points that are
visible only on two photos are likely to be located with poor accuracy. Image count filtering enables
to remove such unreliable points from the cloud.

Projection Accuracy

Average image scale at which image coordinates of the tie-point were measured.
sumjs/n

where

S - image scale at which corresponding projection was measured on the i-th image,
n - number of images where tie-point was measured

Thiscriterion alowsto filter out points which projections were relatively poorer localized dueto their
bigger size.

Toremove points based on specified criterion

1.

Switch to Point Cloud view mode using 8& Point Cloud toolbar button.
Select Gradual Selection... command from the Model menu.
In the Gradual Selection dialog box specify the criterion to be used for filtering. Adjust the threshold

level using the dlider. You can observe how the selection changes while dragging the slider. Click
OK button to finalize the selection.
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To remove selected points use Delete Selection command from the Edit menu or click X Delete
Selection toolbar button (or simply press Del button on the keyboard).

Filtering points based on applied masks

To remove points based on applied masks

1

Switch to Dense Cloud view mode using Dense Cloud toolbar button.
Choose Select Masked Points... command from the Dense Cloud submenu of the Tools menu.

In the Select Masked Points dialog box indicate the photos whose masks to be taken into account.
Adjust the edge softness level using the dlider. Click OK button to run the selection procedure.

To remove selected points use Delete Selection command from the Edit menu or click X Delete
Selection toolbar button (or simply press Del button on the keyboard).

Filtering points based on points colors

Toremove points based on points colors

1

Switch to Dense Cloud view mode using =25Dense Cloud toolbar button.
Choose Select Points by Color... command from the Dense Cloud submenu of the Tools menu.

In the Select Paints by Color dialog box the color to be used as the criterion. Adjust the tolerance
level using the dlider. Click OK button to run the selection procedure.

To remove selected points use Delete Selection command from the Edit menu or click X Delete
Selection toolbar button (or simply press Del button on the keyboard).

Filtering points by class

To select objects of the same type in Dense Cloud, you can filter by class. Classification is performed
automatically, you should choose only the class interested.

Filter by class

1.

Switch to Dense Cloud view mode using =5 Dense Cloud toolbar button.
Choose Filter By Class... command from the Dense Cloud submenu of the Tools menu.

In the Select Point Classes dialog box choose classes to be used as the filter. Click OK button to run
the selection procedure.

The result of the filtering will be shown in the Model view.

Select Reset filter command from the Dense Cloud submenu of the Tools menu to cancel filtering
by classes
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Filtering points by selection

Filter by selection

1.

Switch to Dense Cloud view mode using =:5Dense Cloud toolbar button.

Select pointsto befilter . - iRectangle Selection, {_“Circle Selection or -;_ﬂ Free-Form Selection tools.
Choose Filter By Selection... command from the Dense Cloud submenu of the Tools menu.
Theresult of the filtering will be shown in the Model view.

Select Reset filter command from the Dense Cloud submenu of the Tools menu to cancel filtering
by classes

Filtering points by confidence

M etashape supports dense point cloud filtering by confidence value. To perform such filtering Calculate
point confidence option should be enabled in the Build Dense Cloud dialog before the dense point cloud
of interest is generated.

Filter by confidence

1.

Switch to Dense Cloud view mode using =:5Dense Cloud Confidence toolbar button.
Choose Filter by Confidence... command from the Dense Cloud submenu of the Tools menu.

In the Select Confidence Range dialog box choose min and max value to be used as the filter. The
values define the number of depth maps involved in the point generation.

Click OK button to run the selection procedure.
The result of the filtering will be shown in the Model view.

Select Reset filter command from the Dense Cloud submenu of the Tools menu to cancel filtering
by confidence.

Tie point per photo limit

Tiepoint limit parameter could be adjusted before Align photos procedure. The number indicatesthe upper
limit for matching points for every image. Using zero value doesn't apply any tie-point filtering.

The number of tie points can also be reduced after the alignment process with Tie Points - Thin Point
Cloud command available from Tools menu. Asaresultstie point cloud will be thinned, yet the alignment
will be kept unchanged.

Filter dense cloud

In Metashape it is possible to reduce the number of the dense cloud points by setting the point spacing
parameter manually which defines the regular grid step.

Tofilter dense point cloud

1.

Select Filter dense cloud command from the Dense Cloud submenu of the Tools menu.
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2. IntheFilter Dense Cloud dialog box specify Point spacing in meters to be used.

3. Click OK button to run the selection procedure.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click Cancel button.

4  Note

* In the confirmation dialog box click Yes button if a new dense cloud instance with result
calculation should be created in the active chunk. If No button is pressed the dense cloud filtering
result will overwrite the active dense point cloud instance.

Colorize Dense Cloud

Metashape supports the option to colorize dense point clouds with the colors from the images or
orthomosaic.

To colorize dense cloud

1

Select an active Dense Cloud in the Workspace pane.
Choose Colorize Dense Cloud... command from the Dense Cloud submenu of the Tools menu.
In the Colorize Dense Cloud dialog box select Source data from Orthomosaic orlmages option.

Click on the OK button to start the procedure. The progress dialog box will appear displaying the
current processing status.

Sample points

Sample pointstool creates a dense point cloud based on a Mesh or Tiled model.

To createthe dense point cloud from the polygonal surface

1

2.

Select Sample Points command from the Dense Cloud submenu of the Tools menu.

In the Sample Points dial og sel ect the source polygonal surfacetype (mesh or tiled model) and desired
point spacing value. Target point count based on the input parameters will be displayed in Estimated
points field.

Click on the OK button to start the procedure. The progress dialog box will appear displaying the
current processing status. To cancel processing click Cancel button.

The following parameters can be specified in Sample points dialog:

Source data

Specifies the source polygonal surface for the dense point cloud generation (Mesh or Tiled model).

Points spacing

Specifies the desired distance between points of the dense cloud to be generated.

Estimated points

Defines the expected number of points to be generated.
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Manual points removal

Incorrect points can be also removed manually.

Toremove pointsfrom a point cloud manually

1 Switch to Sparse Cloud view mode using & Point Cloud toolbar button or to Dense Cloud view

mode using Dense Cloud toolbar button.
| Faat Y -

2 Select points to be removed using - .Rectangle Selection, --<Circle Selection or L_g Free-Form
Selection tools. To add new points to the current selection hold the Ctrl key during selection of
additional points. To remove some points from the current selection hold the Shift key during
selection of pointsto be removed.

3.

To delete selected points click the ><Delete Selection toolbar button or select Delete Selection

command from the Edit menu. To crop selection to the selected points click the tn{-Crop Selection
toolbar button or select Crop Selection command from the Edit menu.

Classifying dense point cloud

M etashape allows not only to generate and visualize dense point cloud but also to classify the pointswithin
it. There are two options; automatic division of all the pointsinto two classes - ground points and the rest,
and manual selection of agroup of points to be placed in a certain class from the standard list known for
LIDAR data. Dense cloud points classification opens way to customize Build Mesh step: you can choose
what type of objects within the scene you would like to be reconstructed and indicate the corresponding
point class as a source data for mesh generation. For example, if you build mesh or DEM based on ground
points only, it will be possible to export DTM (as opposed to DSM) at the next step.

Automatic classification of ground points

For the user to avoid extramanual work Metashape offersfeature for automatic detection of ground points.

To classify ground points automatically

1. Select Classify Ground Points... command from the Dense Cloud submenu of the Tools menu.
2. Inthe Classify Ground Points dialog box select the parameters for the classification procedure.
3. Click OK button to run the classification procedure.

Automatic classification procedure consists of two steps. At the first step the dense cloud is divided into
cellsof acertain size. In each cell the lowest point is detected. Triangulation of these points gives the first
approximation of the terrain model.

Additionally, at this step Metashape filters out some noise points to be handled as Low Points class.

At the second step new point is added to the ground class, providing that it satisfies two conditions: it lies
within a certain distance from the terrain model and that the angle between terrain model and the line to
connect this new point with a point from a ground class is less than a certain angle. The second step is
repeated while there still are points to be checked.
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Classify Ground Points

Classes

From: Any class

Tao: Ground + Low Paints
Parameters

Max angle (=); 15.0 H
Max distance {m): 1

Cell size (m): 50

Erosion radius {m): ]

Lok ] Cancel

"Classify Ground Points" dialog
The following parameters control automatic ground points classification procedure

Max angle (deg)
Determinesoneof the conditionsto be checked whiletesting apoint asaground one, i.e. setslimitation
for an angle between terrain model and the line to connect the point in question with a point from a
ground class. For nearly flat terrain it isrecommended to use default value of 15 deg for the parameter.
It isreasonable to set a higher value, if the terrain contains steep slopes.

Max distance (m)
Determinesoneof the conditionsto be checked whiletesting apoint asaground one, i.e. setslimitation
for a distance between the point in question and terrain model. In fact, this parameter determines the
assumption for the maximum variation of the ground elevation at atime.

Cell size(m)
Determines the size of the cells for point cloud to be divided into as a preparatory step in ground
points classification procedure. Cell size should be indicated with respect to the size of the largest
area within the scene that does not contain any ground points, e. g. building or dense forest.

Erosion radius (m)
Determines the indentation (in meters) from unclassified points to create an additional areafrom the
object, it isuseful when classifying houses and treesto exclude the remaining " stumps' when building
DTM.

Automatic dense cloud multi-class classification

Metashape allows for semantic classification of dense point clouds to solve the task of higher-level
interpretation of the reconstructed data. Using the machine learning techniques Metashape enables
automatic dense cloud classification to any combination of the following classes. Ground, High
Vegetation, Building, Road, Car and Man-made.

To start the automatic multi-class classification

1. Select Classify Points... command from the Dense Cloud submenu of the Tools menu.
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2. Inthe Classify Points dialog box select the source point class for the classification procedure in the
"From" field.

3. Select thetarget classes from thelist in "To" field.

4. Define Confidence parameter in 0 - 1 range. Higher value of the parameter means that the point
which class cannot be reliably assigned, will remain unclassified.

5. Click OK button to run the classification procedure.

Classify Points

Classes
Fraom: Any class

L Ground

High Vegetation
Building
Rnarl Snrfares

Confidence: 0,00

Lo ] cancel |

"Classify Points" dialog
&  Note

« If you are not satisfied with the automatic multi-class classification results or would like
to contribute and improve the classificator, please send the manually labeled point clouds
according to the guidelines published on the following page to support@agisoft.com: http://
www.agi soft.com/support/tips-tricks/

Manual classification of dense point cloud

Metashape alows to associate all the points within the dense cloud with a certain standard class (see
LIDAR data classification). This provides possibility to diversify export of the processing results with
respect to different types of objects within the scene, e. g. DTM for ground, mesh for buildings and point
cloud for vegetation.

Toassign aclassto agroup of points

1 Switch to Dense Cloud view mode using using === Dense Cloud toolbar button.

2 Select points to be placed to a certain class using L. Rectangle Selection, {_7 Circle Selection or

Ix_g Free-Form Selection tools. To add new points to the current selection hold the Ctrl key during
selection of additional points. To remove some points from the current selection hold the Shift key
during selection of pointsto be removed.

3. Select Assign Class... command from the Dense Cloud submenu of the Tools menu.
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4. Inthe Assign Class dialog box select the source point data for the classification procedure and the
targeted class to be assigned to the selected points. Click OK button to run classification procedure.

Dense point cloud classification can be reset with Reset Classification command from Tools - Dense Cloud
menul.

Editing model geometry

The following mesh editing tools are available in Metashape:
 Decimation tool

* Photoconsistent mesh refinement tool

* Close holestool

* Smooth tool

» Colorize vertices

» Automatic filtering based on specified criterion

» Manual polygon removal

* Fixing mesh topology

More complex editing can be done in the external 3D editing tools. M etashape allows to export mesh and
then import it back for this purpose.

[ Note

 For polygon removal operations such as manual removal and connected component filtering it
is possible to undo the last mesh editing operation. There are Undo/Redo commands in the Edit
menu.

* Please note that Undo/Redo commands are not supported for mesh decimation and this operation
cannot be undone.

Decimation tool

Decimation is atool used to decrease the geometric resolution of the model by replacing high resolution
mesh with a lower resolution one, which is still capable of representing the object geometry with high
accuracy. Metashape tendsto produce 3D model s with excessive geometry resolution, so mesh decimation
isusually a desirable step after geometry computation.

Highly detailed models may contain hundreds of thousands of polygons. While it is acceptable to work
with such a complex modelsin 3D editor tools, in most conventional tools like Adobe Reader or Google
Earth high complexity of 3D models may noticeably decrease application performance. High complexity
also results in longer time required to build texture and to export model in PDF file format.

In some casesit isdesirable to keep as much geometry details as possiblelikeit is needed for scientific and
archive purposes. However, if there are no specia requirementsit is recommended to decimate the model
down to 100 000 - 200 000 polygons for exporting in PDF, and to 100 000 or even less for displaying in
Google Earth and aike tools.
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To decimate 3D mode
1. Select Decimate Mesh... command from the Tools menu.

2. Inthe Decimate Mesh dialog box specify the target number of polygons, which should remain in the
final model. Click on the OK button to start decimation.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

4 Note

e Textureatlasisdiscarded during decimation process. Y ou will have to rebuild texture atlas after
decimation is complete.

Photoconsistent mesh refinement tool

M etashape allows to refine aready reconstructed mesh with respect to camera photos. This is iterative
process that can further recover details on surface. For example it can recover basrelief or ditch.

Torefinemesh

1. Check the model - it will be refined with respect to camera photos. Y ou can duplicate it with right
click on the model and selecting Duplicate... to refine the copy of model.

2. Select Refine Mesh... command from the Tools menu.

3. Inthe Refine Mesh... dialog box specify the target quality of refinement, number of iterations and
smoothness. Click on the OK button to start refinement.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

Refinement parameters

Quality
Specifies the desired refinement quality. Higher quality settings can be used to obtain more detailed
and accurate geometry, but they require longer time for processing. Interpretation of the quality
parameters here is similar to that of accuracy settings given in Building dense point cloud section.

Iterations
Number of refinement iterations. In some cases additional iterations are able to recover more details,
but it will lead to proportional slow down.

Smoothness
Smaller smoothness parameter |eadsto better features recovering but also it can increase noise. Bigger
smoothness parameter leads to better noise suppression, but can smooth out features too. Changing
smoothness value can help to balance between noise suppression and features recovering.

Colorize model vertices

In Metashape the mesh model vertices can be colorized using images, sparse / dense cloud points colors
or orthomosaic data.
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To colorize model vertices

1. Select Colorize Vertices command in Mesh submenu from the Tools menu.
2. Inthe Colorize Model dialog box select source data for the operation.

3. Click on the OK button to start the procedure.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

Close holes tool

Close Holes tool provides possibility to repair your model if the reconstruction procedure resulted in a
mesh with several holes, due to insufficient image overlap for example.

Some tasks require a continuous surface disregarding the fact of information shortage. It is necessary to
generate a close model, for instance, to fulfill volume measurement task with M etashape.

Close holes tool enables to close void areas on the model substituting photogrammetric reconstruction
with extrapolation data. It is possible to control an acceptable level of accuracy indicating the maximum
size of aholeto be covered with extrapolated data.

Toclose holesin a 3D model

1. Select Close Holes... command in Mesh submenu from the Tools menu.

2. Inthe Close Holes dialog box indicate the maximum size of a hole to be covered with the slider.
3. Click on the OK button to start the procedure.

4. The progress dialog box will appear displaying the current processing status. To cancel processing
click on the Cancel button.

[{ Note

* Thedlider alowsto set the size of aholein relation to the size of the whole model surface.

Smooth tool

The Smooth tool alows you to make the model smoother and remove irregularities on the surface. Some
tasks require a sleek surface disregarding of details or real object more smooth than mesh in Metashape.
Y ou can apply the tool to the entire mesh or only to the selected area.

4 Note

» To apply smoothing to a specific area, you must first select it and then apply the tool.

To smooth mesh
1. Seect Smooth mesh... command in Mesh submenu of Tools menu.

2. In the Smooth mesh dialog box set the Srength parameter using slider. Y ou can aso enable check
box Apply to selected faces.
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3. Click OK when done. To cancel processing click Cancel button.

4 Note

» Fix borders option can be applied to the models with the open edges, it allows to preserve the
position of the mesh vertices along the open edges when using smoothing.

Polygon filtering on specified criterion

In some cases reconstructed geometry may contain the cloud of small isolated mesh fragments surrounding
the "main" model or big unwanted polygons. Mesh filtering based on different criteria helps to select
polygons, which usually are supposed to be removed.

M etashape supports the following criteria for face filtering:

Connected component size
This filtering criteria alows to select isolated fragments with a certain number of polygons. The
number of polygonsin all isolated components to be selected is set with a diider and is indicated in
relation to the number of polygons in the whole model. The components are ranged in size, so that
the selection proceeds from the smallest component to the largest one.

Polygon size
This filtering criteria allows to select polygons up to a certain size. The size of the polygons to be
selected is set with a dider and isindicated in relation to the size of the whole model. This function
can be useful, for example, in case the geometry was reconstructed with the extrapolation and there
is aneed to remove extra polygons automatically added by Metashape to fill the gaps; these polygons
are often of alarger size than therest.

Vertex confidence
This filtering criteria allows to select polygons using confidence value. This parameters available
only if during build model use Depth map as Source data. The value is displayed as a percentage and
corresponds to the percentage of confidence from the maximum value of all confidence.

Toremove small isolated mesh fragments
1. Select Gradual Selection... command from the Model menu.
2. Inthe Gradual Selection dialog box select Connected component size criterion.

3. Select the size of isolated components to be removed using the dlider. Size of the largest component
is taken for 100%. Y ou can observe how the selection changes while dragging the dlider. Click OK
button to finalize the selection.

4. To remove the selected components use Delete Selection command from the Edit menu or click
X Delete Selection toolbar button (or simply press Del button on the keyboard).

Toremovelarge polygons

1. Select Gradual Selection... command from the Model menu.

2. Inthe Gradual Selection dialog box select Polygon size criterion.

3. Sdect the size of polygons to be removed using the slider. Size of the largest polygon is taken for
100%. Y ou can observe how the selection changes while dragging the dider. Click OK button to
finalize the selection.
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4.

To remove the selected components use Delete Selection command from the Edit menu or click

X Delete Selection toolbar button (or simply press Del button on the keyboard).

Note that Metashape always selects the fragments starting from the smallest ones. If the model contains
only one component the selection will be empty.

Manual face removal

Unnecessary and excessive sections of model geometry can be also removed manually.

Toremove part of the mesh polygons manually

1.

-1

Select rectangle, circle or free-form selection tool using . —Rectangle Selection, \../Circle Selection

or ':._‘: Free-Form Sdlection toolbar buttons.

Make the selection using the mouse. To add new polygons to the current selection hold the Ctrl key
during selection of additional polygons. To remove some polygons from the current selection hold
the Shift key during selection of polygons to be excluded.

To delete selected polygons click the Pt Delete Sdlection toolbar button or use Delete Selection

command from the Edit menu. To crop sel ection to the sel ected polygons click thet{- Crop Selection
toolbar button or use Crop Selection command from the Edit menu.

Togrow or shrink current selection

1.

To grow current selection press PageUp key in the selection mode. To grow selection by even alarger
amount, press PageUp while holding Shift key pressed.

To shrink current selection press PageDown key in the selection mode. To shrink selection by even
alarger amount, press PageDown while holding Shift key pressed.

Fixing mesh topology

Metashape is capable of basic mesh topology fixing.

To fix mesh topology

1. Select View Mesh Satigtics... command from the Tools menu.

2. In the Mesh Satistics dialog box you can inspect mesh parameters. If there are any topological
problems, Fix Topology button will be active and can be clicked to solve the problems.

3. The progress dialog box will appear displaying the current processing status. To cancel processing

click on the Cancel button.

Editing mesh in the external program

To export mesh for editing in the external program

1

Select Export Model... command from the File menu.
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In the Save As dialog box, specify the desired mesh format in the Save as type combo box. Select the
file name to be used for the model and click Save button.

In the opened dialog box specify additional parameters specific to the selected file format. Click OK
button when done.

Toimport edited mesh

1
2.

£

Select Import Mesh... command from the File menu.

In the Open dialog box, browse to the file with the edited model and click Open.

Note

» Metashape supports loading models in Wavefront OBJ, 3DS, STL, COLLADA, Stanford PLY,
Autodesk FBX, Autodesk DXF, OpenCTM and U3D fileformatsonly. Please make sureto select
one of these file formats when exporting model from the external 3D editor.

» Please be aware that it isimportant to keep reference information for the model if any.

Shapes

Shapes are used to indicate boundaries either for export or for measurement procedures. Shapes can be
drawn over DEM or Orthomosaic aswell as over model using buttons from the Ortho/Model view toolbar.
Alternatively, shapes can be loaded from external files (SHP, KML, KMZ, DXF, GeoJSON formats are
supported) using Import Shapes... command of Import... submenu available from the File menu. Shapes
created in Metashape can be exported using Export Shapes... command of Export... submenu available
from the File menu.

To draw a shape on DEM/Orthomosaic/M odel

1

6.

Open the surface on which you want to draw (DEM, Orthomosaic or Model). Double clicking on
DEM, Orthomosaic or Model label on the Workspace pane.

=

Select “*" Draw Point /™ Draw Polyline / '/ Draw Polygon instrument from the tool bar.

Draw a point/polyline/polygon on the DEM/orthomosai c/model with a cursor. By default the shape
vertex will be put on the available surface, however, in Metashape is it possible to draw the shapes
on a given plane (for example, at a certain height). To set up the drawing plane, select polyline or
polygon shape with three or more vertices or three markers placed in 3D. Then right click on the
selection and choose Set Drawing Plane command from the context menu. To reset Drawing Plane
select the corresponding command from the context menu.

Double click on the last point to indicate the end of a polyline. To complete a polygon, place the end
point over the starting one.

=

Oncethe shapeisdrawn, ashape label " will be added to the chunk data structure on the Wor kspace
pane. All shapes drawn on the same model (and on the corresponding DEM and orthomosaic) will
be shown under the same label on the Workspace pane.

The program will switch to a navigation mode once a shape is compl eted.

Drawing shapesin 3D (on the model) solves issues with building basements and other features which are
not visible on the orthomosaic. However, drawing on amodel might not be accurate enough. For this case
M etashape offers possibility to draw a shape on source photos and automatically reconstruct it in 3D.
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To automatically reconstruct a shapein 3D
1. Enable Attach markers option available in Markers submenu of Tools menu.
2. Open aphoto in Photo view double clicking on the photo thumbnail in the Photo pane.

3 Select ¥ Draw Point / A Draw Polyline/ '/ Draw Polygon instrument from the toolbar.

4. Draw apoint/polyline/polygon on the photo with a cursor.

5. Doubleclick on the last point to indicate the end of a polyline. To complete apolygon, place the end
point over the starting one. All the vertices will be indicated with markers.

6. Switch to Model view to see that the shape has been reconstructed in 3D automatically.

7. Torefinethe position of the shape, filter photos by shape using the corresponding command from the
shape context menu. The shape must be selected - to select a shape double click on it.

8. Inspect al the relevant photos to refine markers-vertices positions where necessary. The position of
the shape in 3D will automatically be refined.

After a shape has been drawn, it can be edited using Insert Vertex / Delete Vertex commands from the
context menu. Delete Vertex command is active only for avertex context menu. To get accessto the vertex
context menu, select the shape with a double click first, and then select the vertex with a double click on
it. To change position of a vertex, drag and drop it to a selected position with the cursor. Positions of the
markers-vertices cannot be changed in the Model view.

Shapes alow to measure distances both on DEM and 3D model and to measure coordinates, surface
areas and volumes on 3D model. Please refer to Performing measurements on 3D model, Performing
measurements on DEM sections of the Manual for details.

Shapes added to the particular chunk of the project can be organizedinto layers. Thefirst layer isgenerated
automatically on creation of the first shape and is placed into the Shapes folder on the project tree. This
layer is meant to serve as a background thus named No Layer. It is originally set as default one to store
all the shapes.

To create a new layer use Create Shape Layer command from the context menu of the Shape folder on
the Workspace pane. A layer can be set as default one using Set as default command from the context
menu of the layer name on the Workspace pane. A newly created layer can be renamed with a relevant
command from the context menu.

Export Layers... command from the context menu of alayer allows to save shapes from the layer in one
of the supported export formats available: SHP, DXF, KML, KMZ, GeoJSON, GeoPackage.

A shape can be labeled and saved to a certain layer using Properties... command from the context menu
of the shape in the Model/Ortho view.

Shape properties
The style of the shape layer can be defined in Metashape. It is possible to assing the label, border color, fill

color and fill style (for polygons) and transparency for the layer. Attribute table customization is available
from the shape properties dialog for each shape, where an attribute and its value can be specified.

4 Note

» Polygon fill styleisapplied only in Ortho view mode.
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To set propertiesfor a shape

1. Right-clink on the selected shape in the Model, Ortho or Photo view mode.

2. Select Properties... command from the context menu.

3. Assigntheshapeto an existing layer fromthelist or create anew one by clicking on Add Layer button.
4. Populate the attribute table for the shape.

5. Click OK if to complete the settings.

It is possible to modify the style of the shape layer in the Metashape from the shape Properties pane. To
open the Properties pane, select Properties command from the View menu. Properties (Label, Description
and Layer) for the selected shape will appear in this pane. To customize the layer style for this shape,
doubleclick onthe Layer lineand click on the Edit layer button. Parameters can be modified in the opened
Shape layer properties dialog.

Orthomosaic and panorama seamlines editing

M etashape software offers various blending options at orthomosai c and panorama generation step for the
user to adjust processing to their data and task. However, in some projects moving objects can cause
artefacts which interfere with visual quality of the orthomosaic and panorama. The same problem may
result from oblique aerial imagery processing if theareaof interest contains high buildingsor if the user has
captured facade from too oblique positions. To eliminate mentioned artefacts Metashape offers seamline
editing tool. The functionality allows to choose manually the image or images to texture the indicated part
of the orthomosaic/panorama from. Thus, the final orthomosaic and panorama can be improved visually
according to the user's expectations.

e
Automatic seamlines can be turned on for inspection in the Ortho view with pressing the = Show
Seamlines button from the Ortho view toolbar.

To edit orthomosaic or panorama seamlines

L Draw a polygon on the orthomosai c/panorama using "/ Draw Pol ygon instrument to indicate the

areato be retextured.
2. Select Assign Images... command from the context menu of the selected polygon.

3. In the Assign Images dialog box select the image to texture the area inside the polygon from.
Orthomaosai ¢/panorama preview on the Ortho tab allows to evaluate the results of the selection. Click
OK button to finalize the image selection process.

Click '_“JII'! Update Orthomosai ¢ button from the Ortho view toolbar to apply the changes.

Assign Images dialog allows to activate multiple selection option. If the Allow multiple selection optionis
checked, it is possible to assign several images to texture the area inside the polygon from. However, in
this case there is no possibility to preview the resulting orthomosaic or panorama. It is necessary to click

ﬁl:rl'ﬂ Update Orthomosaic button from the Ortho view toolbar to apply the changes and see the results. Until
the changes are applied, the area of interest will be marked with a net of blue color to indicate that some
edits are waiting for enforcement. Blending method selected at build orthomosaic/panorama step will be
implemented at orthomosai ¢/panorama editing step.
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Assign Images dialog, aternatively, allows to exclude selected images from texturing the area of interest.
Check Exclude selected images option to follow this way. Please note that in this case preview illustrates
theimageto be excluded, i.d. the results one should expect after applying the changes are not shown. Click

'_“Jrl'! Update Orthomosai ¢ button from the Ortho view toolbar to apply the changes.

s

If the Assign image operation should be repeated several times, it is recommended to use "=/ Draw Patch
tool available from the Ortho menu or with a corresponding Toolbar button of the Ortho view menu. In
this case it will still be required to draw polygons asin the procedure above, but the best fit image will be
assigned automatically, being selected with respect to the first drawn vertex of the patch.

Editing textures

Remove lighting

Metashape can delight texture automatically. Generally, removing shadows and recovering lighting-
neutral color while preserving texture features isimpossible - at least because of ambiguity between dark
texture produced by shadows on surface and dark texture produced by dark regions of the surface. But in
practice in many cases heuristics based on some assumptions can provide good results.

Texture delighting tool smooths out dark and light sides of object model and can additionally light up
surface areas that were found to be too dark with respect to ambient occlusion map.

1. Open project with textured model. In casethe external model should be delit, the empty project or new
chunk can be created, add new chunk selecting Add Chunk command from the Workspace context
menu and then import textured mesh using Import Model command in the Import submenu of File
menu.

2. Duplicatemodel. To be ableto compare delighted texture with the original one afterwards, you should
preliminary duplicate the model and then delight only the second one. To duplicate the model, right
click on Workspace 3D Model and select Duplicate.

3. Sdlect Remove lighting command from the Mesh submenu of the Tools menu.

In the Remove lighting dialog box select the kind of parameters to be performed. Options include: color
mode, presets and ambient occlusion. Click OK button when done.

Color mode
You can use two types color mode: Single color and Multi color. Use Single color if the model is
homogeneous and use Multi color if scene presents a combination of the colors.

Presets
Preset configures advanced parameters for some special cases.

Aggressive (for rocks)
Preset, it is adjusted for delighting of rocks, but still sometimes can lead to artefacts.

Ambient occlusion map
Optionally, you can load into M etashape ambient occlusion texture map and thetool will try to recover
ambient occlusion dark areas on the model.

Resize texture

M etashape supports texture resizing. Select Resize texture command from the Mesh submenu in the Tools
menu to change the size of the texture.

133



Editing

In the Resize texture dialog box set the diffuse map size in pix. Click OK button when done.

Diffuse map size (pix)
Y ou can set the parameters for resizing texture in order to upscale or downscale it.
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Chapter 7. Automation

Using chunks

When working with typical datasets, automation of general processing workflow allowsto perform routine
operations efficiently. Metashape alows to assign several processing steps to be run one by one without
user intervention thanks to Batch Processing feature. Manual user intervention can be minimized even
further dueto 'multiple chunk project' concept, each chunk to include onetypical dataset. For aproject with
several chunks of the same nature, common operations available in Batch Processing dialog are applied to
each selected chunk individualy, thus allowing to set several data setsfor automatic processing following
predefined workflow pattern.

In addition, multiple chunk project could be useful when it turns out to be hard or even impossible to
generate a 3D model of the whole scene in one go. This could happen, for instance, if the total amount
of photographs is too large to be processed at a time. To overcome this difficulty Metashape offers a
possibility to split the set of photos into several separate chunks within the same project. Alignment of
photos, building dense point cloud, building mesh, and forming texture atlas operations can be performed
for each chunk separately and then resulting 3D models can be combined together.

Working with chunks is not more difficult than using Metashape following the general workflow. In fact,
in Metashape always exists at |east one active chunk and all the 3D model processing workflow operations
are applied to this chunk.

To work with several chunks you need to know how to create chunks and how to combine resulting 3D
models from separate chunks into one model.

Creating a chunk

To create new chunk click on the & Add Chunk toolbar button on the Workspace pane or select Add
Chunk command from the Workspace context menu (available by right-clicking on the root element on
the Workspace pane).

After the chunk is created you may load photosinit, align them, generate dense point cloud, generate mesh
surface model, build texture atlas, export the models at any stage and so on. The models in the chunks
are not linked with each other.

Thelist of all the chunks created in the current project is displayed in the Workspace pane along with flags
reflecting their status.

The following flags can appear next to the chunk name:

R (Referenced)
Indicates that 3D model in the chunk was referenced. Also will appear when two or more chunks are
aligned with each other. See information on how to reference the model in Setting coordinate system.

S (Scaled)
Indicates that 3D model in the chunk was scaled based on scale bars information only, with no
reference coordinates data being present. See information on scale bar placement in Optimization
section.

T (Transformed)
Indicates that 3D model has been modified manually with at least one of the following instruments:

[ 1Y . . P, .
“I# Rotate object, & Move object or ““& Scale object.
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To move photos from one chunk to another simply select themin thelist of photos on the Wor kspace pane,
and then drag and drop to the target chunk.

4 Note

» Chunk can contain several instances of the same object (point clouds, 3D model, etc).

Working with chunks

All operations within the chunk are carried out following the common workflow: loading photographs,
aligning them, generating dense point cloud, building mesh, building texture atlas, exporting 3D model
and so on.

Note that all these operations are applied to the active chunk. When anew chunk is created it is activated

automatically. Save project operation savesthe content of all chunks. To save selected chunks as aseparate
project use Save Chunks command from the chunk context menu.

To set another chunk as active
1. Right-click on the chunk title on the Workspace pane.

2. Select Set Active command from the context menu.

To remove chunk
1. Right-click on the chunk title on the Workspace pane.
2. Select Remove Chunks command from the context menu.

To rearrange the order of chunksin the Workspace pane ssimply drag and drop the chunksin the pane.

Aligning chunks

After the "partiad" 3D models are built in several chunks they can be merged together. Before merging
chunks they need to be aligned.

To align separate chunks
1. Select Align Chunks command from the Workflow menu.

2. Inthe Align Chunks dialog box select chunks to be aligned, indicate reference chunk with a double-
click. Set desired alignment options. Click OK button when done.

3. The progress dialog box will appear displaying the current processing status. To cancel processing
click the Cancel button.

Aligning chunks parameters
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Align Chunks

Chunk 1 (221 cameras, 11 markers, 435,468 poi...
Chunk 2 (221 cameras, 10 markers, 392,772 ...

General

Method: Point based

Fix scale

Image Matching

Accuracy: High
Key point limit: 40,000
Apply masks to: lone

Generic preselection

Lok ] Cancel

"Align Chunks" dialog

Thefollowing parameters control the chunksalignment procedure and can be modified in the Align Chunks
dialog box:

Method
Defines the chunks alignment method. Point based method aligns chunks by matching photos across
all thechunks. Marker based method uses markersas common pointsfor different chunks. Thedetails
on using markers are available in the Setting coordinate system section. Camera based method is
used to align chunks based on estimated camera locations. Corresponding cameras should have the
same label.

Accuracy (Point based alignment only)
Higher accuracy setting hel psto obtain moreaccurate chunk alignment results. L ower accuracy setting
can be used to get the rough chunk alignment in the shorter time.

Point limit (Point based alignment only)
The number indicates upper limit of feature points on every image to be taken into account during
Point based chunks alignment.

Fix scale
Option is to be enabled in case the scales of the models in different chunks were set precisely and
should be left unchanged during chunks alignment process.

Preselect image pairs (Point based alignment only)
The aignment process of many chunks may take a long time. A significant portion of thistime is
spent for matching of detected features across the photos. Image pair preselection option can speed
up this process by selection of a subset of image pairs to be matched.
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Apply mask to (Point based alignment only)

If apply mask to key points option is selected, areas previously masked on the photos are excluded
from feature detection procedure. Apply mask to tie points option means that certain tie points are
excluded from alignment procedure. Effectively thisimpliesthat if some areais masked at least on a
single photo, relevant key points on the rest of the photos picturing the same areawill be also ignored
during alignment procedure (atie point is a set of key points which have been matched as projections
of the same 3D point on different images). This can be useful to be able to suppress background in
turntable shooting scenario with only one mask. For additional information on the usage of masks
please refer to the Using masks section.

4 Note

¢ Chunk alignment can be performed only for chunks containing aligned photos.

» Thereis no need to perform chunk alignment for georeferenced chunks, as they are already in
the same coordinate frame.

Merging chunks
After dignment is complete the separate chunks can be merged into a single chunk.
£ Note

* Werecommend processing all theimagesin asingle chunk to provide better accuracy and quality
of thefinal results than the chunking method (separate processing of the sub-sets of the complete
photos set and merging them).

To merge chunks
1. Select Merge Chunks command from the Workflow menu.

2. Inthe Merge Chunks dialog box select chunks to be merged and the desired merging options. Click
OK button when done.

3. Metashapewill mergethe separate chunksinto one. The merged chunk will be displayed in the project
content list on Workspace pane.

Merge chunks parameters
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Merge Chunks

Chunk 1 (813 cameras, 7 markers, 4,748,556 points)..,
Chunk 2 (1035 cameras, 10 markers, 5,940,318 poin...

Merge dense couds Merge tie points
Merge models Merge markers
Merge DEMs Merge orthomosaics

Merge depth maps

Lok ] cCancel

"Merge Chunks' dialog

Thefollowing parameters control the chunks merging procedure and can be modified in the Merge Chunks
dialog box:

Mer ge dense clouds
Defines if dense clouds from the selected chunks are combined.

Merge models
Defines if models from the selected chunks are combined.

Merge DEMs
Defines if DEMs from the selected chunks are combined.

Mer ge depth maps
Definesif depth maps from the selected chunks are combined.

Mergetie points
Defines if the projections of the tie points for corresponding features should be merged. Since tie
points merging operation assumes re-matching of the features from different chunks, the operation
may be time consuming. Thus it is recommended to disable tie points merging, unlessit is required
by the task specifics.

Merge markers
Defines if markers from the selected chunks are merged (only markers with the same labels would
be merged).

M er ge orthomosaics
Defines if orthomosaics from the selected chunks are combined.

Chunks merging result (i.e. photos, point clouds and geometry) will be stored in the new chunk and it may
be treated as an ordinary chunk (e.g. the model can be textured and/or exported).

4 Note

« Dense cloud and model merging operations will be applied only to the active items. Disabled
(inactive) items will not be transferred to the merged chunk.
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Batch processing

M etashape allows to perform general workflow operations with multiple chunks automatically. It isuseful
when dealing with alarge number of chunks to be processed.

Batch processing can be applied to all chunks in the Workspace, to unprocessed chunks only, or to the
chunks selected by the user. Each operation chosen in the Batch processing dialog will be applied to every
selected chunk before processing will move on to the next step.

General Workflow Import/Export Miscellaneous
Align Photos Import Masks Align Chunks
Build DEM Import Shapes Cadlibrate Colors
Build Dense Cloud Export Cameras Classify Ground Points
Build Mesh Export DEM Classify Points
Build Orthomosaic Export Orthomosaic Close Holes
Build Panorama Export Points Colorize Dense Cloud
Build Texture Export Texture Colorize Model
Build Tiled Model Export Tiled Model Convert Images
Generate Report Decimate Mesh
Detect Fiducials
Detect Markers
Generate Masks
Generate Prescription Map
Load Project
Merge Chunks
Optimize Alignment
Refine Mesh
Remove Lighting
Reset Region
Run Script
Sample Points
Save Project
Smooth Model

To start batch processing
1. Select Batch Process... command from the Workflow menu.
2. Click Add to add the desired processing stages.

3. Inthe Add Job dialog select the kind of operation to be performed, the list of chunks it should be
applied to, and desired processing parameters. Click OK button when done.

4. Repeat the previous steps to add other processing steps as required.

5. Arrangejobs by clicking Up and Down arrows at the right of the Batch Process... dialog box.
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6. Click OK button to start processing.

7. Theprogressdialog box will appear displaying the list and status of batch jobs and current operation
progress. To cancel processing click the Cancel button.

Batch Process

Order  Job Type Applies To

1 Align Photos All Chunks

2 Optimize Align...  All Chunks
3 Build Dense Clo... All Chunks
4 Build DEM All Chunks
3 Build Orthomos. All Chunks
&  Build Mesh All Chunks

7 Build Texture All Chunks

=
Save project after each step
Cancel
"Batch Process’ dialog

When the batch processincludesimport/export features that are applied to multiple chunksit is reasonable
to use the following templatesin the Path field of the import/export jobs:

« {filename} - filename (without extension),

{fileext} - file extension,

e {camera} - cameralabel,

{frame} - frame index,

{chunklabel} - chunk label,

{imagefolder} - folder containing images of an active chunk,

{projectfolder} - path to the folder containing current project,

» {projectname} - current project filename,

{projectpath} - absolute path to the current project.

Thelist of tasks for batch processing can be exported to XML structured file using P.l Save button in the

Batch processing dialog and imported in a different project using =~ Open button.
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4D processing

Overview

M etashape supports reconstruction of dynamic scenes captured by aset of statically mounted synchronized
cameras. For this purpose multiple image frames captured at different time moments can be loaded for
each camera location, forming a multiframe chunk. In fact norma chunks capturing a static scene are
multiframe chunks with only a single frame |oaded. Navigation through the frame sequenceis performed
using Timeline pane.

Although aseparate static chunk can be used to process photosfor each time moment, aggregate multiframe
chunks implementation has several advantages:

» Coordinate systems for individual frames are guaranteed to match. There is no need to align chunksto
each other after processing.

» Each processing step can be applied to the entire sequence, with a user selectable framerange. Thereis
no need to use batch processing, which simplifies the workflow.

» Accuracy of photo alignment is better due to the joint processing of photos from the entire sequence.
» Markers can be tracked automatically through the sequence.
* Intuitive interface makes navigation through the sequence pretty simple and fast.

Multiframe chunks can be also efficient (with some limitations) for processing of disordered photo sets of
the same object or even different objects, provided that cameras remain static throughout the sequence.

Managing multiframe chunks

Multiframe layout is formed at the moment of adding photos to the chunk. It will reflect the data layout
used to store image files. Therefore it is necessary to organize files on the disk appropriately in advance.
The following data layouts can be used with Metashape:

a. All framesfrom corresponding camera are contained in a separate subfolder. The number of subfolders
is egual to the number of cameras.

b. Corresponding framesfrom all cameras are contained in aseparate subfolder. The number of subfolders
isequal to the number of frames.

c. All frames from corresponding camera are contained in a separate multilayer image. The number of
multilayer imagesis equal to the number of cameras.

d. Corresponding frames from all cameras are contained in a separate multilayer image. The number of
multilayer imagesis equal to the number of frames.

Once the data is properly organized, it can be loaded into Metashape to form a multiframe chunk. The
exact procedure will depend on whether the multifolder layout (variants a and b) or multilayer (variants
¢ and d) layout is used.

To create a chunk from multifolder layout

L Select & Add Folder... command from the Wor kflow menu.
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2. Inthe Add Folder dialog box browse to the parent folder containing subfolders with images. Then
click Select Folder button.

3. Inthe Add Photos dialog select Dynamic scene (4D) data layout. For layout @) above select Create
camera from each subfolder. For layout b) select Create frame from each subfolder.

4. Created multiframe chunk will appear on the Workspace pane.

To create a chunk from multilayer images

L Select Add Photos... command from the Workflow menu or click @ Add Photos toolbar button.

2. Inthe Add Photos dialog box browse to the folder containing multilayer images and select files to
be processed. Then click Open button.

3. Inthe Add Photos dialog select the suitable data layout. For layout c) above select Create camera
from each multilayer file. For layout d) select Create frame from each multilayer file.

4. Created multiframe chunk will appear on the Workspace pane.

It isrecommended to inspect the loaded frame sequence for errors. This can be done by scrolling the frame
selector in the Timeline pane and inspecting thumbnails in the Photos pane during scrolling.

In case each frame should be processed completely separately, it is possible to split them using Split
frames... command from the chunk context menu.

Frames can be added from one chunk to another. To do that right-click on the chunk's label in the
Workspace pane and select Add > Add frames command. In the Add Frames dialog select chunk where
from the frames will be added and click OK button.

After multiframe chunk is created, it can be processed in the same way as normal chunks. For multiframe
chunks additional processing parameters allowing to select the range of frames to be processed will be
provided where appropriate.

Tracking markers

Metashape allows to automatically track marker projections through the frames sequence, provided that
object position doesn't change significantly between frames. This greatly simplifies the task of labeling of
amoving point if the number of framesislarge.

Totrack markersthrough the frame sequence

1. Scroll frame selector in the Timeline paneto the 1st frame. Add markersfor the 1st frame as described
in the Setting coordinate system section.

2. Select Track Markers... command from the Markers submenu of the Tools menu.

3. Adjust the starting and ending frameindicesif necessary. Default val ues correspond to tracking from
the current frame to the end of sequence. Click OK button to start tracking.

Check tracked marker locations. Automatically tracked markers will be indicated with [Fh icons. In
case of a placement error at some frame, adjust the wrong marker location within the frame where

the failure occurred. Once the marker location is refined by user, the marker icon will changeto [|3:J

143



Automation

5. Restart tracking from that frame using Track Markers... command again.

4 Note

« If the ending frame index is smaller than the starting index, tracking will be performed in the
backwards direction.

» Automatic marker tracking is likely to fail in case when structured light is used to add texture
details to the object surface, as the light pattern will not be static with respect to the moving
object surface.

Python scripting
Python scripting in Metashape

M etashape supports Python API, using Python 3.8 as a scripting engine.
Python commands and scripts can be executed in Metashape through one of the following options:
1. Metashape Console pane can serve as Python rich console.

2 Click Lé# Run Script button on Console pane toolbar or use ¥ Run Script... command from the Tools

menu to run a Python script.
From command-line using -r argument.

On Windows:
metashape.exe -r <scriptname.py>

On Linux:
Jmetashape.sh -r <scriptname.py>

On macOS:
/M etashapePr o.app/ContentsM acOS/M etashapePro -r <scriptname.py>

From autorun folder.

for Windows: C:/Users/<user>/AppData/L ocal/Agisoft/M etashape Pro/scripts/

for Linux: /home/<user>/.local/share/Agisoft/M etashape Pro/scripts/

for macOS: /Users/<user>/Library/Application Support/Agisoft/Metashape Pro/scripts/
on any OS (for all users): <installation folder>/scripts/

For details on Metashape functionality accessible through Python scripts please refer to Python API
Reference document available on Agisoft official website (http://www.agisoft.com/downloads/user-
manuals/).

The collection of the sample Python scriptsis available on Agisoft GitHub repository: https://github.com/
agisoft-1lc/metashape-scripts.

Stand-alone Python module

M etashape can be used as Python 3 package for stand-alone Python modul e devel opment.
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To configure development environment

1. Download Metashape Python 3 module for your platform from Agisoft web-site: https./
www.agi soft.com/downl oads/installer/

2. Instal Metashape Python 3 module

3. Import Metashape Python 3 module and start development: import M etashape

Java API

Metashape Java API allows to integrate photogrammetric processing engine into applications devel oped
using Java programming language. It comes in the form of software library and need to be downloaded
separately from Downl oads section of Agisoft website.

To configure development environment
1. Download Metashape JavaAPI from Agisoft web-site: https://www.agisoft.com/downloads/installer/
2. Unpack downloaded archive and copy libs and jniLibs folders to your project directory.

3. Addjarsfrom thelibs folder to your classpath.

¢ Important
Java garbage collection system may not release memory associated with Metashape objects in a
timely manner as it doesn't know memory consumption of underlying native objects. To prevent
excessive memory consumptionit ishighly recommended to call del ete() method manually for each
object obtained using Metashape Java APl when it is no longer needed.

For details on Metashape Java API functionality please refer to the included javadoc package. Also please
take alook at examples available in the samples directory to get started.
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Chapter 8. Distributed processing

Local network processing

Overview

Agisoft Metashape can be configured to run on a computer cluster where processing is distributed on
several computer nodes connected to alocal network. In such configuration multiple M etashape instances
running on different processing nodes can work on the same task in parallel, effectively reducing the total
processing time needed.

Processing tasks are divided between the nodes on a chunk by chunk or frame by frame basis (when
possible). In addition a more fine grained distribution can be optionally enabled for image matching
and alignment, generation of dense point clouds, tiled models, DEMs and orthomosaics, as well as
mesh generation from depth maps, in which case processing of individual chunks/frames will be further
subdivided between several processing nodes.

Communication between processing nodes, server and clients is performed using TCP connections. In
addition, shared network storage accessible for al processing nodes and clients is used for storing the
source data and intermediate processing results.

Cluster components

Server

—mi Processing Node 1
TCP TCcp
Master Processing Node 2
Server

Processing Node N
Network Storage

The server node coordinates operation of all processing nodes, maintaining a task queue for al projects
scheduled for processing. The clients can connect to the server to start new processing tasks or monitor
progress of existing ones.
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The server itself doesn't perform any processing and can easily run on slow hardware. The server
component is critical for operation of the cluster, and is not fault tolerant. Measures should be taken to
ensure continuous operation of the server node.

The server node accepts TCP connections from processing nodes and clients. Additional dave servers can
be connected to the master server to perform replication of processing queue for additional fault tolerance
in critical environments.

Processing nodes

Processing nodes perform actual calculations, and thus need to be run on fast hardware. Each processing
node connects to the server on startup and waits for atask to be assigned. Once the task is available, the
node starts processing, informing the server about the progress. When processing is finished, the results
are stored on shared network storage, and the server isinformed about completion. Then a node switches
to the next task when it becomes available.

Processing nodes can be added or removed from the cluster as needed. Abnormal shutdown of processing
node doesn't cause cluster failurein most cases. Nevertheless, it is highly recommended to stop particular
nodes using Agisoft Network Monitor before disconnecting them from the cluster.

Clients

Clients can connect to the server nodeto control cluster operation or to monitor its status. New tasks can be
submitted for processing using Agisoft Metashape software configured as a network client, while cluster
monitoring is performed using Agisoft Network Monitor. Multiple clients can be connected to the server
node simultaneously.

Cluster setup

Before proceeding to the following steps please make sure that shared network storage is accessible from
all processing and client nodes using the same absol ute path. 1t should be either mounted to the same folder
on all nodes (Linux), or should have the same UNC network path (Windows). In case such configuration
isnot possible (for example in mixed Windows/Linux cluster), a path prefix can be specified on each node
to compensate for the differences.

Starting server

It is recommended to configure server with a static |P address, not dynamically assigned one. This IP
address will be needed for each processing node and client.

The server process can be started by executing M etashape with the following command line arguments:
metashape --server --host <ip>[:port]

--server parameter specifies that M etashape should be started in a server mode.
--host <hostname>[:port] parameter specifies the network interface to be used for communication with
clientsand processing nodes. In case port valueis omitted, the default port 5840 is used. The host parameter

can be specified multiple time, in which case the server will listen for connections on multiple interfaces.

--master <hostname>[:port] parameter switches the server to slave mode and starts replication of the
specified master server. In case port value is omitted, the default port 5840 is used.

Example:
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metashape --server --host 10.0.1.1

In this case Metashape will use 10.0.1.1 interface for both clients and processing nodes with default port
value.

Starting network nodes

The processing node can be started by executing M etashape with the following command line arguments:
metashape --node --host <ip>[:port] [--root prefix]

--node parameter specifies that Metashape should be started as a processing node.

--host <hostname>[:port] parameter specifies IP of the server to connect. In case port value is omitted,
the default port 5840 is used. The host parameter can be specified multiple times, in which case the node
will automatically connect to the next server in the list if the previous one becomes unavailable. Thisis
useful when using slave servers.

--root <path> parameter can be used to specify network storage mount point or prefix path in case it is
not the same across network.

--priority <priority> parameter can be used to specify the priority of the node. Higher number means
higher priority.

--capability {cpu, gpu, any} parameter can be used to specify whether the node should work on CPU-
only tasks, GPU-supported tasks only or will receive any tasks.

--gpu_mask <mask> parameter set GPU device mask for GPU-supported tasks.

--cpu_enable {0,1} parameter can be used to enable or disable CPU during the GPU-supported tasks.
--absolute paths{0,1} parameter can be used to set the absolute paths option.

--timestamp parameter can be used to append timestamps to the output messages.

--auto-submit parameter can be used to enable automatic crash report submission.

--email <address> parameter specifies email address to be included in the crash reports.

--comment <text> parameter specifies optional comment to be included in the crash reports.

Example:
metashape --node --host 10.0.1.1 --r oot /mnt/datasets

This command will start processing node using 10.0.1.1 as a server | P with default port 5840.

Checking cluster status

Start Agisoft Network Monitor application. In the host name field enter server IP used for client
connections (10.0.1.1 in our example). Modify port values in case non-default port was specified. Click
Connect button when done.

A list of available network nodes currently connected to the server will be displayed in the bottom part of
the window. Please make sure that all started processing nodes are listed. Agisoft Network Monitor for
each node allowsto modify the node priority, capability, CPU enable flag, GPU mask and to pause/resume

148



Distributed processing

the node. The priority for the tasks can be also atered and tasks themselves can be paused, resumed and
aborted via Agisoft Network Monitor.

Thetop part lists tasks currently being processed (finished tasks are removed from the list as soon as they
are completed). The task list will be empty if no processing was started yet.

Starting network processing

1.

Configure Agisoft Metashape for network processing.
Start Agisoft Metashape on any computer connected to the cluster network.

Open Preferences dialog using Preferences... command from the Tools menu. On the Network tab
make sure Enable network processing option is turned on, and specify the server 1P used for client
connection in the Host name field. In case non-default port was configured on a server, modify the
port value accordingly.

In case you are going to process afew single-frame chunkswith large number of photos, please make
sure that Enable fine-level task subdivision option is turned on in the Advanced tab of Preferences
dialog. The subdivision will be automatically applied when possible to all the supported operations
(Match Photos, Align Cameras, Build Depth Maps, Build Mesh from Depth Maps, Build Dense
Cloud, Build Tiled Model, Build DEM, Build Orthomosaic, Classify Points). In case you are going
to process a large number of small chunks, or chunks with large number of frames, fine-level task
subdivision can be disabled, therefore each chunk or frame will be processed on the single node only
without any further internal distribution applied.

Press OK button when done.
Prepare project for network processing.

Open the project file to be processed. Make surethat the project is saved in M etashape Project (*.psx)
format. Processing of projectsin Metashape Archive (*.psz) format is not supported in network mode.

¢ |Important
Please make sure that source images are located on shared network storage and not on alocal
hard drive. Otherwise processing nodes will be unable to load them.

Start processing.

Start processing using corresponding command from the Workflow menu, or using Batch Process
command to execute a command segquence. A network progress dialog should appear displaying
current progress.

Wait for processing to complete.

You can disconnect from the server at any time using Disconnect button in the Network Progress
dialog in case you need to work on other projects. Processing will continue in the background.

To see processing status after you have disconnected from the server simply open corresponding .psx
project on the network storage. Alternatively you can use Agisoft Network Monitor to see processing
status for all projects being processed.

Inspect processing results.

After processing is finished, click Close button to close Network Progress dialog. The project with
processing results will be displayed in Metashape window.
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Cluster administration

Adding processing nodes

New processing hodes can be added by starting Agisoft M etashape on additional computersin the network
node mode, as outlined in the Starting network nodes section above.

Removing processing nodes

Aborting or disconnecting processing node during cluster operation is not absolutely safe, and can lead to
project corruption if performed during final project update at the end of processing. Although the chances
of this situation are relatively low, we strongly recommend against such approach. To safely disconnect
processing node from the cluster you need to stop processing on this node using Agisoft Network Monitor
first.

1. Start Agisoft Network Monitor. Make sure the server IPis properly configured in the host namefield
and click Connect button.

2. In the bottom list of network nodes identify the node to be removed. From the node menu select
Pause command to stop the node after it finishes current job, or Stop command to abort processing
immediately.

3. Wait until the Batch # and Progress items for a selected node become empty. This indicates that the
node has finished processing. The status of the node should be Paused.

4.  Now you can safely disconnect the node by aborting M etashape process.

Using server replication

In case of abnormal termination of the server node processing queue will be lost, and all incompl ete tasks
will need to be restarted from the beginning. To avoid such problem it is possible to set up one or more
slave servers, that will be automatically synchronized with a master server. In case of a master server
failure, it will be possible to resume processing by switching to the one of the available slave servers.

Here is an example setup of a cluster with a server replication:

metashape --server --host 10.0.1.1

metashape --server --host 10.0.2.1 --master 10.0.1.1

metashape --node --host 10.0.1.1 --host 10.0.2.1 --root /mnt/datasets

These commands will start amaster server at 10.0.1.1 interface and aslave server on 10.0.2.1 interface. In

addition a node will be configured to ook for an active master server at 10.0.1.1 and 10.0.2.1 addresses.
In case of amaster server failure the node will automatically reconnect to another master server.

¢ Important

* In case of a master server failure, slave servers will not switch to a master state automatically.
An operator will need to switch one of the slave servers to a master state manually using Reset
Master Server command from the Agisoft Network Monitor File menu and connect remaining
slave servers to a new master. In the unattended environment this can be automated using a
Python or Java API.
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» Before switching to a new master server please make sure that original master server isdisabled
and will not be unexpectedly restored (due to a temporary network failure for example).
Simultaneous operation of two master serverswill result in inconsistent project state and further
processing will fail.

Installing server and nodes as a Windows service
It is possible to configure server and nodes to run as a service on Windows. In thislog in.
The following command line parameters are used to manage Windows service settings:

--service {install,remove,start,stop} parameter can be used to configure Windows service.

--ser vice-name <name> optional parameter for Windows service name. Required when multiple services
needs to be installed on the same computer.

Examples:

metashape --service install --node --host 10.0.1.1 --r oot /mnt/datasets
metashape --service install --server --host 10.0.1.1

metashape --service start

metashape --service stop

metashape --service remove

[{ Note

e These commands must be executed from Administrators Command Prompt as they require
elevated privileges.

Cloud processing

Overview

Agisoft Metashape presents cloud processing option integrated into the application user interface for
those who are interested in high quality outputs for big datasets, without need to invest into hardware
infrastructure.

Starting cloud processing

Cloud processing option is only accessible for those Metashape license owners who have registered on
Agisoft Cloud page: https://cloud.agisoft.com/. Personal account page providesinformation about current
subscription plan, storage space and processing hours available, projects published in the cloud, invoices
and personal data. Having completed the registration and having chosen the appropriate payment plan,
one should input Agisoft Cloud account credential sto the Network tab of Preferences dialog in Metashape
application.

Setting up cloud processing in M etashape

1. Select Preferences command from the Tools menu.
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2. Input your Agisoft account credentials to the Network tab in Preferences dialog.

3. Check thebox for Enable cloud processing optionto turnit on. Check that Enable networ k processing
option isturned off.

4. Click OK button when done.

Once the cloud processing option is enabled, each time the processing operation is run in Metashape a
confirmation dialog will appear, asking if the operation should be executed locally or in the cloud. If
the cloud processing option is selected in the dialog, the project data and related source imagery will be
upl oaded/synchronized with the dataiin your personal Agisoft Cloud account. To monitor the status of the
project, you can use Project tab on the personal account page.

Do not disable Internet connection nor shut down the computer when uploading processisin progress. Y ou
can disconnect, however, once the processing has been started according to the indication in the program
interface and in the web interface of your personal account.

Next time you open a loca project for which a processing operation in Agisoft Cloud is finished the
updated project fileswill be downloaded from the cloud and synchronized with your local project copy.

Download project from the cloud

To download project from the cloud
1. Select Download Project... command from the Cloud submenu of the File menu.
2. Select the project to be downloaded from the list.

3. Click OK to start the download process.

Visualize project results

To make cloud project available for visualization in web interface, it is necessary to publish it, first.
Publication is a process of preparing processing results for 3D visualization in web interface. The
publication is only available for georeferenced PSX projects. Each publication takes up storage space.

When processing a new project in Agisoft Cloud for the first time, you may check Publish results option
in the Schedule processing in the cloud Metashape dialog. If Publish results option is checked on during
the first processing of the current project in Agisoft Cloud, results of further processing iterations for the
same project will be published automatically.

Furthermore, it is possible to publish project via Agisoft Cloud web interface.
When the project is published, use View button to inspect project results.
To unpublish the project (i.e. disable the possibility to view the project processing results online) use

Unpublish button on the projects page of your personal account. The Unpublish button is available when
the project is selected from the list.

Upload project into the cloud

If the cloud processing option is enabled and properly configured (valid email and password are input to
the Network tab of Preferences dialog) in Metashape, each time the processing operation in run in Agisoft
Cloud, a synchronization procedure will be started and the source imagery together with the project file
directory will be uploaded to your Agisoft Cloud account.

152



Distributed processing

Optionally, it is possible to upload project to Agisoft Cloud from Metashape user interface manually,
without running any processing operation.

To upload project into the cloud
1. Select Upload Project... command from Cloud submenu of the File menu.

2. Click Yes button to confirm the operation and start the upload process.
Download photos from the cloud

To download photos from the cloud
1. In Metashape user interface open the project which the photos should be downloaded for.
2. Select Download Photos... command from the Cloud submenu of the File menu.

3. Inthe Download Photos dialog specify the target folder for the images and select the images to be
downloaded from the list.

4. Click OK to start the download process.

4 Note
« Cloud processing is supported only for projects saved in Metashape Project (*.psx) format.

» All the files related to a certain project can be removed to free the disk space available for the
subscription plan from your personal account in Agisoft Cloud web interface.

« Some operations do not support processing in the cloud (for example, no of the export operations
are supported). If the Batch Processtask sent to the Cloud includes such operations, the warning
message will be displayed and the batch processing task list should be adjusted before sending
it to the Agisoft Cloud again.

Share cloud project

In Agisoft Cloud the following project sharing methods are available: share a project with alink and share
aproject viaemail. Each project by default isin private mode. When private mode is activated, only the
owner of the project has access to view project visualization in the web interface and download it via
M etashape desktop application.

To shareproject with alink

1. Click onthe Share button on the project visualization page or select Share option in the project menu
on My Projects page.

2. Inthe Share pop-up window select Anyone with the link can view option from the dropdown menu,
copy the link and close the pop-up window.

When share with a link option is activated, each person who has the link will be able to view project
visuaization in web interface without need to create an account on Agisoft Cloud.

In caseit is needed to securely share the project with a person or anumber of people, it is possibleto share
published or unpublished projects by including someone's email into the sharing list. When share viaemail
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option is activated, invited users will have access to view the project visualization in web interface and
download its copy via Metashape desktop application.

To securely share project via email

1. Click the Share button on the project visualization page or select Share option in the project menu
on My Projects page.

2. Inthe Share pop-up window select Invited people can view and download option from the dropdown
menu, insert email of the person who you want to grant the accessto the project to and click the Invite
button. Then close the pop-up window.

4 Note

« Those who have an account on Agisoft Cloud will be notified by email and granted the access
to view the project visuaization in web interface and download its copy via M etashape desktop
application.

» Those who have no account on Agisoft Cloud will be invited via email to create an account to
be able to view the project visualization in web interface and download its copy via Metashape
desktop application.

Toturn off sharing and switch the project to the private mode

1. Click Share button on the project visualization page or select Share option in the project menu on
My Projectspage.

2. Inthe Share pop-up window select Turn off sharing option in the project menu on My Projects page.
To closethe accessto the project to a certain person

1. Click the Share button on the project visualization page or select Share option in the project menu
on My Projectspage.

2. Delete email of aperson who you want the access to the project be closed to by clicking the Delete
button represented as a cross mark. Then close the pop-up window.
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Application window

General view

v Project_1.7.psx — Agisoft Metashape Professional = O *
File Edit View Workflow Model Photo Ortho  Tools Help
T r--1 .
: @ B - IR NP
Model
Petspective 30° Snap: Axis, 20
z b

painks: 106,606,518 *

I # Workspace

Reference = X
EER * O B * BEREE

Cameras East err (m) Morth err (m) Alt. err (m) Accuracy (m) 5 Shapes (3 polygons)

/B sem_1. 0150164 -0.270678 -0.025276 0050000 I +% T Points (281,176 points)

B Sem_1.. 0047400 T 00 o 050000 Depth Maps (201, High quality, Mild filtering) I
J B Sem. 1. 0022316 YR YT 050000 ii: Dense Cloud (106,606,818 points, High quality)

/B Sem_t.. 0148120 0T Btiionss o 050000 b 3D Model (1,964,999 faces, High quality)
T Properties & X
Markers East err (m) North err (m) Alt. err (m) Accuracy (m)

J | M ocPol 0013693 0005443 -0.001894 0.005000 I SR

P cpoz  0.061270 0.036841 0.053780 0.005000 Type Label Description Layer
— e cont_nntont 0000 nooas fna0snnn Polygon building 1 Buildings I

Reference  Photos

WGS 84 / UTM zone 12N (EPSG::32612) 702449.032337 X 2856510.946943Y 11.988m ..

General view of application window

Model view

Model view tab is used for displaying 3D data as well as for mesh and point cloud editing. The view of
the model depends on the current processing stage and is also controlled by mode selection buttons on
the M etashape tool bar.

Model can be shown as a dense cloud, with class indication or without, or as a mesh in shaded, solid,
wireframe or textured mode. Along with the model the results of photo alignment can be displayed. These
include tie point cloud and camera positions visualized data. Additionally tiled textured model can be
displayed and navigated in the model view.

M etashape supports the following tools for navigation in the 3D view:

Tool
Rotation Tool

Keyboard modifier
Default
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Tool Keyboard modifier
Pan Tool Ctrl key pressed
Zooming Tool Shift key pressed

All navigation tools are accessible in the navigation mode only. To enter the navigation mode click the
+ Navigation toolbar button.

Metashape offers two different navigation modes: Object navigation and Terrain navigation. Switching
between the navigation modes can be performed from the Navigation Mode submenu of the View menu.
Object navigation mode allows for 3-axis rotation control, while Terrain navigation mode restricts control
to 2-axis rotation only, z-axis being kept vertical all the time.

In Object navigation mode the rotation with mouse can be performed while left mouse button is pressed,
whereas holding right mouse button allows for model tilt. In Terrain navigation mode mouse buttons
functionality isinverted and left button is responsible for tilt, whereas right button for rotation.

[ Note

e Zooming into the model can be aso controlled by the mouse whed!.

Ortho view

Ortho view is used for the display of 2D processing results data: digital elevation model, full resolution
orthomosaic, raster transformed orthomosaic as well as shapes data. Switching between DEM and
orthomosaic can be performed using the corresponding button on the toolbar or by double-clicking on the
respective icon on the Workspace pane, providing that both products have been generated.

Orthomosaic can be displayed in the original colors or in colors according to the palette set for vegetation
index values visualization.

Additional instruments allow to draw points, polylines and polygons on the orthomosaic and/or digital
elevation model to perform point, linear, profile and volume measurements. Also polygonal shapes are
allowed to be set up as inner or outer boundaries, that will be used for the definition of the area to be
exported. Using polygonal shapes allows to create custom seamlines on the orthomosaic, which can be
useful for some projects enabling to eliminate blending artefacts.

Switching to Ortho view mode changes the contents of the Toolbar, presenting related instruments and
hiding irrelevant buttons.

Photo view

Photo view tab is used for displaying individual images as well as corresponding depth maps in semi-
transparent representation, markers, shapes and masks on them.

In the Photo view tab it is allowed to create markers, refine their projections, draw shapes and adjust
positions of shape vertices and to draw masks on the images. Additionally in Photo view tab it is possible
to display the residuals for the tie points and markers providing that the corresponding camerais aligned.

Photo view isvisible only if any image is opened. To open an image in Photo view mode double-click on
the label of the corresponding camera on the Workspace, Reference or Photos pane.

For multicamera systems which have several sensors assigned to the same layer Photo view tab will be
vertically split into corresponding number of sub-frames.
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Switching to Photo view mode changes the contents of the Toolbar, presenting related instruments and
hiding irrelevant buttons.

Workspace pane

On the Workspace pane al elements comprising the current project are displayed. These elements can
include:

 List of chunksin the project

 List of cameras and camera groups in each chunk

« List of markers and marker groups in each chunk
 List of scale barsand scale bar groupsin each chunk
o List of shape layersin each chunk

* Tiepointsin each chunk

» Componentsin each chunk

» Depth mapsin each chunk

» Dense point clouds in each chunk

* 3D modelsin each chunk

* Tiled modelsin each chunk

 Digital elevation modelsin each chunk

* Orthomosaicsin each chunk

 Panoramasin each chunk

» Cameratracksin each chunk

Buttons located on the Workspace pane toolbar allow to:

» Add chunk

Add photos
» Add marker

» Create scale bar

Enable or disable certain cameras or chunks for processing at further stages.
* Removeitems

Each element in the list is linked with the context menu providing quick access to some common
operations.

Photos pane

Photos pane displaysthelist of photos/ masks/ depth mapsin the active chunk in the form of thumbnails.
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Buttons located on the Photos pane toolbar allow to:

Enable/ disable certain cameras

Remove cameras

Rotate selected photos clockwise / counterclockwise (for display purposes only)
Reset current photo filtering option

Switch between images / masks/ depth maps thumbnails

Increase / decrease icons' size or display detailed information on photos including EXIF data

Console pane

Console paneis used for:

Displaying auxiliary information

Displaying error messages

Python commands input

Buttons located on the Console pane toolbar allow:

Savelog (in HTML, XHTML or Plain Text format)
Clear log

Execute Python script

Reference pane

Reference pane is designed for:

Displaying and editing cameraand / or marker coordinates
Displaying and editing scale bars lengths

Displaying and editing camera orientation angles
Displaying estimation errors

Displaying and editing accuracy parameters for camera/marker coordinates, camera angles and scale
bar lengths

Buttons located on the pane toolbar allow:

Import / export reference coordinates

Convert reference coordinates from one system to the other

Optimize camera alignment and update data

Switch between source coordinates, estimated coordinates, errors views and variance values

Specify the coordinate system and measurement accuracy to be assumed through Settings dialog
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Shape Properties pane

Properties pane is designed for:

 Displaying and editing labels for selected shapes

 Displaying and editing description for selected shapes

 Displaying and editing existing attribute values for selected shapes

» Adding new attributes for the selected shape

» Assigning shape layer to the selected shapes

* Editing label and style for shape layer assigned to the selected shapes
Buttons located on the pane toolbar allow:

+ Add attribute

» Remove attribute

Jobs pane

Jobs pane is designed for:

» Monitoring the processing status for active and background projects
 Organizing the background processing queue

» Switching between the projects

Buttons located on the pane toolbar allow:

 Start / pause/ cancel the selected tasks

» Change the order of the tasks in the processing queue

* Clear the processing tasks history

4 Note

< You can switch between projects by right-clicking on the project name.

Timeline pane
Timeline pane is designed for:
» Working with multi-frame chunks
Buttons located on the pane toolbar allow:
» Add/ remove frames from chunk

» Play / stop frame sequence
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Adjust frame rate through Settings dialog

Animation pane

Animation pane is designed for:

Creating anew cameratrack from pre-sets(Horizontal, Vertical) with the given number of the keyframes
Loading cameratrack from external file in supported formats (Autodesk FBX, Camera Path)
Exporting cameratrack

Playing the viewpoint camera movement according to the track

Rendering the frame sequence to the form of the separate images for the keyframes

Rendering the frame sequence to the form of the video file

Appeneding current viewpoint to the camera track

Removing keyframes from the camera track

Changing the selected keyframes positionsin current camera track sequence

Settinging the camera track parameters (label, duration, field of view, loop camera track)

Buttons located on the pane toolbar allow:

Create new track

Load camera track

Save cameratrack

Start / stop the animation according to the camera track
Capture video file

Append current viewpoint to the active camera track
Remove selected keyframes from the active cameratrack
Move selected keyframes up

Move selected keyframes down

Update selected keyframe to the current viewpoint

Change cameratrack settings

[{ Note

« To open any pane select a corresponding command from the View menu.

» Todisplay the track path, select Show animation in Show/Hide items submenu from the Model
menu.
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* You can adjust the position of the viewpoint in Model view by dragging the left mouse button
to display it visually.

Menu commands

FileMenu
EI New Creates an empty M etashape project.
Open... Opens Metashape project file.
Append... ?uefgfg r;séisti ng Metashape project file to the
H Save Saves Metashape project file.
Save As... Saves Metashape project file with a new name.
Upload Project... Uploads current project to Agisoft Cloud.

Downloads project from the list of the projects

Download Project... currently available in Agisoft Cloud.,

Downloads images from Agisoft Cloud for the

Download Photos... current project.

Export Points... Saves sparse / dense point cloud.

Export Model... Saves 3D model.

Export Tiled Modd... Saves atiled model as hierarchical tiles.

Export Orthomosaic... Exports generated orthomosaic.

Export DEM... Exports generated digital elevation model.

Generates Agisoft Metashape processing report in
PDF and HTML formats.

Exports camera positions, orientation data and tie
points measurements.

Generate Report...

Export Cameras...

Export Markers... Exports marker projections/ estimated marker

locations.
Export Reference Exports reference.
Export Masks... Exports masks.
Export Shapes... Exports shapes from the selected layers.
Export Texture... Exports model texture.

Export Panorama... Exports spherical panoramafor camera stations.

Exports orthorectified images corresponding to

Export Orthophotos... individual cameras.

Exports the images corresponding to the original

Convert Images... camera with distortion or color correction applied.

161



Graphical user interface

FileMenu
Render Photos...
Import Cameras...
Import Markers...
Import Reference

Import Masks...
Import Shapes...

Import Points...
Import Model...

Import Texture...

Import Tiled Modd...

Import DEM...

Import Orthomosaic...

Import Laser Scans

Import Video...

Upload Data...

Exit
Edit Menu

“) Undo

| Add selection

“| subtract sdlection

Invert Selection
Invert Selection
Grow Selection

Shrink Selection

Generates lenticular images for the current scene.
Imports camera positions and orientation data.
Imports marker projections.

Imports reference data.

Imports masks or creates mask from model or
background.

Imports shapes to be used for editing or
measurements.

Imports pointsin aform of the dense point cloud.
Imports polygonal mesh model.

Imports texture and appliesit to the current model.
Imports tiled model.

Imports digital elevation model.

Imports orthomosaic.

Imports laser scans data.

Imports video in aform of frame sequence and
saves the extracted frames as images.

Uploads generated products (points, textured mesh
models, tiled models, orthomosaics or digital
elevation models) to one of the supported web-
sites.

Closes the application window.

Undo the last editing operation.
Redo the previously undone editing operation.

Enable or disable snap type (Axis, Vertex, Edge,
2D snap).

Adds current selection to the mask.

Subtracts current selection from the mask.

Inverts current selection for the photo.

Inverts current selection of faces/ points/ cameras.
Grows current selection of mesh faces.

Shrinks current selection of mesh faces.
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Edit Menu

:K Delete Selection

ﬁ Crop Selection
Invert Mask

X Reset mask

ﬁL Rotate right

4
:JL- Rotate | eft

View Menu
£ 7oom In
‘=L Zoom Out

*
*2* Reset View
Capture view

L Workspace
@ Timeline
@ Animation
"37 Reference
4 Properties
Photos
] Console
i Jobs

Toolbar

Full Screen

Workflow Menu

Add Photos...

& Add Folder...

Align Photos...

Build Dense Cloud...

Removes selected faces from the mesh or selected
points from the point cloud.

Crops selected faces/ points.
Inverts mask for the current photo.
Resets mask for the current photo.
Rotates the photo clockwise.

Rotates the photo counterclockwise.

Increases magnification in the active view mode.
Decreases magnification in the active view mode.

Resets the viewport to display the complete model
or photo.

Saves screenshot of current view of the project
(Model/Ortho/Photo)

Shows or hides Workspace pane.
Shows or hides Timeline pane.
Shows or hides Animation pane.
Shows or hides Reference pane.
Shows or hides shape Properties pane.
Shows or hides Photos pane.

Shows or hides Console pane.

Shows or hides Jobs pane.

Shows or hides Toolbar.

Switches to or from Full Screen mode.

L oads additional photos to be processed by
Metashape.

L oads additional photos from foldersto be
processed by Metashape.

Estimates camera positions and tie point cloud.

Generates dense point cloud.
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Workflow Menu
Build Mesh...
Build Texture...
Build Tiled Modé...
Build DEM...
Build Orthomosaic...
Build Panorama...
Align Chunks...
Merge Chunks...

Batch Process...

Model Menu

¥¥' Navigation

L Rectangle Selection
{_? Circle Selection

':_i Free-form Selection
Gradual selection...

¥ Draw Point
A Draw Polyline

"/ Draw Polygon

& Ruler

& Move Object

ﬁc" Rotate Object

-i.': Scale Object
Reset Transform

F‘:nﬂ Update Transform

% Move Region

@ Rotate Region

Resize Region

Generates polygonal mesh model.

Generates texture map for the mesh model.
Generates tiled textured model.

Generates digital elevation model.

Generates orthomosaic.

Generates panorama.

Aligns multiple chunks.

Merges multiple chunks into the single chunk.

Opens Batch Process dialog box.

Switches to navigation mode.

Rectangle selection tool for the elements of the
Model view.

Circle selection tool for the elements of the Model
view.

Free-form selection tool for the elements of the
Model view.

Selects faces / points based on the specified
criterion.

Switches to the 3D point drawing tool.
Switches to the 3D polyline drawing tool.
Switches to the 3D polygon drawing tool.

Switches to 3D coordinate and linear distance
measurement tool.

Switches to object movement tool.

Switches to object rotation tool.

Switches to object scaling tool.

Resets the transformations applied to the object.
Update the transformations to the object.
Switches to volume movement tool.

Switches to volume rotation tool.

Switches to volume resize tool.
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Model Menu

Reset Region

. Show Basemap

82 show Cameras

Show Thumbnails
= show Shapes
”Q‘_' Show Markers
ED Show Labels

Show Images
D Lock Image

Show Region
ER Show Animation
Show Trackball

'@' Show Info

D Show Grid

= Show Aligned Chunks

Show All
Hide All

oo X
oo Point Cloud

23 Point Cloud Variance

.

oon Dense Cloud

=

a5 Dense Cloud Confidence

#1 Dense Cloud Classes

4> Model Shaded

4> Moddl Solid

<l> Mode Wireframe

Resets the transformations applied to the volume to
default.

Displays or hides Basemap.
Displays or hides camera positions estimated
during image alignment.

Displays or hides image thumbnailsin the camera
placeholders.

Displays or hides shapes.

Displays or hides marker positions.

Displays or hides item labels.

Switches stereographic image overlay mode on/

off.

Locks current image in stereographic image
overlay mode.

Displays or hides region selector.
Displays or hides animation track.
Displays or hides the trackball.

Displays or hides the auxiliary on-screen
information.

Displays or hides the grid.

Displays all enabled aligned chunks in project
workspace.

Displays all elements at the sametime.

Hides all elements.

Displaystie point cloud reconstructed during photo
alignment.

Displaystie point cloud colored by variance.
Displays dense point cloud.
Displays dense point cloud colored according to

the confidence values.

Displays dense point cloud colored according to
the point classes.

Displays 3D model in the shaded mode with
vertices colored with interpolated colors.

Displays 3D modél in the solid mode.

Displays 3D model in the wireframe mode.
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Model Menu

{»' Model Confidence

J’ Model Textured

K Tiled Model Textured

¥ Tiled Model Solid

k13 Tiled Mode! Wireframe
% DEM
Orthomosaic
Diffuse Map
Norma Map
Occlusion Map

Perspective/Orthographic
Stereo Mode

Predefined views

Navigation Mode

Photo Menu

“I Navigation

L Rectangle Selection

o Intelligent Scissors
% Intelligent Paint

N Magic Wand

¥ Draw Point

A Draw Polyline

"/ Draw Polygon

& Ruler

Displays 3D model with vertices colored according
to the confidence values.

Displays 3D model in the textured mode.
Displays tiled model with applied texture.

Displaystiled model without texture in the solid
model.

Displaystiled model in the wireframe mode.
Displays digital elevation model.

Displays orthomosaic.

Displays diffuse map for the textured mode.
Displays normal map for the textured mode.
Displays occlusion map for the textured mode.

Switches visualization view between Perspective
and Orthographic.

Enables or disables stereo view mode according to
the parameters specified in Preferences dialog.

Switches viewport to one of the predefined views.

Switches between Object and Terrain navigation
modes for the Model view window. Object
navigation mode allows for 3-axis rotation control,
while Terrain navigation mode restricts control to
2-axisrotation only, z-axis being kept vertical all
thetime.

Switches to navigation mode.

Rectangle selection tool.

Intelligent Scissors selection tool.
Intelligent Paint selection tool.

Magic Wand selection tool.

Switches to the 3D point drawing tool.
Switches to the 3D polyline drawing tool.
Switches to the 3D polygon drawing tool.

Switches to 3D coordinate and linear distance
measurement tool.
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Photo Menu
Open Next Photo

Open Previous Photo
Go To Next Marker
Go To Previous Marker

Show Masks
™ show Depth Maps
Show Intensity
2 Show Shapes
% show Markers
Show Marker Residuals
E0 Show Labels

oo X
oo Show Points

Show Point Residuals
Show All

Hide All

OrthoMenu
¥%' Navigation

r=1
i -1 Rectangle Selection

LAY
1

"._ Circle Selection

';_i Free-form Selection

*" Draw Point

A Draw Polyline

'_/ Draw Polygon

2 Draw Patch
= Draw Rectangle

& Ruler

Opens next photo from the list in the Photos pane.

Opens previous photo from the list in the Photos
pane.

Zooms to the next marker projection on the opened
photo.

Zooms to the previous marker projection on the
opened photo.

Turns mask shading on or off.
Displays or hides the depth maps overlay.

Displays or hides intensity map overlay for the
laser scans.

Displays or hides shapes.

Displays or hides markers.

Displays or hides the residuals of each marker.
Displays or hides item labels.

Displays or hides tie point projections used for the
camera alignment.

Displays or hides the residuals of each point.
Displays all elements at the same time.

Hides all elements.

Switches to navigation mode.

Rectangle selection tool for the elements of the
Ortho view.

Circle selection tool for the elements of the Ortho
view.

Free-form selection tool for the elements of the
Ortho view.

Switches to the 2D point drawing tool.
Switches to the 2D polyline drawing tool.
Switches to the 2D polygon drawing tool.
Switches to the patch drawing tool.
Switches to the 2D rectangle drawing tool.

Switches to coordinate and linear distance
measurement tool.
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Ortho Menu

. Show Basemap
=]

=] Show Seamlines

82 show Cameras

% show Markers
2 Show Shapes
L Show Labels
Show All
Hide All
 DEM
Orthomosaic
] Hitishading

ToolsMenu
Detect Markers...
Detect Fiducials...
Print Markers...

Track Markers...
Attach Markers
Refine Markers
Build Point Cloud...

Thin Point Cloud...
View Matches...

Sample points...

Filter Dense Cloud...

Displays or hides basemap (map and satellite).
Displays or hides orthomosaic seamlines.

Displays or hides camera positions according
to the estimated location for aligned cameras or
reference coordinates for not aligned cameras.

Displays or hides marker positions.
Displays or hides shapes.

Displays or hides item labels.
Displays all elements at the sametime.
Hides all elements.

Switches to the digital elevation model display
mode.

Switches to the orthomosaic display mode.

Enables or disables hillshading mode of digital
elevation mode visualization.

Creates markers from coded targets on photos.
Detects fiducia marks on the images.
Generates printable PDF file with coded targets.

Tracks marker locations across the frame
sequence.

Enables or disables the mode where every newly
drawn shape has markers attached to its vertices.

Enables or disables automatic marker projection
refinement based on the image content.

Builds tie point cloud based on the estimated
camera parameters available.

Thinstie point cloud by reducing the number of
projections on the individual photosto the given
limit.

Displays View Matches dialog for visual
representation of the common tie points between
the image pairs.

Re-build a dense cloud based on a built model
(mesh or tiled mode).

Decimates the dense point cloud according to the
user-defined point spacing distance.

168



Graphical user interface

ToolsMenu

Colorize Dense Cloud...

Invert Point Normals...

Classify Ground Points...

Classify Paints...

Assign Class...

Reset Classification...

Select Points by Masks...
Select Points by Color...

Select Points by Shapes...

Filter By Class
Filter By Confidence
Filter By Selection

Reset Filter

Compact Dense Cloud...

Restore Dense Cloud...
Update Dense Cloud...

Refine Mesh...
Decimate Mesh...
Smooth Mesh...
Close Holes...

Colorize Vertices...

Resize texture...
Remove Lighting...

Generate masks...

Applies colors to the dense cloud points basing on
source images or orthomosaic.

Inverts normals for the selected points of the dense
cloud.

Classifies dense point cloud based on the user
defined settings.

Automatically classifies dense point cloud to the
supported classes.

Assigns classto the selected points.

Resets assigned classes for the selected point
classes.

Selects dense cloud points according to the masks
of the selected images.

Selects dense cloud points according to the color
and tolerance.

Selects dense cloud points according to the
selected shapes.

Filters the points in the dense cloud according to
the selected classes.

Filters the points in the dense cloud according to
the calculated confidence value.

Filters the points in the dense cloud according to
the selected points.

Resets all applied dense cloud filters.
Permanently removes all deleted points from the
dense cloud.

Restores all deleted points of the dense cloud that
were once marked as removed.

Updates statistics of the dense cloud, including
point numbers and assigned classes.

Starts photoconsistent mesh refinement operation.
Decimates mesh to the target face count.
Smooths mesh.

Closes holes on the model surface.

Applies colors to the mesh vertices basing on
source images, orthomosaic or point cloud.

Starts resize texture operation for mesh.
Starts the delighting operation for mesh texture.

Starts generate masks based on the built mesh.
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ToolsMenu
View Mesh Statistics...

View Mesh UVs...

Measure Area and Volume...

Filter By Selection

Reset Filter
Transform DEM...
By -
% E Update Orthomosaic
Reset Orthomosaic
X Remove Orthophotos
Generate Seamlines

Generate Prescription Map

Cdlibrate Lens...
Show Chesshoard...
82 Camera Calibration...

& Optimize Cameras...

Cdlibrate Reflectance...
Calibrate Colors...

Set Primary Channdl...

& s Brightness...
& Set Raster Transform...

Generate Contours...

Plan Mission...

Collects and displays mesh statistics.
Displays mesh UV mapping.
Displays surface area and volume of the polygonal

model.

Filters the faces of the polygonal model according
to the selected points.

Resets all applied mesh filters.

Displays digital elevation model transformation
dialog.

Applies all the manual edits to the orthomosaic.

Resets all applied edits to default orthomosaic
stitching.

Removes individually orthorectified images from
the project contents.

Creates the shape layer with the polygonal shapes
as copies of the orthomosaic patches.

Creates the shape layer with the prescription map
information based on the orthomosaic index.

Displays lens calibration dial og.
Displays the calibration board on screen.
Displays camera calibration dialog box.

Starts the optimization of exterior and interior
parameters of the aligned cameras.

Displays reflectance calibration dialog for precise
radiometric calibration of multispectral data based
on reflectance pandl and sun sensor data.

Displays the color correction dialog for the
brightness and white balance compensation of the
images.

Displays the primary channel selection dialog.

Adjustsimage brightness and contrast for more
convenient display.

Displays Raster Calculator dialog for NDVI and
other vegetation indices calculation.

Generates contours based on DEM according
to the elevation levels or based on Orthomosaic
according to the vegetation index values.

Creates mission plan based on available mesh
model.
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ToolsMenu

Reduce Overlap...

Detect Powerlines

Survey Statigtics...
4% Run Script...
"% Preferences...
Help Menu

“%” Contents

Check for Updates...

Activate Product...

]

& About Metashape...

Toolbar buttons

General commands
D New
Open

HSave

3D view commands
“) Undo
™ Redo

¥%' Navigation

r=1

i -1 Rectangle Selection

..+ Circle Selection

';_ﬂ Free-Form Selection

Reset Selection

Reduces the number of enabled camerasin the
active project to optimize the coverage in case of
excessive overlap.

Starts image based powerlines detection operation.

Displays the survey statistics dialog in aform of
interactive report.

Displays Run Script dialog box for Python script
execution.

Displays preferences dialog box.

Displays help contents.

Checks if Metashape update is available for
download.

Displays the activation dialog for activation /
deactivation of the product using the activation key
or borrowing / returning borrowed floating license
to the license server.

Displays program information, version number and
copyright.

Creates anew Metashape project file.
Opens a Metashape project file.

Saves a Metashape project file.

Undo the last editing operation.

Redo the previously undone editing operation.
Navigation tool.

Rectangle selection toal.

Circle selection tool.

Free-form selection tool.

Resets current selection.

171



Graphical user interface

3D view commands
L3y overegion
Resize region
62’ Rotate Region
Reset Region
& Move Object
@b Rotate Object
i.': Scale Object
Reset Transform
EE Update Transform
s Draw Point
A Draw Polyline

=

"/ Draw Polygon

6& Ruler

>< Delete Selection

ﬁ Crop Selection

3D view settings
#, Zoom In

=L Zoom Out
"2 Reset View

oo .
oo Point Cloud

ES Point Cloud Variance

.

oot Dense Cloud

o

ooa Dense Cloud Confidence
#1 Dense Cloud Classes
4> Model Shaded

4> Modd Solid

<[> Mode Wireframe

Volume tranglation tool.

Volume resize tool.

Volume rotation tool.

Resets region according to the actual point cloud.
Model trandation tool.

Model rotation tool.

Model resize tool.

Resets all transformations applied to the model.
Update transformations parameters for the model.
Switches to the 3D point drawing tool.

Switches to the 3D polyline drawing tool.
Switches to the 3D polygon drawing tool.

3D coordinate and linear distance measurement
tool.

Removes selected faces / points.

Crops selected faces/ points.

Increases magnification.
Decreases magnification.
Resets model view.

Displaystie point cloud reconstructed during
image alignment.

Displaystie point cloud colored by variance.
Displays dense point cloud model.

Displays dense point cloud colored according to
the confidence values.

Displays dense point cloud colored according to
the point classes.

Displays 3D modé in the shaded mode with
vertices colored with interpolated colors.

Displays 3D model in the solid mode.

Displays 3D mode in the wireframe mode.
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3D view settings

{»' Model Confidence

< Model Textured
Diffuse Map
Norma Map
Occlusion Map

Tiled Model Textured

%% Tiled Model Solid

Tiled Model Wireframe
% show DEM

Show Orthomosaic

@ Show Basemap

82 show Cameras
Show Thumbnails

% show Shapes
"37 Show Markers

Show Images

D Lock Images

£ Show Aligned Chunks

Photo view commands
“J Undo

™ Redo

¥ Navigation

Ll Rectangle Selection

¢« Intelligent Scissors
% Intelligent Paint

S Magic Wand

Displays 3D model with vertices colored according
to the confidence values.

Displays 3D model in the textured mode.
Displays diffuse map for the textured mode.
Displays normal map for the textured mode.
Displays occlusion map the textured mode.
Displaystiled model with the applied texture.
Displaystiled model in the solid mode.
Displaystiled model in the wireframe mode.
Displays digital elevation model.

Displays orthomosaic.

Displays or hides basemap.

Displays or hides camera positions, reconstructed
during image alignment.

Displays or hides image thumbnailsin the camera
placeholders.

Displays or hides 3D shapes.

Displays or hides positions of markers placed on
the model.

Displays or hides stereographic image overlay.

Locks current image in stereographic image
overlay mode.

Displays or hides enabled aligned chunks.

Undo the last mask editing operation.

Redo the previously undone mask editing
operation.

Switches to the navigation mode.
Rectangle selection toal.
Intelligent scissorstool.
Intelligent paint tool.

Magic wand toal.
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Photo view commands
M agic Wand Options
Reset Selection
?" Draw Point

A Draw Polyline

o

'_/ Draw Polygon

& Ruler

“../ Add Selection

..... Subtract Selection

Invert Selection

& s Brightness

2 Rotate Right

JE Rotate L eft

%, Zoom In

=L Zoom Out

"3 Reset View
Show Masks

™ show Depth Maps
Show Intensity

2 Show Shapes
% show Markers

Show Marker Residuals

oo X
oo Show Points

Show Point Residuals

Ortho view commands

¥ Navigation

r=1

L. Rectangle Selection

Changing the parameters of the magic wand.
Resets current selection.

Switches to the 3D point drawing tool.
Switches to the 3D polyline drawing tool.
Switches to the 3D polygon drawing tool.

3D coordinate and linear distance measurement
tool.

Adds current selection to the mask.
Subtracts current selection from the mask.
Inverts current selection.

Adjustsimage brightness and contrast for more
convenient display.

Rotates the image clockwise.

Rotates the image counterclockwise.

Increases magnification.

Decreases magnification.

Resets the viewport to display the whole image.
Enables or disables the mask shading overlay.

Enables or disables the depth map overlay of the
selected level.

Displays or hides intensity map overlay for laser
scans.

Displays or hides shapes on the current image.
Displays or hides marker projections.

Displays or hides residuals related to marker
projections.

Displays or hides tie point projections.

Displays or hides residuals related to tie point
projections.

Switches to the navigation mode.

Rectangle selection toal.
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Ortho view commands

..+ Circle Selection

[_ﬂ Free-Form Selection

Reset Selection
s Draw Point
A Draw Polyline
@ Draw Polygon
&) Draw Patch

= Draw Rectangle

6‘9 Ruler
% DEM
[ Hij shading

Orthomosaic

v Set Brightness

% Set Raster Transform

EE Update Orthomosaic

%, Zoom In

=, Zoom Out

*34 Reset View

@ Show Basemap

=]
=] Show Seamlines

82 show Cameras

|]ﬂ:' Show Markers

= show Shapes

Circle selection tool.

Free-form selection tool.

Resets current selection.

Switches to the point drawing tool.
Switches to the polyline drawing tool.
Switches to the polygon drawing tool.
Switches to the patch drawing tool.

Switches to the rectangle drawing tool in Ortho
view.
2D linear distance measurement tool.

Switches to the digital elevation model display
mode.

Enables or disables hillshading mode of digital
elevation mode visualization.

Switches to the orthomosaic display mode.

Adjustsimage brightness and contrast for more
convenient display.

Displays Raster Calculator dialog for NDVI and
other vegetation indices calculation.

Applies al the manual edits to the orthomosaic.

Increases the magnification of theimagein the
Ortho view.

Decreases the magnification of theimagein the
Ortho view.

Resets the viewport to display the complete
orthomosaic or DEM.

Displays or hides basemap in aform of satellite or
vector map.

Displays or hides orthomosaic seamlines.

Displays or hides camera positions according
to the estimated location for aligned cameras or
reference coordinates for not aligned cameras.

Displays or hides marker positions.

Displays or hides shapes.
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Hot keys

For convenient operation in the Metashapeit is possible to use Hot keys. Below isalist of default hot keys
that can be customized in the Preferences dialog. Select the Customize button at the Shortcuts menu item.

General
Create new project Ctrl +N
Save project Ctrl +S
Open project Ctrl +O
Run Script Ctrl +R
Full Screen F11
Model View

Undo (only for Delete, Assign Class/ Classify Ctrl +Z
Ground Points,Masking and Close Holes

operations)

Redo (only for Delete, Assign Class/ Classify Ctrl +Y
Ground Points,Masking and Close Holes

operations)

Switch between navigation and any other Space
previously selected mode

Zoom In Ctrl + +
Zoom Out Ctrl + -
Reset view 0
Switch to stereoview mode 9
Switch between orthographic and perspective view 5
modes

Change the angle for perspective view Ctrl + mouse wheel
Assign dense cloud class (only if some pointsare  Ctrl + Shift + C
selected)

Predefined Views

Top 7
Bottom Ctrl +7
Right 3

Left Ctrl +3
Front 1

Back Ctrl +1
Rotate View

Rotate Up

Rotate Down 2
Rotate L eft
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Rotate View

Rotate Right 6
Photo View

Next photo (according to Photos pane order) Page Up

Previous photo (according to Photos pane order)  Page Down

Go to the next marker on the same photo Tab

Go to the previous marker on the same photo Shift + Tab

Navigation mode \%

Selection Tools

Rectangle selection M

Intelligent scissors L

Intelligent paint P

Magic wand wW

Add selection Ctrl + Shift + A
Subtract selection Ctrl + Shift+S
Invert selection Ctrl + Shift + |
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Images

Input formats

JPG

TIFF

PNG

BMP

OpenEXR

JPEG 2000

JPEG XL

TARGA

Digital Negative (DNG)
Portable Bit Map (PGM, PPM)
Multi-Picture Object (MPO)
Norpix Sequence (SEQ)
AscTec Thermal Images (ARA)

Camera calibration

Import formats

Agisoft Camera Calibration (*.xml)
Australis Camera Parameters (*.txt)
Australisv.7 Camera Parameters (*.txt)
PhotoModeler Camera Calibration (*.ini)
3DM CadibCam Camera Parameters (* .txt)
Ca Cam Camera Calibration (*.cal)
Inpho Camera Calibration (*.txt)

USGS Camera Calibration (*.txt)

Pix4D Camera Calibration (*.cam)
OpenCV Camera Calibration (*.xml)
Photomod Camera Calibration (* .x-cam)
Z/| Distortion Grid (*.dat)

Camera flight log

Input for mat
Agisoft XML (*xml)

Appendix B. Supported formats

Undistort formats
JPG

TIFF

PNG

BMP

OpenEXR

JPEG 2000

JPEG XL

Export formats

Agisoft Camera Calibration (*.xml)
Australis Camera Parameters (*.txt)
Australisv.7 Camera Parameters (*.txt)
PhotoModeler Camera Calibration (*.ini)
3DM CadibCam Camera Parameters (* .txt)
CaCam Camera Calibration (*.cal)
Inpho Camera Calibration (*.txt)

USGS Camera Calibration (*.txt)

Pix4D Camera Calibration (*.cam)
OpenCV Camera Calibration (*.xml)
Photomod Camera Calibration (* .x-cam)
Z/| Distortion Grid (*.dat)

Estimated positions
Agisoft XML (*xml)
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Supported formats

GCP

Input format

Character-separated values (*.txt, *.csv)

EXIF meta data

MAVinci CSV (*.cov)
APM/PixHawk Log (*.log)
C-Astral Bramor log (*.log)
TopoAxistelemetry (*.tel)

locations

Input for mat

Character-separated values (*.txt, *.csv)

Agisoft XML (*.xml)

Estimated positions
Character-separated values (* .txt)

Estimated positions
Character-separated values (* .txt)
Agisoft XML (*.xml)

Interior and exterior camera orientation
parameters

Import camera positions
Agisoft XML (*.xml)

Autodesk FBX (*.fbx)

Alembic (*.abc)

Realviz RZML (*.rzml)

Bundler (*.out)

Inpho Project File (*.prj)

BINGO (*.dat)

Blocks Exchange (*.xml)
N-View Match (*.nvm)

PATB Camera Orientation (*.ori)
VisionMap Detailed Report (*.txt)

Tie points

Import tie points
Bundler (*.out)

Export camera positions

Agisoft XML (*.xml)

Autodesk FBX (*.fbx)

Alembic (*.abc)

Realviz RZML (*.rzml)

Bundler (*.out)

Inpho Project File (*.prj)

BINGO Project (*.dat)

Blocks Exchange (*.xml)

N-View Match (*.nvm)

PATB Project (*.pro)

Boujou (*.txt)

Maya ASCII (*.ma)

CHAN files (*.chan)

ORIMA (*.txt)

AeroSys Exterior Orientation (*.orn)
Summit Evolution Project (*.smtxml)
Omega Phi Kappa (*.txt)

Export tie points
Bundler (*.out)
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Supported formats

Import tie points

Import formats
Wavefront OBJ (*.obj)
Stanford PLY (*.ply)
ASCII PTS (*.pts)
ASPRSLAS (*.las)
LAZ (*.l1az)

ASTM E57 (*.e57)
Point Cloud Data (*.pcd)
PTX format (*.ptx)

Mesh model

Import mesh

Wavefront OBJ (*.obj)
3DS models (*.3ds)
COLLADA (*.dee)
Stanford PLY (*.ply)
Alembic (*.abc)

STL models (*.stl)
OpenCTM models (*.ctm)
Universal 3D models (*.u3d)
Autodesk FBX (*.fbx)
Autodesk DXF (*.dxf)

Sparse/dense point cloud

Export tie points

BINGO (*.dat)

ORIMA (*.txt)

PATB (*.ptb)

Summit Evolution Project (*.smtxml)
Blocks Exchange (*.xml)

Export formats
Wavefront OBJ (*.obj)
Stanford PLY (*.ply)
ASCII PTS (*.pts)
ASPRSLAS (*.las)
LAZ (*.laz)

ASTM E57 (*.e57)
Point Cloud Data (*.pcd)
XYZ Point Cloud (*.txt)
Cesium 3D Tiles (*.zip)
Scene Layer Package (*.9lpk)
Universal 3D (*.u3d)
Autodesk DXF (*.dxf)
potree (*.zip)

Agisoft OC3 (*.oc3)
Topcon CL3 (*.cl3)
Adobe 3D PDF (*.pdf)

Export mesh

Wavefront OBJ (*.obj)

3DS models (*.3ds)
COLLADA (*.dege)

Stanford PLY (*.ply)
Alembic (*.abc)

STL models (*.stl)

VRML models (*.wrl)
Universal 3D models (*.u3d)
Autodesk FBX (*.fbx)
Autodesk DXF Polyline (*.dxf)
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Supported formats

Import mesh

Texture maps

Import texture

JPG

TIFF

PNG

BMP

TARGA

JPEG 2000
OpenEXR

Portable Bit Map
Digital negative
Multi-Picture Object
Norpix Sequence File
AscTec Thermal Images

Orthomosaic

Import orthomosaic

GeoTIFF Raster Data (* .tif)
GeoPackage (*.gpkg)

Google Earth KML/KMZ (* .kmz)
MBTiles (*.mbtiles)

Tiled Map Service Tiles (*.zip)

Export mesh

Autodesk DXF 3DFace (*.dxf)
Binary gITF (*.glb)

X3D models (*.x3d)
OpenSceneGraph Binary (*.osgb)
OpenSceneGraph Text (*.osgt)
Google Earth KMZ (*.kmz)
LandXML (*.xml)

Adobe PDF (*.pdf)

Export texture
JPG

TIFF

PNG

BMP

TARGA

JPEG 2000
OpenEXR

Export orthomosaic
GeoTIFF Raster Data (* .tif)
GeoPackage (*.gpkg)

Google Earth KML/KMZ (* .kmz)
MBTiles (*.mbtiles)

Tiled Map Service Tiles (*.zip)
Google Map Tiles (*.zip)
World Wind Tiles (*.zip)

JPG

JPEG 2000 (.jp2)

JPG XL

PNG

BMP
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Supported formats

Digital elevation model (DSM/DTM)

Import DEM Export DEM

GeoTIFF elevation (*.tif) GeoTIFF elevation (*.tif)
Arc/Info ASCII Grid (*.asc)
Band interleaved file format (*.bil)
XYZ (*.xyz)
GeoPackage (*.gpkg)
Sputnik KMZ (*.kmz)
Google Map Tiles (*.zip)
MBTiles (*.mbtiles)
World Wind Tiles (*.zip)
Tile Map Service Tiles (*.zip)

Tiled models

Import tiled model Export tiled model

Agisoft Tiled Modd (*.tls) Agisoft Tiled Moddl (*.tls)
Agisoft Tile Archive (*.zip)
Cesium 3D Tiles (*.zip)
Scene Layer Package (*.slpk)
PhotoMesh Layer (*.zip)
OpenSceneGraph Binary (*.zip)
OpenSceneGraph Text (*.zip)

Laser Scans

Import laser scans

ASTM E57 (*.e57)

PTX (*.ptx)

Dynamic Depth images (*.jpg, *.jpeg)

Shapes and contours

Import shapes Export shapes/contours
Shape Files (*.shp) Shape Files (*.shp)

DXF Files (*.dxf) DXF Files (*.dxf)

KML files (*.kml) KML Files (*.kml)

KMZ files (* .kmz) KMZ Files (*.kmz)
GeoJSON files (*.geojson) GeoJSON files (*.geojson)
GeoPackage files (*.gpkg) GeoPackage files (*.gpkg)
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Supported formats

Import shapes
Survey Points (*.txt)

Video

Import video
AVI (*.avi)

Flash video (*.flv)
MOV (*.mov)
MPEG-4 (*.mp4)
WMV (*.wmv)

Export shapes/contours
Survey Points (*.txt)

Export video
AVI (*.avi)
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Appendix C. Camera models

Agisoft Metashape supports several parametric lensdistortion models. Specific model which approximates
best a real distortion field must be selected before processing. All models assume a central projection
camera. Non-linear distortions are modeled using Brown's distortion model.

A cameramodel specifiesthe transformation from point coordinatesin the local camera coordinate system
to the pixel coordinatesin the image frame.

Thelocal camera coordinate system has origin at the camera projection center. The Z axis points towards
the viewing direction, X axis pointsto theright, Y axis points down.

The image coordinate system has origin in the middle of the top-left pixel (with coordinates (0.5, 0.5)).
The X axisin the image coordinate system points to theright, Y axis points down. Image coordinates are
measured in pixels.

.Ymmgra
i
—
Z camera
Ymmera
.)(mmrgg
erm:ug:-a

Ifr‘magg

Image and camera coordinate systems

Equations used to project a points in the local camera coordinate system to the image plane are provided
below for each supported camera model.

The following definitions are used in the equations:

(X,Y, Z) - point coordinatesin the local camera coordinate system,

(u, v) - projected point coordinates in the image coordinate system (in pixels),
f - focal length (in pixels),

Cx, Cy - principal point offset (in pixels),
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Cameramodels

K1, Ko, K3, Ky4 - radial distortion coefficients (dimensionless),
Py, P, - tangential distortion coefficients (dimensionless),
B, B> - affinity and non-orthogonality (skew) coefficients (in pixels),

w, h - image width and height (in pixels).

Frame cameras

X=Xz

y=Y/Z

r = sqrt(x + y?)

X' = X(L+ Kqr? + Kor® + Kar® + Kar®) + (P(r2+2x) + 2Pxxy)
Y =YL+ Kar?+ Kor + Kar® + Kar®) + (Por*+2y%) + 2Pyxy)
u=w*05+¢c+xf+xB1+yB>

v=h*05+c, +yf

Fisheye cameras

Xo=X1Z

Yo=Y /Z

o = SArt(xo” + Yo’)

X=Xg* tan'lrol ro

y=Yo* tan'ro/ 1o

r = sgrt(x? + y?)

X' = X(1 + Kqr? + Kor* + Kar® + Kar®) + (P1(r2+2x%) + 2P,xy)
Y' =YL+ Kar? + Kor* + Kar® + Kar®) + (Po(r+2y?) + 2P1xy)
u=w*05+c+xT+xB;+yB>y

v=h*05+c, +yf

Spherical cameras (equirectangular projection)

u=w* 05+f* tan(X / Z)
v=h*05+f* tan’ (Y / sort(X? + Z?))
where:

f=w/(2* pi)
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Cameramodels

4 Note

» Spherica (equirectangular) camera model doesn't support distortions. All distortions should be
corrected before loading images in Metashape.

* In case you are capturing panoramas with a rotated frame/fisheye camera, we recommend to
process original images in Metashape using camera station function instead of stitching them in
external software.

Spherical cameras (cylindrical projection)
u=w* 05+f* tan’{(X / Z)
v=h*05+f*Y/syt(X?+Z?
where:
f=w/(2* pi)
4 Note

» Spherica (cylindrical) camera model doesn't support distortions. All distortions should be
corrected before loading images in Metashape.

* In case you are capturing panoramas with a rotated frame/fisheye camera, we recommend to
process original images in Metashape using camera station function instead of stitching them in
external software.
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Appendix D. What do some error
messages in Metashape mean?

In some caseswarning or error messages may be displayed after unexpected termination of the processing
operation in Metashape. Below isthelist of some messageswhich could be encountered and our comments
on the possible origins of the issue together with the recommendations for resolving the problem.

Empty extent - Bounding box ismisplaced during Build Tiled Model or Build Orthomosaic operation
and doesn't contain any information or all the cameras for the related area are disabled.

Empty camera list - no cameras are pointing to the area of the orthomosaic generation.

Empty frame path - the selected operation (for example, import DEM) requires the project to be
saved in PSX format.

Empty surface - Bounding box is misplaced during Build Mesh operation and doesn't contain any
information.

Index Overflow - usually such amessage is observed when the Arbitrary mesh generation method is
used based on avery big dense point cloud. To reduce the number of points you can use Filter Dense
Cloud option in the Tools menu or shrink the bounding box to the smaller volume using Resize Region
instruments in the Model view mode.

Null dense point cloud - missing dense cloud for the operation based on it (like mesh generation or
classification).

Null model - missing mesh model for the operation based on it (like mesh decimation).

Null point cloud - missing sparse cloud for the operation based on it (like mesh generation).

Media resource couldn't beresolved - indicates that some video codecs are missing in the system,
SO we can suggest to install "K-lite Codec pack” or similar in order to guarantee the Import Video
operation. Note that you do not need to install any auxiliary utilities in addition to the codecs
themselves.

Some photos failed to align - the message indicates that some images were not aligned as a result
of the adjustment process. This may be due to poor image quality or insufficient overlap. We can
recommend you try to select images in the Workspace pane and select Align Selected Cameras
command from the context menu.

Zero resolution - Bounding box is misplaced prior to the Build Dense Cloud operation and doesn't
contain any information (almost no tie points are present in the bounding box and therefore no depth
maps can be generated).
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