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 08
Explicação

O que faremos nesse curso?

Esse é o curso de Photoshop: Introdução criando páginas da web. Nosso objetivo é utilizar ferramentas básicas para criar

uma One Page App, que é uma aplicação web de apenas uma página. Esse tipo de site é utilizado para expor produtos e

alguns exemplos são os site da Casa do Código (https://www.casadocodigo.com.br/), Alura (https://www.alura.com.br/),

Caelum (https://www.caelum.com.br/) e Medium (https://medium.com/).

Nesse curso aprenderemos ferramentas de:

seleção;

marcação;

preenchimento;

Aprenderemos, ainda, sobre tratamento de imagens, boas práticas para web e métodos de organização do projeto. É um

curso voltado, especi�camente, para Web Design.

Esse curso é ideal para quem nunca abriu o Photoshop, nunca encostou no programa! O objetivo é aprender do zero a

criação de páginas para web!

Nossa motivação é o Brie�ng que recebemos de um cliente - material disponível nos exercícios - através de um e-mail ele

pede um site moderno e descolado!

Gostando desse curso a continuação está no Módulo2: Photoshop para web II

(https://cursos.alura.com.br/course/photoshop-2)

Creative Cloud, Adobe e Photoshop

Primeiro, é preciso instalar o Photoshop. Esse so�ware faz parte da nuvem de serviços da Adobe, a Adobe Creative Cloud,

que inclui diversos programas em uma única assinatura.

Para adquirir o so�ware acessamos o site da Adobe (www.adobe.com.br) e criamos uma conta nele. Clicando em "Entrar",

abrirá uma nova janela com a opção de criar uma conta, acessamos ela, preenchemos o formulário da imagem abaixo,

aceitamos os termos de uso e clicamos no botão "Inscreva-se"!

https://www.casadocodigo.com.br/
https://www.alura.com.br/
https://www.caelum.com.br/
https://medium.com/
https://cursos.alura.com.br/course/photoshop-2
https://cursos.alura.com.br/course/photoshop-web-1/task/www.adobe.com.br
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Falta realizar o download do so�ware. Para isso clique na opção "Menu" que aparece no topo da página e ela abrirá uma nova

janela com as opções de programas que podem ser baixados:

Como nós desejamos realizar o download do Photoshop, basta clicarmos em cima de seu ícone e abrirá uma nova página:
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Nessa página existem duas opções de como realizar o download: "Comprar agora" ou "Versão de serviço gratuita". Essa

segunda opção só serve para quem criou a conta pela primeira vez e a Adobe concede um período de 30 dias de uso gratuito

para avaliar o so�ware. Nós optaremos pela segunda opção! Abrirá o seguinte:

Nessa janela somos questionados sobre nosso nível de conhecimento, vamos preencher como "Iniciante" e na sequência

selecionamos o botão "Entrar", pois acabamos criando nossa conta, mas ainda não acessamos ela. A próxima janela que abre

pedirá nosso login. Preenchendo com o login e dando um "Ok" ele fará o download do arquivo! Poderemos encontrar esse

arquivo, facilmente, na pasta Downloads. Um detalhe: como usamos a Creative Cloud não baixamos apenas o aplicativo, mas

sim a nuvem inteira! Ou seja, temos um gerenciador dos so�wares. Dessa maneira, mesmo desejando apenas o Photoshop,

teremos o acesso aos demais aplicativos! Clicando duas vezes no arquivo da Creative Cloud teremos o seguinte:
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Basta clicar duas vezes na caixinha vermelha que a instalação da Creative Cloud ocorrerá, feito isso, poderemos instalar o

Photoshop. Logo abrirá uma janela pedindo nome de usuário e senha e completando isso a instalação do Creative Cloud será

�nalizada. Abrirá uma janela onde, novamente, teremos que introduzir nosso e-mail e senha. Por �m, selecionamos a opção

"Entrar":

Feito isso, ele pedirá uma con�rmação do e-mail, o aceite dos "Termos de Uso" e clicando em "Continuar" ele terminará de

carregar o download. Finalmente, aparecerá a opção de todos os so�wares vinculados e dentre eles, o Photoshop ! Como

baixamos a Creative Cloud optando pelo Photoshop, o programa já terá sua instalação iniciada. Mas, se quisermos optar por

outros aplicativos basta clicar neles e instalar!

O so�ware estará em língua portuguesa, para mudar isso, basta clicarmos no símbolo da engrenagem e selecionarmos

"Preferências":

Dentro das preferências podemos acessar a aba Creative Cloud e alterar de "Português do Brasil" para "English". Nós optamos

pelo inglês pois é a língua mais fácil para encontrar resoluções de dúvidas na internet ou fóruns! Mesmo que uma pessoa não

fale inglês é possível, ainda assim, trabalhar com o so�ware nesse idioma. Alterado isso, basta dar um "Ok"!

Briefing
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Recebemos do cliente um documento com todas as indicações necessárias para o trabalho que devemos desenvolver, isso se

chama Brie�ng. Nesse documento o cliente discrimina quais são as áreas que ele deseja: área de destaque, área sobre, área

blog, área planos e área contato. Cada um desses trechos possui suas respectivas recomendações!

Vamos iniciar?

Primeiro, abrimos o Photoshop que funciona da mesma maneira em Windows e Mac, pois é um so�ware multiplataforma!

Como é a primeira vez que utilizamos o programa aparecerá uma tela de boas vindas, mas como ela não é importante para

nós, podemos fechá-la.

Desejamos especi�car as dimensões do arquivo, portanto, vamos em "File > New File" e abrirá a seguinte janela:

Nesse formulário nós podemos modi�car as medidas para que elas correspondam ao que desejamos!

No campo "Document Type" podemos optar pelo tipo do arquivo, nós selecionamos "web", pois é justamente para essa

linguagem que estamos desenvolvendo! Repare que ao alterar essa opção as dimensões de altura e largura também são

atualizadas! No campo "Artboard Size" nós podemos escolher dentre os vários tipos de dimensões da web, escolhemos "Web

1280, 800". Feita essa escolha falta apenas renomear o arquivo, nós chamaremos ele de "Layout Apeperia". Basta dar um "Ok"

e nosso arquivo será criado! Agora, poderemos trabalhar nessa área, entretanto, observe como ela está:

Antes de tudo, vamos nos livrar de uma informação que não é necessária, movemos o "Layout 1" para cima e deletamos o

"Artboard 1":
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E �caremos com uma tela totalmente quadriculada!

Mas, não queremos que nossa tela �que com esse aspecto e para termos uma tela em branco podemos utilizar a ferramenta

"balde de tinta" ou Paint Bucket Tool

. Se preferir pode utilizar o atalho de apenas pressionar o "G".

Antes de utilizar a ferramenta devemos escolher a cor para pintar. Para isso, basta clicar duas vezes no quadrado que �ca ao

�nal da barra

de ferramentas e abrirá um seletor de cores! Nele podemos arrastar o cursor circular até encontrarmos a cor desejada e no

canto direito, na barra de cores, também poderemos alterar as tonalidades!

Nosso cliente recomendou que usássemos uma cor que tem o nome de "ebebeb". Se preenchermos esse nome no campo

assinalado na imagem acima chegaremos na cor desejada pelo cliente, que é uma tonalidade de cinza claro! Basta dar um

"ok" para fechar a paleta de cores! Podemos escolher cores a partir dos "hexas" - veja o

(https://cursos.alura.com.br/course/photoshop-web-1/section/1/task/10) Exercício 3 .

Voltando ao arquivo! Com a ferramenta "balde de tinta" selecionada, podemos clicar na tela e ela será toda pintada com a

tonalidade escolhida!

Feito isso, podemos retornar ao Brie�ng para saber como prosseguir no projeto. Lembra-se que o desejo do cliente é que

houvessem diversas áreas em nosso site?! O que podemos criar para facilitar o acesso do usuário aos diversos trechos do site?

Podemos observar que no site da Alura (https://www.alura.com.br/), no Medium (https://medium.com/), no Musicdot

(https//www.musicdot.com.br) e no site da Caelum (https://www.caelum.com.br/) existe um padrão: os topos dessas páginas

consistem em um conjunto de logo e informações relevantes. O topo da página, o cabeçalho, chama-se Header.

Antes de montar o Header nós podemos redimensionar a área do nosso arquivo. Pois, será que o arquivo comporta extensão

su�ciente para uma one page app? Para redimensionar o size da imagem vamos em "Image > Image Size" e abrirá uma

janela. A intenção é aumentar nosso arquivo, mas para baixo e não para os lados. Para fazer isso nós devemos alterar apenas

a medida da altura, Height. Mas, repare que o Photoshop possui dimensões pré-de�nidas e conforme alteramos a altura ele

corrige, automaticamente, a largura. Para resolver esse problema basta que nós apertemos no símbolo do "cadeado", que

segura as proporções, para desativar a correção automática!

Dando um "Ok" teremos, por �m, as dimensões corretas em nosso arquivo!

Agora, podemos construir o cabeçalho. Para montar isso nós podemos selecionar uma área do arquivo que equivalerá ao

Header e pintar ela! Com a ferramenta Marquee Tool "> podemos fazer a marcação do espaço que desejamos colorir.

Primeiro, selecionamos a ferramenta, clicamos na tela e arrastamos o cursor até onde deve ser a área do Header. Feita essa

seleção podemos clicar no "Balde de Tinta" e duas vezes nos quadrados para abrir a paleta de cores, escolhemos um tom de

azul. Escolhida a cor podemos dar um "ok" e com o Paint Bucket nós clicamos na área selecionada e ela será pintada!

https://cursos.alura.com.br/course/photoshop-web-1/section/1/task/10
https://www.alura.com.br/
https://medium.com/
https://cursos.alura.com.br/course/photoshop-web-1/task/https//www.musicdot.com.br
https://www.caelum.com.br/
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Vamos acrescentar um texto indicativo de cada uma das áreas do nosso site! Para acrescentar um texto no Photoshop nós

utilizamos a ferramenta Text Tool

. Basta clicar nela ou utilizar o atalho "T". Para começar a escrever clicamos em algum ponto do arquivo e digitamos as

palavras desejadas, nós escreveremos "Sobre".

Para alterar a cor da fonte do texto, selecionamos o que acabamos de escrever e clicamos para abrir a paleta de cores. Nós

optaremos pelo preto! Dando um "Ok" a cor do texto será alterada!

Observação: A cor principal continua sendo a mesma!

A cor principal manda na cor do texto. Entretanto, a cor do texto não manda na cor principal!

Bom, após escrever o "Sobre" falta apenas con�rmar que esse texto deve ser adicionado! Para isso, nós selecionamos o

"check" no canto superior:

Feito isso, prosseguimos adicionando as demais áreas: "Blog", "Planos" e "Contato". Lembrando que devemos con�rmar a

criação dos textos clicando no "check"!

Temos, portanto, um quase header criado!

Salvando no formato adequado

Agora, nosso arquivo contêm um quase Header! Para aproximar os ícones da tela basta dar um zoom, para isso, podemos

manusear a ferramenta da lupa que aparece no topo da página

. Nos aproximando da tela observamos que os textos que acrescentamos ao cabeçalho estão desalinhados.

Para deixar a distribuição mais bonita e adequada utilizaremos a ferramenta de "seleção"

. Essa ferramenta é uma das mais importantes que temos no Photoshop, pois é ela que nos auxiliará a mudar o

posicionamento dos itens e para usá-la podemos digitar simplesmente o atalho "V". Essa ferramenta possui por padrão um

"auto-select" desativado. Para ativar essa con�guração basta ir na barra de ferramenta e dar um "check" em sua caixa:

Na caixa Group nós modi�camos para Layer. Feito isso será mais fácil de selecionar os itens que desejamos e bastará clicar

neles para que possamos alterá-los de local. Selecionando um item, note que aparecem linhas automáticas para nos

orientarmos!

Se as linhas não estiverem aparecendo vá em "View > Show > Smart Guides" e com isso elas aparecerão. Essas marcações são

inteligentes! Observe que, por exemplo, elas mostram a distância entre os objetos.

Claro que centralizar um item de cada vez pode demorar um pouco, portanto, podemos selecionar todos esses itens de uma

única vez. Dessa maneira, para veri�car que os objetos foram selecionados, devemos ativar a caixa do Show Transform

Controls:

Assim, poderemos ver que os itens foram selecionados!



16/12/2019 Photoshop para web I: Aula 1 - Atividade 8 Explicação | Alura - Cursos online de tecnologia

https://cursos.alura.com.br/course/photoshop-web-1/task/20730 8/11

Para selecionar vários objetos de uma única vez basta clicar em um item e, na sequência, pressionar o "Shi�" e seguir

clicando em outros itens! Como queremos alinhar todos os textos e fazer isso com eles juntos, podemos selecioná-los através

da ferramenta de seleção e optar por alguma das maneiras de alinhamento: por cima, pelo meio, pelo centro, por baixo, pela

direita ou pela esquerda. Observe onde essas opções estão localizadas:

Saber que essas possibilidade existem é bacana, mas em nosso caso estamos trabalhando com textos e queremos alinhar eles

pela Base Line, ou seja, a linha de base do texto! Portanto, faz sentido que nós organizemos os textos um por um! Já temos os

textos do menu e falta agora o logo!

Mas, se lembrarmos das referências - o site Medium (https://medium.com/) - veremos que o logo �ca em uma extremidade e

o menu em outra!

Todavia, nós ainda não temos um logo pronto. Ele será �nalizado apenas quando entregarmos a primeira versão do site!

Assim, podemos colocar um logo provisório! Antes, vamos clicar em um dos textos, selecionar "Shi�" e deslocar tudo para a

direita! Poderíamos deixar um quadrado colorido que sinaliza o espaço do logo, entretanto, é mais interessante utilizar uma

imagem mais realista! É a mesma lógica, por exemplo, de escrevermos as áreas do site, não é porque elas podem ser

alteradas depois que nós escreveremos de qualquer maneira!

Vamos, portanto, importar um arquivo, mas no Photoshop não utilizamos essa palavra "importar", o correto é Place, de

colocar. Vamos em "File > Place Embedded". Abrirá uma janela onde poderemos selecionar um documento. Nós

selecionamos um arquivo já pronto e dando um "Place" nós teremos o logo em nosso arquivo:

Basta clicar nisso e arrastar até onde desejamos que esteja esse logo! Vamos acrescentar também um texto com o nome da

Empresa, "Apeperia". Vamos alinhar o nome da empresa com os demais textos e ajeitar também as dimensões do logo, pois

ele está muito grande e queremos que ele seja menor! Caso você tenha feito uma alteração que não tenha sido a desejava,

basta negá-la:

E o logo volta ao normal! Se quiser diminuir o logo mantendo as suas proporções basta clicar no logo e segurar o "Shi�"! E se

segurarmos "Shi�+Alt" ele diminui proporcionalmente para o centro!

Bom, já �zemos diversas modi�cações nesse arquivo, talvez seja um bom momento de salvar o que �zemos! Para salvar é

muito simples, "File > Save" ou "File > Save As", este último serve para criar novas versões. O programa já pré-de�ne o

formato que seria o ".psd", mas esse não é o tipo mais adequado para salvar se quisermos compartilhar o arquivo. O ideal é

salvar como "jpeg". Para isso basta modi�car o formato:

Uma vez que o arquivo é salvo ainda somos questionados de qual o tamanho que desejado!

Layers

Para manusear o arquivo que modi�camos basta abri-lo, entretanto, não podemos trabalhar com a versão jpeg  que

tinhamos salvo, pois, ela está em baixa qualidade e, além disso, não é editável. O arquivo jpeg  assemelha-se a uma folha!

Dessa forma, vamos abrir o arquivo .psd , que é um arquivo próprio para Photoshop.

Abrindo o .psd , arquivo no qual trabalharemos, percebemos algumas características: o arquivo é de ótima qualidade e é

modi�cável! Como desejamos centralizar os ícones, usamos a ferramenta selecionar e clicando em um item e pressionando

https://medium.com/
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"Shi�" podemos escolher todos os demais objetos, inclusive, o fundo! Entretanto, o cabeçalho azul que construímos não é

uma nova parte do nosso arquivo, é como se ele fosse parte do fundo! Dessa forma, é preciso separá-lo do resto criando para

si uma camada!

É preciso homogeinizar o fundo, ou seja, reverter a pintura de azul para a cor cinza clara. Com a ferrameta de Marquee Tool

podemos selecionar o retângulo e com a Paint Bucket pintamos o retângulo da mesma cor do fundo. Para saber qual é a cor

do fundo usamos o Eye Droppertool , ou conta gotas, que ao clicar em determinada cor nos mostra qual é ela:

Feito isso, nós conseguimos homogeinizar o fundo! É preciso, agora, recomeçar o cabeçalho. Mas, vamos criar uma camada

exclusiva para o Header, assim, será possível trabalhá-lo de maneira autônoma! No canto direito da tela é possível observar o

"Painel de Camadas" através dele conseguimos controlar as camadas existentes.

Observe que cada item de texto, corresponde a uma camada diferente, dessa maneira, se você clicar em uma das camadas

verá que o seu respectivo texto terá sido selecionado!

Agora, vamos criar a camada referente ao cabeçalho! Bom selecione com o Marquee Tool o cabeçalho e escolha na barra de

ferramentas superior "Layer > New > Layer...". Abrirá uma janela perguntando o nome dessa nova camada:

Nós nomearemos de Barra do Header  e dando um "Ok" ela terá sido criada!

Perceba que podemos des-selecionar o olho que �ca ao lado da camada "Barra do Header"

que ela desaparecerá da tela! Para torná-la visível mais uma vez basta clicar no olho novamente!

Selecionando a camada do Header, um "Shi�" e clicando nos outros textos, poderemos centralizar o conteúdo do cabeçalho.

Mas, apertando na opção de centralizar veremos que ocorrerá uma sobreposição da camada do cabeçalho, sobre os textos!

As camadas são como folhas, então se uma camada estiver em cima da outra, isso impedirá a visualização de determinadas

partes. Por exemplo, se os textos devem aparecer a cima da caixa azul do Header, as camadas correspondentes aos textos

devem estar distribuidas antes da camada da Header na lista do "Painel de Camadas".

Se usarmos a ferramenta de seleção podemos arrastar o cursor e selecionar todas as Layers do cabeçalho, inclusive, o fundo!

Dessa maneira teremos deslocado tudo, inclusive o fundo, o que não é o desejado. Queremos que a Layer 1 que corresponde

ao fundo permaneça sempre em um lugar! Como queremos proteger essa camada, podemos no Painel de Camadas, tendo ela

selecionada, clicar no cadeado:

Podemos aproveitar para renomear a camada como "Fundo"!

Agora, ao selecionarmos as camadas e mover-las, o fundo não será mais deslocado!

O Layer é algo bom pois podemos editar cada objeto separadamente dentro do arquivo, dessa maneria nós podemos alterar

cada objeto individualmente. Assim, não precisamos nos preocupar muito se as cores e objetos devam ser alterados pois eles

já estão distribuidos de maneiras separadas. Outro ponto que faz diferença inclusive para organização, é nomear os itens de

maneira a conseguirmos identi�car-los facilmente.

Mascarando

Já conseguimos separar os objetos do site utilizando Layers!
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Agora, queremos acrescentar uma listra, igual a que aparece na referência do site da Alura (https://www.alura.com.br/). Para

fazer isso basta selecionar as Layers correspondentes ao cabeçalho e deslocamos elas para baixo, deixando um espaço em

branco onde colocaremos a linha colorida. Usando a Marquee Tool selecionamos esse espaço e criamos uma Layer

correspondente a ele! Para criar uma camada clicamos no seguinte botão:

Nós nomeares a camada de "Barrinha do Header" e para alterar a sua nomenclatura basta clicar duas vezes em cima do

nome.

Com a Paint Bucket nós podemos selecionar uma cor e pintar a listra que criamos! E, vamos deslocar a barrinha que

acabamos de criar para baixo do cabeçalho, para isso basta alterar sua ordem no Painel de Camadas.

Nosso cliente deseja, ainda, uma foto de destaque, algumas informações e um botão de venda que chame a atenção do

usuário. E, essa parte do topo, é justamente o que o cliente observa primeiro quando acessa o site! Vamos começar por

anexar a imagem, para tanto é preciso importar ela. Para isso, vamos em "File > Place Linked... " e escolhemos a imagem.

Deslocamos a camada correspondente dessa imagem para baixo de todas as outras no "Painel de Camadas".

Observe como �cou:

Repare que a imagem está muito grande em relação ao restante do site e, portanto, podemos recortá-la para que �que

menor! Entretanto, se tentassemos deletar essa imagem seríamos avisados de que não é possível apagar uma smart object:

Um smart object não é diretamente editável! Por isso não podemos deletar a imagem. Podemos transformar esse objeto em

algo que podemos modi�car? Sim! Nós podemos selecionar a camada que corresponde a imagem no painel e clicando nela

com o botão direito podemos selecionar a opção "Rasterize Layer" que é tornar o Layer editável! Feito isso nós podemos

deletar a parte da imagem que selecionamos para editar!

Será, entretanto, que é mais inteligente apagar a imagem? Talvez apenas dobrá-la seja mais inteligente! O que corresponde,

no Photoshop, a ação de dobrar?

Vamos apertar duas vezes o "Ctrl+Z" para voltar as etapas de corte e de Rasterize layer para que possamos dobrar a imagem!

A ferramenta que podemos utilizar é a Mask

. Selecionando essa ferramenta não podemos aplicá-la diretamente pois, a única coisa que ganharemos fazendo isso é ter um

quadrado todo pintado em nossa imagem. Podemos alterar as opções avançadas da ferramenta para Path:

https://www.alura.com.br/
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Dessa forma, selecionamos com a ferramenta o espaço que desejamos que permaneça visível e clicando em "Mask" nas

opções de ferramenta teremos, por �m, o item dobrado!

Caso você tenha feito algo que deseja modi�car, pode utilizar as opções de edição da Mask que �cam em baixo do menu!

Vamos observar a ferramenta do Cursor:

Com o cursor preto nós movemos a Mask inteiramente e mesmo tirando ela dos limites da página ela continua existindo para

fora das bordas!

O mouse branco serve para editar cada um dos pontos da Mask, individualmente, podemos puxá-los, mové-los, aumentar,

etc. Inclusive, note que no Painel de Camadas existe uma imagem que sinaliza como essa camada está e nela dintinguimos as

partes que estão mascaradas das que não estão:

Resumindo

Até o momento trabalhamos diversos aspectos interessantes em nosso site:

Incluimos um Header;

Importamos um logo;

Criamos uma barra;

Importamos uma imagem e a modi�camos utilizando uma Mask;

Além de termos feito tudo isso aprendemos sobre algumas ferramentas básicas!


